990 Idle Problem

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by skidxr, Aug 11, 2013.

  1. skidxr

    skidxr Excuses

    Joined:
    Mar 7, 2006
    Oddometer:
    434
    Location:
    Durango, Colorado
    Hey all. My 2007 990 Adv will not idle. Just out of the blue when I come to a stop it just dies. I haven't done anything to troubleshoot except connect to TuneECU to check for any error codes and there are none. Where should I begin to troubleshoot this? :cry
    #1
  2. bikyto

    bikyto Dans le doute...gaz!

    Joined:
    Jun 15, 2009
    Oddometer:
    2,341
    Location:
    Northern Cali
    In tuneecu, with a warm engine but not running, check your tps.
    Anything below 0.58v or above 0.64 could lead to idling issue.
    Most target 0.60v as ideal tps.
    #2
  3. Midlife

    Midlife HalFassed

    Joined:
    Mar 28, 2006
    Oddometer:
    69
    Location:
    Canton GA
    Clean filter? How old are the plugs?
    #3
  4. Mother_trucker69

    Mother_trucker69 Adventurer

    Joined:
    May 5, 2011
    Oddometer:
    16
    Location:
    When home Visalia Ca
    Check fuel filter.
    #4
  5. Zuber

    Zuber Zoob

    Joined:
    Sep 28, 2004
    Oddometer:
    3,416
    Location:
    Main Street, Shedd, Oregon
    Check the throttle cables, if too tight, the ECU will not pick up the idle. You are starting it with a closed throttle? If you crack the throttle, the auto-idle will not take over.

    Then +2 on the TPS sensor.

    -2 on fuel filters, they usually don't show problems on idle.

    So the count sofar is 2 for TPS, 1 for cables and 0 for filters. Any one of us is not as stupid as all of us.
    #5
    Parx400 likes this.
  6. skidxr

    skidxr Excuses

    Joined:
    Mar 7, 2006
    Oddometer:
    434
    Location:
    Durango, Colorado
    Thanks for the replies.

    So I connected it up to TuneECU again after riding it around for a bit. I had the ignition turned on but the engine is not running and the headlight fuse is out. On the test screen under TPS it reads 0.71

    I don't know enough about TuneECU to know if I did that right.

    When started it today after sitting for a couple days it started just fine and idled fine while in neutral. It did not die on me but the idle dropped down to just below 1k after I popped it into gear and rolled forward a few feet and then stopped. Then it will slowly increase up to about 1400k.

    Thanks again...
    #6
  7. skidxr

    skidxr Excuses

    Joined:
    Mar 7, 2006
    Oddometer:
    434
    Location:
    Durango, Colorado
    I adjusted to TPS and all is good with the idle now.

    Thank you all for the help. I couldn't own this bike if not for this forum !!!
    #7
  8. bikyto

    bikyto Dans le doute...gaz!

    Joined:
    Jun 15, 2009
    Oddometer:
    2,341
    Location:
    Northern Cali
    :clap:freaky
    #8