Auxiliary LED Lights - MondoMotos

Discussion in 'Vendors' started by The Toad, Dec 27, 2011.

  1. Wisconsinkris

    Wisconsinkris Been here awhile

    Joined:
    Sep 3, 2012
    Oddometer:
    117
    Location:
    SE Wisconsin
    Headlight only on low

    [​IMG]


    Both headlight, on low with mondos

    [​IMG]
  2. goodcat8

    goodcat8 I can pass this guy.....

    Joined:
    Feb 19, 2008
    Oddometer:
    3,066
    Location:
    Los Angeles
    What's that weird white stuff on the ground?
  3. paramedic

    paramedic n00b

    Joined:
    Feb 8, 2011
    Oddometer:
    2
    THANK YOU very much Wisconsinkris!!!!
  4. playinatwork

    playinatwork Been here awhile

    Joined:
    Jul 30, 2010
    Oddometer:
    177
    Location:
    Jacksonville FL
    Brian,
    One of my lights is on the fritz already. It will come on for a few minutes them flicker and eventually quit working completely. I removed it from the bike and tried it on my inverter with the same results.
  5. The Toad

    The Toad on the go since...wait. where am I ?

    Joined:
    Oct 6, 2007
    Oddometer:
    1,256
    Location:
    Location, Location.
    Sorry youre having a problem. Most likely its the connector. In either case, send an email to Kris - info@mondomotos.com and she can help you out.

    thanks,
    -Brian
  6. The Toad

    The Toad on the go since...wait. where am I ?

    Joined:
    Oct 6, 2007
    Oddometer:
    1,256
    Location:
    Location, Location.
    Many thanks for posting up the pics.

    But thats not really snow on the ground already is it????

    -Brian
  7. The Toad

    The Toad on the go since...wait. where am I ?

    Joined:
    Oct 6, 2007
    Oddometer:
    1,256
    Location:
    Location, Location.
    Scott,

    thanks for the review. Glad youre happy with them,


    -Brian
  8. Wisconsinkris

    Wisconsinkris Been here awhile

    Joined:
    Sep 3, 2012
    Oddometer:
    117
    Location:
    SE Wisconsin
    No, no snow yet. Just taken when there was snow last season.

    Sorry if I frightened anyone !



  9. markgsnw

    markgsnw WTF?

    Joined:
    Jan 15, 2002
    Oddometer:
    3,659
    Location:
    Portland, Oregon US
    I've just ordered a set of MM10's, looking forward to them...deer season is upon us.
  10. markgsnw

    markgsnw WTF?

    Joined:
    Jan 15, 2002
    Oddometer:
    3,659
    Location:
    Portland, Oregon US
    received the light set and started playing with them this past weekend. Very very impressive build quality and materials quality. I've done several sets of lights before, these really are top notch. Astonishing for the price.


    I just fired them up in the garage last night, these suckers are bright. Looking forward to getting out on the road with them.



    Thanks for a quality product at a very affordable price!
  11. The Toad

    The Toad on the go since...wait. where am I ?

    Joined:
    Oct 6, 2007
    Oddometer:
    1,256
    Location:
    Location, Location.

    Thanks for the feedback.

    Post up some pics if you get an opportunity. Love to see them on the Norge (assuming thats where the intended recipient).


    -Brian
  12. playinatwork

    playinatwork Been here awhile

    Joined:
    Jul 30, 2010
    Oddometer:
    177
    Location:
    Jacksonville FL
    As you can tell from my message above that I had a problem with a light that I got from Toad. Well you only truly find out how good a vendor is when things go sideways. I now have 2 working lights and highly recommend Toad and his products. I couldn't have asked for better customer service. Thanks Kris and Brian.
  13. hizzo3

    hizzo3 Adventurer

    Joined:
    May 7, 2012
    Oddometer:
    99
    I skimmed through the thread and didn't see anything but the idea of a yellow filter. Anything more on this?

    Sent by my NSA monitored Verizon Galaxy Nexus.
  14. The Toad

    The Toad on the go since...wait. where am I ?

    Joined:
    Oct 6, 2007
    Oddometer:
    1,256
    Location:
    Location, Location.
    Thanks for taking the time to post a follow up.



    -Brian
  15. The Toad

    The Toad on the go since...wait. where am I ?

    Joined:
    Oct 6, 2007
    Oddometer:
    1,256
    Location:
    Location, Location.
    Hoping to make some time over the holidays to explore this a little more. Will post up here first if it comes to life.



    thanks,
    -Brian
  16. markgsnw

    markgsnw WTF?

    Joined:
    Jan 15, 2002
    Oddometer:
    3,659
    Location:
    Portland, Oregon US
    I think they look pretty classy on the Norge:




    [​IMG]
  17. Ridingfl

    Ridingfl n00b

    Joined:
    Sep 17, 2013
    Oddometer:
    2
    I have a J&M CB radio on my bike, and some other electronics such as a Garmin. Has anybody used these on their bikes with a CB radio. Any problems with RF interference from the LED's?
  18. jerbelgium

    jerbelgium Adventurer

    Joined:
    Oct 3, 2008
    Oddometer:
    46
    need some help top lead the cables from the battery to the ligths on my ktm adventure 990? where to put the fuse etc.

    any ideas or examples?

    thanks
  19. headshrink

    headshrink Adventurer

    Joined:
    May 10, 2013
    Oddometer:
    62
    Maybe I'm not understanding your question, but there is an in-line fuse in the included wiring harness.
  20. jerbelgium

    jerbelgium Adventurer

    Joined:
    Oct 3, 2008
    Oddometer:
    46
    thanks,

    sorry, I mean, how to install the cables from my battery to the headlights? the battery of the ktm is on the bottom, and the fuse on the cable is more to the side of the battery then to the lights side, and there is no room to mount them somewhere to something