BMW Navigator VI and Media Player- Garmin Response Jun 12, 2017

Discussion in 'Mapping & Navigation' started by Dakarider, Jun 12, 2017.

  1. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,561
    Location:
    alabama
    honestly, is easier my way. doesn't really matter if it's a $900 device that is causing problems or a $3 USB cord, eliminating the error prone part makes it all much better.
    #41
  2. Fosters

    Fosters Adventurer

    Joined:
    Nov 6, 2010
    Oddometer:
    60
    Location:
    florida
    They sure are dragging their feet in "rushing" out an update...
    #42
  3. pldj1000

    pldj1000 n00b

    Joined:
    Jan 5, 2014
    Oddometer:
    6
    Location:
    Lancaster County, PA
    Not to reopen this thread but... Im still annoyed...

    Still no change on the Nav VI issue... I've read all the threads on the net, tried EVERTHING and filed issue with Garmin. Hopefully they will fix this soon.

    I bought the Nav VI a few months ago with the release and have had no luck either. (iPhone 6 / Sena 20s / GPS Prepped 12GSA) I even picked up a SRC System Pro for my C3 Pro with no luck and even tried a different iPhone. Occasionally i'll be riding along and it work as advertised but it is so inconsistent and hard to replicate. I am disappointed as I bought the GPS for the music feature so i can keep my phone safely in my pocket or bag.
    #43
    GoPlaces and Fosters like this.
  4. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,561
    Location:
    alabama

    rugged phone, under $100, plays music all day, does GPS great too. put it on the bars and don't mess with the annoyances again.
    #44
  5. pldj1000

    pldj1000 n00b

    Joined:
    Jan 5, 2014
    Oddometer:
    6
    Location:
    Lancaster County, PA
    ohgood, you are very right but...

    You know the quote... the one about "too far to turn back now..."

    Got too much money invested. Cheaper to keep going forward this time and learn from my mistakes. :)

    Problem solved for my next bike = Paper maps and me singing in my helmet.
    #45
  6. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,561
    Location:
    alabama

    sell the crap that doesn't work
    buy crap that does
    #46
  7. GoPlaces

    GoPlaces IG:ADVwxyz

    Joined:
    Aug 11, 2015
    Oddometer:
    344
    Location:
    Vancouver
    I fixed my issue with it... I bought a 1200 Rallye with TFT screen and On Board Computer Pro- it allows me to deal with my music... : )
    #47
    Fosters likes this.
  8. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    Nav VI software update, v. 4.90, was just released within the last two days. It promises to fix a number of issues, including playing/streaming music.
    #48
    GoPlaces and Fosters like this.
  9. GoPlaces

    GoPlaces IG:ADVwxyz

    Joined:
    Aug 11, 2015
    Oddometer:
    344
    Location:
    Vancouver
    Awesome- it just saved me $31k CDN! Gonna return the bike tomorrow! ; )
    #49
  10. scfrank

    scfrank Old farts riding club.

    Joined:
    Oct 27, 2005
    Oddometer:
    17,666
    Location:
    Upstate SC
    Any experiences since the update? I’m having problems but don’t know if it’s the “standard” problem people complain about. Have Sena linked to Garmin. iPhone linked to Garmin. The media player comes up and shows me albums. When I try to play something it plays 5-10 seconds and then skips to another song, just keeps repeating this. This is in shuffle mode.

    Are there secrets? Special pairing modes? Do I have to pair phone to Sena?

    I’ve updated to 4.9.
    #50