BMW Navigator VI (GARMIN) Issue *HELP*

Discussion in 'Mapping & Navigation' started by EnduroAmerica, Jun 29, 2017.

  1. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    I purchased the new Garmin BMW Navigator VI when I got the bike about 2 weeks ago. I cannot seem to get the GPS to connect to my computer. I have tried power-cycling both, different cables etc... The USB on the computer will not even recognize it. It charges just fine when plugged into the computer but does not allow me to access anything because it is not recognized. Anything I should be doing differently?
    It makes no difference if the GPS is on or off and yes I have the latest version of the Garmin software. Edit: Multiple USB ports tried on multiple computers.
    I was trying to make sure the GPS didn't have any available updates and I wanted to load my music onto it so that I can control it with the handlebar jog.
    HELP!
    #1
  2. LowOnFuel

    LowOnFuel In the crapper

    Joined:
    Oct 2, 2007
    Oddometer:
    1,376
    Location:
    Pacific Northwest
    Did you try a different USB port on the computer?
    #2
  3. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    I've tried all 3 on this computer and 2 on the other computer.
    #3
  4. ObiJohn

    ObiJohn Screaming Banshee

    Joined:
    Jul 22, 2010
    Oddometer:
    937
    Location:
    Seattle suburbia
    Are you using the supplied Garmin cable? If so, have you tried s known good USB cable? Do you have Garmin Connect installed on your computer?

    Windows or Mac?
    #4
  5. kiwi_outdoors

    kiwi_outdoors Been here awhile

    Joined:
    Nov 16, 2007
    Oddometer:
    234
    Location:
    Oakland, CA
    first try Garmin Express to update the device software, before you use Basecamp (or whatever)
    #5
    Tork likes this.
  6. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    Yes supplied garmin cable as well as another cable. Then I plugged my sena communicator into the same cable and turned it on, works perfect and connects to the computer.
    New windows 10 PC.
    Latest version of Garmin connect is on the PC.
    I'm beginning to think it may be the GPS.
    #6
  7. hammick

    hammick Long timer

    Joined:
    Dec 2, 2007
    Oddometer:
    3,665
    Location:
    Kansas City, Missouri
    Download the latest version of Garmin Express. Might be a driver issue.
    #7
  8. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    Thank you guys for the responses!
    I did that as well. Uninstalled it when it didn't work and then downloaded again. Still nothing.
    At the very least when it is plugged into the computer I should get the device folder to pop up in the my computer tab. Nothing there either.
    #8
  9. AZgman

    AZgman Addicted to curves

    Joined:
    Jan 1, 2014
    Oddometer:
    198
    Location:
    Casa Grande AZ
    My Nav V can be finicky sometimes as well. Try turning on the Nav and then connect the USB cable to the computer. You should see a pop up on your computer that asks what you want to do with the new device. Select the "open files" option.
    #9
  10. ErikMotoMan

    ErikMotoMan Airbag crash survivor!

    Joined:
    Apr 4, 2014
    Oddometer:
    4,435
    Location:
    In Motorcycle Heaven since 1990 - So Cal!
    Me thinx you've done everything. Defective unit. Return it to the dealer.
    #10
    EnduroAmerica likes this.
  11. hammick

    hammick Long timer

    Joined:
    Dec 2, 2007
    Oddometer:
    3,665
    Location:
    Kansas City, Missouri
    Try a different computer before you return it.
    #11
  12. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    Nothing at all. Even tried turning the computer off, then on. All while I was removing the battery from the GPS to reset it completely. Then plugged the USB cable to the computer, the navigation turns on automatically when plugged into the USB cord when it is plugged into the computer. I've tried it with it being on prior to this as well.
    Nothing. Uggggggg.
    At least it charges properly.
    #12
  13. M1kefries

    M1kefries Been here awhile

    Joined:
    Dec 3, 2013
    Oddometer:
    151
    Location:
    Hampton Roads VA
    What does the screen on the Garmin show? I know with the Nav V when plugging into my Mac it comes up with a file and cable graphic which lets me know the device recognizes that it is plugged into a computer.
    #13
  14. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    Just shows the main screen with map or where to options.
    I an going to try and call garmin today.
    #14
  15. M1kefries

    M1kefries Been here awhile

    Joined:
    Dec 3, 2013
    Oddometer:
    151
    Location:
    Hampton Roads VA
    If you power the Nav VI off and then plug it into the computer what does it do? It should power on and then go to that file cable graphic. If not then it is definitely not recognizing the computer connect. Calling Garmin tech support would be the next best step IMHO.
    #15
  16. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    UPDATE:
    Called Garmin this morning. They referred me to Windows and gave me the Windows 10 site that should have had the supplied fix: didn't work. Imagine that.
    Further experimentation after digging an old Windows 7 Surface out of the closet showed that it is indeed a Windows 10 driver issue but no way to delete the driver out of my 10 machine as it does not exist?? I plugged it into thew Windows 7 machine and it popped the folder up immediately. NOW - Garmin Express will not run on my Windows 7 Machine. Seriously...
    Getting agitated, I now loaded the music onto a micro SD card from the 10 machine and plugged it into the Navigator VI. Nothing. It doesn't recognize the SD card with music on it.
    Now that I can plug the GPS into the Windows 7 computer it recognized the GPS and the SD card and I am trying to transfer the music from the SD card directly to the GPS folder into a folder that I named MUSIC.
    I'll provide an update if this works or not. This process should not be this difficult. Either way I still cannot update the maps...
    #16
  17. AdvMoto18

    AdvMoto18 NORDO

    Joined:
    Jun 17, 2013
    Oddometer:
    1,916
    Location:
    Where it's 5PM!
    One of many reasons I gave up on MS OS years ago; so much frustration! Simply too many programs, apps and devices I use had conflicts with Windows (regardless of the version) and simply did not/would not play nice. Since I migrated to Mac 8 years ago, not a single issue.

    The downside to MacOS and IOS, you pretty much have to drink the Apple Kool Aide and get their family of devices to take full advantage of all the playful features. But, at least third party devices play nicely and that's about all I can ask for.

    Good luck and I hope you get the issue sorted out soonest.
    #17
    khones likes this.
  18. wonderings

    wonderings Long timer

    Joined:
    Jan 26, 2007
    Oddometer:
    1,576
    Location:
    Kitchener, Ontario
    There is a mode you have to turn on in some secret developer menu, I had this problem before. No drivers or anything should be needed for Mac or Windows to see it. Should load up like a connected SD card.

    This is what support told me last year and it did work:

    To put an MTP device into mass storage mode:

    1. Touch Volume
    2. Touch and hold the upper right corner of the screen
    3. Touch MTP Settings (you may need to scroll down)
      • Touch Configuration and Settings on some devices before getting the option for MTP Settings
    4. Touch Mass Storage Single Session
    5. Touch Save
    #18
    scfrank likes this.
  19. EnduroAmerica

    EnduroAmerica Worldwide Adventure Guide

    Joined:
    Feb 22, 2012
    Oddometer:
    560
    Location:
    EARTH
    Tried the secret menu and switched to mass storage with the Garmin report on the phone. No luck.
    #19
  20. DRTBYK

    DRTBYK All Things GPS

    Joined:
    Mar 26, 2003
    Oddometer:
    7,736
    Location:
    47°50′15.8″N, 119°56′21.9″W
    Can't fix the Win 10 problem. Regarding your SDCard or Music not being seen by the NAV6, are you music files in MP3 format? If so, then your SDCard is improperly formatted. The SDCard needs to be formatted as a FAT32 storage device. Windows native file system can not do that. You will need this free application from SDCard.org. Once you SDCard is properly formatted and your music is in MP3 format, the NAV6 should have no problem finding your music as long as the Media Player App is set to MP3 as the source.
    #20
    EnduroAmerica and JR356 like this.