BMW Navigator VI Info Now On BMW Motorrad Website

Discussion in 'Mapping & Navigation' started by marco polo, Jan 24, 2017.

  1. Tommy Gunn

    Tommy Gunn Adventurer

    Joined:
    Jan 26, 2007
    Oddometer:
    99
    Location:
    N. GA
    Got the updated 2018.20 Map version up and running on my Nav VI with no problem.
    Not so with the ZUMO 665LM. The ZUMO no longer has the capacity to support all of North America as I have been accustomed to. So those with major cross country trips will be hindered as you have to choose which parts of North America you want loaded on your ZUMO. Or get a new GPS I suppose.
  2. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,561
    Location:
    alabama
    How about just use the "old" maps that still work fine ? You might find 1/2% of the entire area covered has actually changed.
    Yukon Ho! likes this.
  3. Tommy Gunn

    Tommy Gunn Adventurer

    Joined:
    Jan 26, 2007
    Oddometer:
    99
    Location:
    N. GA
    Yup. I would say you are correct and that would work.
    Just saying, if you update, you're gonna lose geography on older units like the ZUMO 665 and once you update, I'm not aware of a way to go back.
  4. Geordietraveller

    Geordietraveller On the road to nowhere...

    Joined:
    Oct 25, 2004
    Oddometer:
    164
    Location:
    Victoria,BC
    Can anyone tell me how to disable the advanced weather alerts? I'm getting crazy "Gales" and "Small craft alert"!!? warnings constantly. They seem to have no bearing on reality. I've shut the Nav VI down and searched for a way to disable the weather but other than disabling the entire Smartphone link app I'm at a loss.


    2017 R1200GS
  5. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    That's an issue a number of people have raised with regard to the Nav V, and now, the Nav VI. I don't recall anyone having an answer, short of not opening the Smart Link App on your phone. I don't know whether anyone has discovered how to delete/disable the weather subscription from the App. The problem with the weather alerts, presumably, is that they come from the station(airport, I believe) that's providing the weather info, and that may not be very close to where you actually are. I also get small craft warnings all the time (I'm right on the Potomac River, but an hour west of the ocean).
  6. Geordietraveller

    Geordietraveller On the road to nowhere...

    Joined:
    Oct 25, 2004
    Oddometer:
    164
    Location:
    Victoria,BC
    Well I guess that's some conciliation! It's been driving me mad - at least I can just switch off the app.



    2017 R1200GS
    Fosters likes this.
  7. DRTBYK

    DRTBYK All Things GPS

    Joined:
    Mar 26, 2003
    Oddometer:
    7,731
    Location:
    47°50′15.8″N, 119°56′21.9″W
    The only way to not get these is to not have Weather Service or not connect to Smartphone Link App. I do hope you all have communicated with BMW and Garmin as to the inadequacies of this Weather Service from MyCast - a Garmin subsidiary. Even Garmin no longer uses this service with the Automobile devices - they now have a Accuweather App linkage. BMW probably didn't want to pay for the Accuweather Service (speculation on my part).
    Fosters likes this.
  8. Yukon Ho!

    Yukon Ho! We can go ANYWHERE!

    Joined:
    Oct 2, 2011
    Oddometer:
    234
    Location:
    Seattle/Mazama
    When I bought Garmin's tire pressure sensors (valve caps) I could swear the BMW Navigator was listed among the Compatible Devices. Alas there's no Tire Pressure app on the Nav Vi, and no way to add apps. (Yes I know the Nav shows tire pressure from BMW's own tire sensors via the the bike's LIN/CAN bus and cradle. Don't have BMW's TPM.) Anybody know a secret way to enable this? Seems purely a firmware/config thing, I doubt the Nav lacks the ANT circuitry.
  9. Geordietraveller

    Geordietraveller On the road to nowhere...

    Joined:
    Oct 25, 2004
    Oddometer:
    164
    Location:
    Victoria,BC
    Actually, I'm still getting Gale and storm warnings even after I close the app. I ended up just putting the Nav VI into "mute" to try and silent the alerts but it still cut into intercom conversations to tell me about imaginary weather! Aaarrgghhh!


    2017 R1200GS
  10. DRTBYK

    DRTBYK All Things GPS

    Joined:
    Mar 26, 2003
    Oddometer:
    7,731
    Location:
    47°50′15.8″N, 119°56′21.9″W
    You might want to make sure the Smart Link App is not still running in the background. There is no way the NAV6 can receive Weather Alerts without the App running on your Smartphone.
  11. DRTBYK

    DRTBYK All Things GPS

    Joined:
    Mar 26, 2003
    Oddometer:
    7,731
    Location:
    47°50′15.8″N, 119°56′21.9″W
    I don't quite understand what leads you to believe that the NAV5/6 have ANT+ radios? They have never shown on the "Compatible Devices" page for the TPS product. The NAV5/6 do not have ANT+ nor would BMW be willing to pay for such hardware when they don't need it to show TP.
  12. Yukon Ho!

    Yukon Ho! We can go ANYWHERE!

    Joined:
    Oct 2, 2011
    Oddometer:
    234
    Location:
    Seattle/Mazama
    I'm speculating the Zumo 595 and Nav VI have identical hardware. At these scales (50x more Zumos than Navs) you pay to remove stuff, no win, just disable it in firmware. Also CE certification etc etc.
  13. Geordietraveller

    Geordietraveller On the road to nowhere...

    Joined:
    Oct 25, 2004
    Oddometer:
    164
    Location:
    Victoria,BC
    Ok. So I er "might" have turned the app back on and forgot...
    I'll give it another shot today. Is there anything useful that I'm missing out on by keeping it off? Traffic?


    Sent from my iPhone using Tapatalk Pro
  14. Geordietraveller

    Geordietraveller On the road to nowhere...

    Joined:
    Oct 25, 2004
    Oddometer:
    164
    Location:
    Victoria,BC
    Well - believe it or not but I still got the warnings today with the phone powered off!


    2017 R1200GS
  15. ropegun

    ropegun Go Dawgs!

    Joined:
    Jul 22, 2005
    Oddometer:
    50
    Location:
    Ogden, Utah
    Doubt that the update is going to fix the media player issue, otherwise I would have been contacted directly by Garmin (or so they stated). Nonetheless, I'm downloading the update with the optimism of a child.
    bnsutton likes this.
  16. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    What update are you referring to? Do you mean the recently-released quarterly map update, or is there a software/firmware update to the Nav VI itself? If no update to Nav VI firmware, you're absolutely right that a map update (or update to Garmin Express) will have no affect whatsoever on the operation of the Media Player.
  17. shuravko

    shuravko n00b

    Joined:
    May 31, 2017
    Oddometer:
    2
    Looks like I found touchscreen bug in all new Nav VI that I've seen so far.

    1) turn on qwerty keyboard (it's just more obvious)
    2) try to type in search or any other place letter close to edge of a keyboard. The best is "1" or "l".
    3) when you type same letter multiple times, once in a while device register clicks in other part of screen. Like other side of keyboard.
    4) it happens everywhere resulting in sudden map movements when panning or selecting menu lines when scrolling with buttons, or just plain typos (it can be every 10th to 20th click)

    Tried 3 devices in 3 different dealerships with same result. Calibrating doesn't help. In service mode when testing touchscreen error clicks goes to the diagonal line from top right to bottom left corner.

    Do you think it's software fixable?
  18. DRTBYK

    DRTBYK All Things GPS

    Joined:
    Mar 26, 2003
    Oddometer:
    7,731
    Location:
    47°50′15.8″N, 119°56′21.9″W
    If you report it it can be...:scratch. Although, I doubt that very many folks will ever find this bug or figure out it's repeatability. Report it anyway.
  19. shuravko

    shuravko n00b

    Joined:
    May 31, 2017
    Oddometer:
    2
    Do you, gentlemen, have same issue? Couldn't believe they let such bug pass QC.
  20. SydneyPom

    SydneyPom Adventurer

    Joined:
    Apr 27, 2014
    Oddometer:
    14
    Morning all, Navigator VI in a GPS Prep cradle on my new Rallye X...

    Loving it so far since picking up and playing and riding all afternoon. But the "My Motorcycle" bits don't seem to work? Wonderwheel works, power works... any ideas from the brains trust?