BMW Zumo "can't unlock maps" error

Discussion in 'Mapping & Navigation' started by TexasMule, Jun 22, 2008.

  1. TexasMule

    TexasMule Float away ya fairy...

    Joined:
    Jul 27, 2001
    Oddometer:
    3,911
    Location:
    North of BIG D
    Mulewife has been having fits with her BMW Zumo that came with her K12GT.

    She keeps getting an error message "can't unlock maps" on her Zumo.

    We're getting ready to go to Canada, and she's trying to upload some routes and the GPS keeps coming back with the above error message.

    All the maps are already downloaded, so it's frustrating when she gets this message.

    Anybody got any ideas as to this error message?

    I think I'll keep my 276C for a while longer. :deal
    #1
  2. JR356

    JR356 Long timer

    Joined:
    May 4, 2005
    Oddometer:
    4,108
    Location:
    Way out West
    Have heard from other posts here,that in this situation,you need to reload the maps.

    JR356
    #2
  3. TexasMule

    TexasMule Float away ya fairy...

    Joined:
    Jul 27, 2001
    Oddometer:
    3,911
    Location:
    North of BIG D
    She just re-loaded the maps, got the same error message.

    Will try re-loading again.
    #3
  4. pckopp

    pckopp Aged Adventurer

    Joined:
    Feb 25, 2003
    Oddometer:
    1,312
    Location:
    Seattle, WA
    Do you have the same version of City Nav on your PC as your Zumo? Maybe you upgraded one and not the other? Just a quess.

    That's an odd message since the pre-loaded maps in the Zumo are already unlocked.
    #4
  5. OleGrumpy

    OleGrumpy TFM/ODS Proficient

    Joined:
    Feb 1, 2006
    Oddometer:
    12,541
    Location:
    Mountains of Virginia
    I just bought a new zumo 450 and right from the box I got "can't unlock maps." I found that I can upload routes but not maps.

    I think I'll drop back to my old 2610!
    #5
  6. pckopp

    pckopp Aged Adventurer

    Joined:
    Feb 25, 2003
    Oddometer:
    1,312
    Location:
    Seattle, WA
    What maps are you trying to upload? The Zumo models all come with City Nav pre-loaded. You don't need to upload maps.

    Confused.
    #6
  7. xlcr

    xlcr Stop being a dick, dick.

    Joined:
    Feb 27, 2004
    Oddometer:
    4,895
    Location:
    SoCal
    Is she saving the routes to an SD card and then inserting the card in the Zumo? If your PC writes map segments to an SD card and those segments are unlocked for only your 276, the Zumo will deny access to those segments when it reads the card. If you write directly to the Zumo, MS should warn you that the segments will be unuseable and ask for confirmation before it sends the maps.

    You should be able to deselect maps when you "Send to GPS".
    #7
  8. TexasMule

    TexasMule Float away ya fairy...

    Joined:
    Jul 27, 2001
    Oddometer:
    3,911
    Location:
    North of BIG D
    I think she was saving the routes to the SD card. I removed the maps from the SD card, and she just sent the routes and waypoints, but she still gets the same message.

    She's going to call Garmin and get to the bottom of this (he says hopefully).
    #8
  9. walrond

    walrond Earth Wanderer

    Joined:
    May 24, 2005
    Oddometer:
    1,067
    Location:
    Leander, TX - R1150GS
    Did your Zumo come with a City Select Nav DVD? If so did you install that DVD on your computer? I suspect that the maps on your PC are not associated with your Zumo and you will be unable to use information derived from the mapsets that are on your PC until you do.
    #9
  10. xlcr

    xlcr Stop being a dick, dick.

    Joined:
    Feb 27, 2004
    Oddometer:
    4,895
    Location:
    SoCal

    Does she get the message when there's no SD card in the Zumo? There may be a wayward map segment on the internal flash drive.
    #10
  11. BurnieM

    BurnieM Nipple boy

    Joined:
    Sep 24, 2003
    Oddometer:
    4,104
    Location:
    Sydney, Australia
    Connect your zumo to your pc

    Go to the garmin folder

    Delete gmapsupp.img only!

    Disconnect and let the zumo restart
    .
    #11
  12. TexasMule

    TexasMule Float away ya fairy...

    Joined:
    Jul 27, 2001
    Oddometer:
    3,911
    Location:
    North of BIG D
    I deleted that file off her SD card, but still didn't fix the "can't unlock maps" error message.

    We'll try it with the Zumo connected to the PC.
    #12
  13. TexasMule

    TexasMule Float away ya fairy...

    Joined:
    Jul 27, 2001
    Oddometer:
    3,911
    Location:
    North of BIG D
    As MuleWife just e-mailed me...

    THAT IS A WINNER!

    Fixed the problem.

    Thanks.
    #13
  14. BurnieM

    BurnieM Nipple boy

    Joined:
    Sep 24, 2003
    Oddometer:
    4,104
    Location:
    Sydney, Australia
    Problem was when you copied some waypoints or routes across to the zumo you inadvertantly had a map segment selected and the map box ticked and you copied over a map that was not unlocked for your zumo.

    gmapsupp.img is the map file that MapSource on the PC creates when it copies maps.
    The preloaded factory map file has a different name

    Cheers,
    Burnie M
    #14
  15. TexasMule

    TexasMule Float away ya fairy...

    Joined:
    Jul 27, 2001
    Oddometer:
    3,911
    Location:
    North of BIG D
    Excellent explanation mate.

    Thanks again. :thumb
    #15
  16. chopped58

    chopped58 Long timer

    Joined:
    Jul 19, 2006
    Oddometer:
    1,392
    Location:
    L.I. NY
    Found this on a google search, and it worked for me as well...
    #16
  17. cwadej

    cwadej Keeper of the truth

    Joined:
    May 20, 2008
    Oddometer:
    936
    Location:
    Arlington, TX
    Yet another satisfied ADV'er. Called Garmin, they were no help. tried this today, and I'm golden.

    Zumo 220 and Nuvi 275 fixed!
    #17
  18. wncstrada

    wncstrada Adventurer

    Joined:
    Nov 12, 2005
    Oddometer:
    97
    Location:
    Western NC
    Add me to the satisfied customers. Thanks so much from saving me from one click too many on Mapsource!
    #18
  19. tcourdin

    tcourdin Resident Spooner

    Joined:
    Apr 3, 2008
    Oddometer:
    10,748
    Location:
    Arkansas
    I was having this same problem, thanks for the fix!
    #19
  20. farcall

    farcall Bike-a-holic

    Joined:
    May 29, 2008
    Oddometer:
    1,905
    Location:
    Western Australia
    Thanks BurnieM. :thumb Another successful fix. Can't believe how many hours I've wasted on this before coming to this place looking for help. 5 minutes later and problem solved.
    #20