Brisk plugs on 1150GS

Discussion in 'GS Boxers' started by Gintaronas, Oct 7, 2012.

  1. Gintaronas

    Gintaronas hobbyist

    Joined:
    Jun 26, 2007
    Oddometer:
    189
    Location:
    Vilnius, Lithuania
    Hi,

    I bought the new plugs for my 1150GS - Brisk DOR14LGS off ebay. Was a bit wondering when l got them.
    [​IMG]

    They look exactly as in the picture above. The gap between central electrode and side ones is somewhat big.
    Strange, but the bike started after I installed them. Made a test ride - bike was running normal.

    Now I wonder what mileage can I expect on those plugs?

    I was using NGK Iridium plugs before. After 20,000 kilometers they seemed to require a change, because bike did not start "on a half turn" anymore.

    Anyone who has used this kind of plugs, please share your experience.

    G.
    #1
  2. def

    def Ginger th wonder dog

    Joined:
    Feb 28, 2004
    Oddometer:
    12,714
    Location:
    The woods and mountains of Alabama
    Likely not enough improvement to justify the increased price for these spark plugs.

    I use Autolites 3923s. Paid $1.50 each for them years ago. I still get 43 MPG and the engine still starts regardless of weather. The Autolites have 30,000 miles+ on them.
    #2
  3. Ken Fritz

    Ken Fritz Long timer

    Joined:
    Oct 2, 2002
    Oddometer:
    1,039
    Location:
    Orangevale, CA
    What he said - money down the drain for those fancy plugs.
    #3
  4. Gintaronas

    Gintaronas hobbyist

    Joined:
    Jun 26, 2007
    Oddometer:
    189
    Location:
    Vilnius, Lithuania
    In that sense - yes, it is money down the drain. It was something like 11EUR per plug, so about 10 times more expensive. But I was very interested to try, cause those plugs looked very unusual. Curiosity, you know :evil

    People are doing more crazy things for that - and much more expensive, like sending machines to Mars. Oh yeah, again - it's "Curiosity" :D
    #4
  5. k1w1t1m

    k1w1t1m Kiwi

    Joined:
    Oct 10, 2010
    Oddometer:
    921
    Location:
    NW Arkansas
    Those look like pretty fancy plugs and I'd imagine they'd perform as well as if not better than the factory spec plugs.

    My 1150 seems to be the exception. It does not like the Autolite plugs. When the factory spec plugs are installed there is no surging, put the Autolites in and bring on the surging.
    #5