DRC Edge 2 Brake light problems

Discussion in 'Thumpers' started by MingRidesBikes, Dec 11, 2012.

  1. MingRidesBikes

    MingRidesBikes Been here awhile

    Joined:
    Oct 17, 2010
    Oddometer:
    202
    Location:
    Boise, ID
    hey guys 1st off, I have a 99 wr400f. I just switched out the stock fender and tail light for a yz fender and DRC edge 2 tail light. Love the looks, but cannot figure out why the brake light will not work. I 1st just tried matching up the colors on the 3 wires. (btw, I have the brake pressure switch to activate the brake light) So the WR400's have a blue wire (constant i believe) and black wire (ground) that run from the bike to the stock tail light. The wire harness from the tail light has a yellow wire (brake light) that is not connected stock. The brake pressure switch is hooked up as so: The red wire from the banjo splices into the blue wire. and the yellow wire from the banjo hooks up directly to the yellow wire out of the stock tail light. This set up works perfect. no issues. here is the issue. When I switched to the DRC edge 2 tail light (again a red wire, a black wire, and a yellow wire) I hooked up black to black (ground), red to blue, and yellow to yellow. This is what happened: The running light works fine. but the 3 white licence plate LED's do not light up. when I press on the brake, the 3 white licence plate LED's light up. No change to the tail lights that are on. Okay so I look at the package, and what do you know it says the red is the brake light and the yellow is the running tail light. Okay, so I switch it around. Now I have black to black, red (drc wire) to yellow (bike), and yellow (drc wire) to blue (bike) and here is the result. Now the tail light AND the 3 white licence plate LED's are on, but the brake does nothing... The LED's don't get brighter, they don't dim. It's like the brake light (or pressure switch) doesn't exist! Can anyone help me??? Is there any other way to wire up 3 different wires knowing that the black on both the bike and the tail light is ground...
    #1
  2. webmonstro

    webmonstro A Aventura Continua....

    Joined:
    Jul 21, 2008
    Oddometer:
    614
    Location:
    Portugal

    If you disconnect the red DRC and connect a wire ditrect to the batt (+) does the brack light light up ?

    get or make a test light and check if witch wire from the harness e getting power when lights on an witch is getting power when brake is pressed
    #2
  3. MingRidesBikes

    MingRidesBikes Been here awhile

    Joined:
    Oct 17, 2010
    Oddometer:
    202
    Location:
    Boise, ID
    the wr400 doesnt have a battery. I may have to get a test light, since i don't have one. (but both the red wire and the yellow wire are getting power it seems...) now I'm more confused. lol. thanks for the response though. I'm hoping someone with a wr that has installed this tail light can chime in.
    #3
  4. MingRidesBikes

    MingRidesBikes Been here awhile

    Joined:
    Oct 17, 2010
    Oddometer:
    202
    Location:
    Boise, ID
    so after pulling everything apart, it was a bad connection from my bikes constant, to my brake pressure switch. all is working now. :clap
    #4