Fuel injectors and fuel level light BMW r1100rs

Discussion in 'Road Warriors' started by Laki TC, Mar 8, 2013.

  1. Laki TC

    Laki TC n00b

    Joined:
    Dec 21, 2006
    Oddometer:
    7
    Location:
    Novi Sad
    I have two problems on my 94 RS.

    1. Light that signals that fuel is out, the red one, is working constantly, despite the fuel level in tank. Fuel level gauge is working as it should, so I know how much fuel is in the tank.

    2. Left injector is leaking, when ingnition is off, when I pull out the injector it let about one drop every minute or so. Oil also stinks like fuel, when I smell the cilinder with the oil cap remowed. Should I clean injectors ultrasonically, will it stop leakage? Is it possible that oil can smell like gas because of something else as well?

    Thanks
    #1
  2. Laki TC

    Laki TC n00b

    Joined:
    Dec 21, 2006
    Oddometer:
    7
    Location:
    Novi Sad
    nobody?:ear
    #2
  3. Anorak

    Anorak Woolf Barnato

    Joined:
    Jul 23, 2004
    Oddometer:
    34,826
    Location:
    OAK
    You need to clean or replace the injectors. If you're goin to try cleaning them yourself, you should energize the injector so it's open so the deposits on the pointless, the little valve are cleaned off.

    The oil has fuel in it be because of the injector.

    So far as the fuel level light, I believe ere are two circuits on the sender, one for the guage and one for the light. Maybe the warning light contact at the sender is bad.
    #3
  4. Laki TC

    Laki TC n00b

    Joined:
    Dec 21, 2006
    Oddometer:
    7
    Location:
    Novi Sad
    Thanks, I will get the injectors to the service to clean them ultrasonically.

    Cheers...
    #4
  5. Laki TC

    Laki TC n00b

    Joined:
    Dec 21, 2006
    Oddometer:
    7
    Location:
    Novi Sad
    Do you know what settings do I need for 93 r1100rs with no CO pot, Laser exhaust and no O2 sensor? CCP is removed, so I need to switch it back to 30-87 connection or 30-87a?
    #5
  6. walkingbear

    walkingbear Long timer

    Joined:
    Jun 5, 2004
    Oddometer:
    3,655
    Location:
    Scottsdale AZ..
    I found a used fuel pump and checked the connection. That took care of the fuel problem on the fuel sending unit.
    #6