G650GS prob with dials/clocks

Discussion in 'Thumpers' started by CaptBlodwen, Nov 25, 2012.

  1. CaptBlodwen

    CaptBlodwen n00b

    Joined:
    Oct 1, 2012
    Oddometer:
    3
    OK peeps, I know this bike isn't strictly covered in this forum (it's a smaller sibling of the evil twin) but on a general issue you may be able to help out.

    Washed the dirt off my GS yesterday then took it out for a ride. Did about 18kms and suddenly both dials dropped to zero. Bike still ran perfectly but with the following:
    no rev counter (not too important)
    no speedo (oops)
    no warning lights - neutral, ABS, indicators, oil
    no indicators working

    clock still works as do the horn, heated grips, kill switch and the bike still started numerous times

    Any ideas? Is there a fuse for the console (but why the working clock)
    #1
  2. Reaver

    Reaver Outta Here

    Joined:
    Aug 7, 2008
    Oddometer:
    10,665
    Location:
    Zona Sur Costa Rica
    Hurry, put on your helmet before the guys start beating you up for posting in the twin section!!!!!!!!!!:eek1
    #2
  3. Reaver

    Reaver Outta Here

    Joined:
    Aug 7, 2008
    Oddometer:
    10,665
    Location:
    Zona Sur Costa Rica
    OK, before you get the boot, my experience with those bikes is that it's a warranty item. Check the single forum to see if it's common.

    The G bikes were made cheaply and with Chinese built engines in the first years and were a warranty nightmare. We had them leaking all over the showroom (like the old Harleys!). Many recalls and part replacements due to failures.

    Sorry if this is news to you.
    #3
  4. Reaver

    Reaver Outta Here

    Joined:
    Aug 7, 2008
    Oddometer:
    10,665
    Location:
    Zona Sur Costa Rica
    See how fast the boot works!

    :bash
    #4