Garmin Smartphone Link ... no weather/no radar

Discussion in 'Mapping & Navigation' started by Fastman, Oct 6, 2017.

  1. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    495
    Location:
    Webster Groves, MO
    I have the BMW Nav VI installed on my '16 R1200GSAW and the Garmin Smart Link app (ver 2.7.0) on my iPhone 6S (running iOS 11). I purchased the Advanced Weather service months ago. The link between the Nav VI and Smart Link app has been sketchy enough. Now, I'm no longer able to get weather radar on the Nav VI. When I select Weather Radar, I get the map with "updating" in the lower right (all good so far):
    Updating.jpg

    However, after 3-5 minutes of "updating", I get the following error message:
    Error.jpg

    This has been going on for days now. Is it just me, an issue with the local (St. Louis) area or a bigger problem with the link to the NWS radar data? I’ve also realized I cannot receive local or other weather data/forecasts While I really like this GPS (almost compelled to given its price), I'm super underwhelmed by the Smart Link app integration, functionality and stability.
    #1
  2. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,562
    Location:
    alabama
    put the iPhone on the bars, you'll get weather, maps, music, without all the problems associated with pairing.
    #2
  3. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    #3
    Fastman likes this.
  4. BeachMoto

    BeachMoto Been here awhile

    Joined:
    May 30, 2008
    Oddometer:
    743
    Location:
    Va. Beach
    I have the same issue with my two iPhone 7s running iOS 11.03. The garmin app makes the connections but map and weather data does not transfer. I read that it is an issue with Apple.


    Sent from my iPhone using Tapatalk Pro
    #4
  5. scfrank

    scfrank Old farts riding club.

    Joined:
    Oct 27, 2005
    Oddometer:
    17,676
    Location:
    Upstate SC
    What the hell is wrong with these companies? Company A updates their software and App from company B no longer works? Do they talk to each other? I know I’m an antique but back during my career we got early notifications and beta code. Garmin especially always seems to be behind the curve.
    #5
  6. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    495
    Location:
    Webster Groves, MO
    I was working with a Garmin tech via email about a week ago when suddenly everything started working properly after having not changed anything. At the time, I was on iOS 11.0.2 on my iPhone 6s. Now, after upgrading to iOS 11.0.3, everything is broken again. The Nav VI says it's connected to my iPhone and Smartphone Link, but not the other way (Smartphone Link says it's not connected to the Nav VI). I'm back to no radar map, no weather, no alerts, no tracking ... essentially no 2-way comms between the iPhone and Nav VI. I sent the Garmin tech a lengthy email this afternoon complete with multiple screenshots from both my iPhone and Nav VI. I don't know why this irritates me so much, but it does.
    #6
    omid455 likes this.
  7. BeachMoto

    BeachMoto Been here awhile

    Joined:
    May 30, 2008
    Oddometer:
    743
    Location:
    Va. Beach
    Could be because you paid almost a $1000 for GPS unit that doesn’t do what it is supposed to do and it is no better than an $85 unit from Costco.

    I am just as irritated, GARMIN units seem to get worse with each model. My 595 was a much better unit than this POS.


    Sent from my iPhone using Tapatalk Pro
    #7
    Fastman likes this.
  8. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,562
    Location:
    alabama

    two devices, requiring an application to share data, which is acquired over cellular networks, and transferred over a paired Bluetooth connection....

    what could go wrong ? lol

    just put the phone on the bars and see the radar/map/music right there, instead of introducing failure points between two units and odd sharing problems.
    #8
    BeachMoto likes this.
  9. BeachMoto

    BeachMoto Been here awhile

    Joined:
    May 30, 2008
    Oddometer:
    743
    Location:
    Va. Beach
    That is what I have started doing. Bought a Perfect Squeeze from an inmate, now I can just use the phone.
    #9
    ohgood likes this.
  10. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    495
    Location:
    Webster Groves, MO
    While I trust most of the mounts out there, I just don't want to put my phone on the handlebars. I prefer to keep it on me inside a waterproof jacket pocket.

    FWIW, the Garmin product support tech I've been working with acknowledged they are seeing a number of issues with their app and the latest iOS updates. He requested, and I provided the Bluetooth logs from my Nav VI. They've been forwarded to the engineering team and a case has been created to have this investigated further. In the mean time, if I really need to see something that the app/GPS combination would have provided, I'll pull off and get out my phone.
    #10
  11. omid455

    omid455 Adventurer

    Joined:
    Jul 8, 2009
    Oddometer:
    17
    Location:
    Dubai, UAE
    I have the same exact issue which is driving me crazy, iphone 6s Plus and IOS 11.0.3
    It only connects if I unpair both devices and pair again. the moment any of 2 devices is disconnected from next time i don't get any traffic or weather updates on the map. Also smartphone link doesn't send any waypoints to the navigator. today upgraded to ios 11.1 let's see if it fixes the issue.
    #11
  12. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    Ditto. I have an iPhone6 (running iOS 11.1), and a Nav VI (with latest firmware). The Smart Link app stopped working, though on a ride a couple of days ago, it suddenly started giving me traffic alerts! Not so yesterday. The Smart Link did not work at all. I had re-paired the Nav VI and the phone a few days ago.
    #12
  13. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    495
    Location:
    Webster Groves, MO
    The Garmin tech I've been emailing back and forth with believed the upgrade to iOS 11.1 coupled with re-pairing the devices in a specific order would fix the issue ... NOT! I ended up sending him more troubleshooting information that's apparently being forwarded to their engineering team. For some reason, the Bluetooth data connection is extremely unstable and once broken, can't seem to re-establish itself. For example, Smartphone Link stayed connected until the phone/Nav VI/Sena 20S were ready for telephone calls; then it dropped and I could not get it to restore without powering down the Nav VI.
    #13
  14. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    Well that's comforting! :D
    #14
  15. parralix

    parralix n00b

    Joined:
    Sep 17, 2017
    Oddometer:
    2
    Location:
    madrid
    i have the same problem. smartphone link in ios11 works for a while when i pair nav and phone. as soon as they disconnect they never work again unless i delete the pairing and start from scratch. garmin tech support says its apple problem but of course i dont believe it...
    #15
  16. bschulz903

    bschulz903 n00b

    Joined:
    Dec 17, 2014
    Oddometer:
    1
    I have never been able to get the Garmin GPS and smartlink app to work consistently with my iphone. I have resorted to just using my Iphone. This has been an ongoing problem that apparently they can't solve.
    #16
  17. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    Smart Link on my iPhone 6 worked just fine with my Nav V for 3+ years, just as it did with my Nav VI earlier this year. It’s only very recently that it stopped. As many have said, it seems to be related to the introduction of iOS 11 on the iPhone.

    EDIT: Went for a ride this morning, and everything paired up, including Smart Link. Whether it stays that way, who knows. Having said that, since iOS 11, I have not been able to access music (stored on my iPhone) through the Media App on the Nav VI (I know, a commonly-reported problem), even though I had been able to do this pretty much without an issue for months. Now I get the dreaded message, "downloading data from Apple device". As many have reported, it never completes that task, so no music. I always had the settings in the Media App set to "iPhone". However, today, I switched it to "Bluetooth", and was able to play music, however, all I could do was hit play, and stop. I could not browse my tunes, or playlists, nor could I see any titles, or album art, all of which were accessible when I had the Media App on the Nav VI set to "iPhone". You'd think after all this time, with many people reporting this to Garmin, they could have sorted this out. By the way, I had updated my phone yesterday to the latest version of iOS 11 (11.1.2).

    EDIT #2: Went for another ride Sunday, but this time I could not get Smart Link to work, despite going into the Nav VI's Bluetooth settings and trying to "poke" it. No luck.
    #17
  18. RobertInColorado

    RobertInColorado Adventurer

    Joined:
    Aug 25, 2008
    Oddometer:
    58
    Location:
    Larkspur, CO
    Scared to update now... I have a Zumo 590 and have had various issues between it and my iPhone 6 and Sena 20s (no audio on calls sometimes, Smart Link disconnecting, etc). I updated everything (590, Sena) except the iPhone to iOS 11 and just finished a 1,000 mile ride last night and everything was working perfectly, like I hoped it would when I bought all those devices... it was really nice. Smart Link stayed connected more reliably than ever. Was just about to update the iPhone but I think I'll hold off.
    #18
  19. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    495
    Location:
    Webster Groves, MO
    Apple updated its AirPlay software to AirPlay 2 with iOS 11. I have to wonder if that isn't the source of the SmartLink connectivity issues that have surfaced between the BMW Nav VI and iPhone?
    #19
  20. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    Garmin just released software version 4.90 for the Nav VI. The release notes say that it corrects a long list of issues, including Smart Link app connectivity, streaming music from iOS devices etc. I just updated my GPS, but have no idea at this point whether it really does what Garmin says.
    #20