Help with a 950 please

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by Bumpaman, Aug 22, 2013.

  1. Bumpaman

    Bumpaman Been here awhile

    Joined:
    Oct 21, 2009
    Oddometer:
    162
    Location:
    Foot of the Sangre de Cristos and Music City, TX.
    I have put this out before, but my problem still exists and I cannot seem to solve it. I have a 2005 950 A S model with 30K miles that really has been a trouble free machine. During the winter I did a water pump rebuild and a valve clearance check. Valves were in spec. When I rode the bike in june, I noticed a miss or a hesitation between 4k and 5k rpms that I have never noticed before. It will run smoothly from 4 to 5k while running up through the gears until you hit 5 and 6 then the hesitation/miss becomes noticeable. I have changed the fuel filter, it has a Facet pump that seems to be delivering alot of fuel, the stick coils and their attaching wires are plugged in well. all other wiring seems to be plugged in. I have had the carbs off and have gone through them cleaning passages and jets. I did a throttle body sync with a flowmeter and a twinmax. I thought maybe it was running to rich so I moved the needle up a notch to position 2, but this seemed to make the problem worse. So then I moved the needle back to position 3. This is were it has been since I put a jetting kit from ADVmachines and where they recommended it for my altitude and the bike has run perfectly for a couple of years in this position, until now. The moving of the needle would indicate that it is running lean, but how would this happen just sitting there in the garage????????? Anyone else have any ideas ????????? Any help would be appreciated. Thanks
    #1
  2. charlie264

    charlie264 Long timer

    Joined:
    Oct 27, 2007
    Oddometer:
    8,591
    Location:
    Blighty
    Check fuel flow, clean fuel tap tank gausses......sounds like starvation...
    #2
  3. renogeorge

    renogeorge Long timer

    Joined:
    Apr 7, 2007
    Oddometer:
    1,522
    Location:
    Reno
    Air leak at carb connections to manifold? Vacuum leak from SAS manifold vacuum taps--not sealed, cracked tubing???

    Good luck
    #3
  4. brents347

    brents347 Trusting my Cape...

    Joined:
    Mar 5, 2006
    Oddometer:
    3,936
    Location:
    Where the hell is Truckee, CA?
    You didn't mention checking float height. These bikes can be sensitive to this. 3-3.5mm would be the place to start. Where are your air mixture screws set?

    Brent
    #4
  5. Bumpaman

    Bumpaman Been here awhile

    Joined:
    Oct 21, 2009
    Oddometer:
    162
    Location:
    Foot of the Sangre de Cristos and Music City, TX.
    Floats checked. 3.5mm. Idle mixture screws at 1.75 turns. Replaced the vacuum hoses and they are secure. Carbs tight to manifold. Tank tap flows like a river.?????????????????????????/
    #5
  6. FuTAnT

    FuTAnT KTM 990ADV

    Joined:
    Oct 19, 2006
    Oddometer:
    343
    Location:
    Brisvegas, Oz
    Doesn't the battery relay or something on these frag out and cause shitty issues like this? You've done the fuel system, check electrics.

    Sent from my Nexus 4 using Tapatalk 4
    #6
  7. Bumpaman

    Bumpaman Been here awhile

    Joined:
    Oct 21, 2009
    Oddometer:
    162
    Location:
    Foot of the Sangre de Cristos and Music City, TX.
    Do you have more info on this? This is the first time I have heard of this. The electrics seem to work fine.
    #7
  8. DesertSurfer

    DesertSurfer Tail sprayin

    Joined:
    Feb 20, 2009
    Oddometer:
    1,553
    Location:
    City of the Angels
    I think Pyn documented this in his thread... you might be able to google it, or read his entire thread over a long holiday weekend.
    #8
  9. Bumpaman

    Bumpaman Been here awhile

    Joined:
    Oct 21, 2009
    Oddometer:
    162
    Location:
    Foot of the Sangre de Cristos and Music City, TX.
    I will search it out. Thanks
    #9
  10. FuTAnT

    FuTAnT KTM 990ADV

    Joined:
    Oct 19, 2006
    Oddometer:
    343
    Location:
    Brisvegas, Oz
    I was trying to find it too. It was only a few weeks ago I saw someone with the same problem again as well. Its the electrical terminal block on the lower right hand side of the bike in behind the bash plate. With water crossings, dust, vibration and time it can take a toll. Perhaps just a simple review and clean while checking the earth points on the bike might be a good place to start. It won't hurt anyway at this stage in the bikes life.

    Sent from my Nexus 4 using Tapatalk 4
    #10
  11. Orangecicle

    Orangecicle On a "Quest"

    Joined:
    Apr 24, 2007
    Oddometer:
    3,344
    Location:
    West Des Moines, IA
    I always start with the stuff that I last worked on. My KTM usually falls apart somehow in relation to the thing I tried to fix. You say the carbs are synced and that vacuum lines are not an issue. Assuming your carb bowls are clean and the jets aren't stopped up, I would suggest a some fuel restriction. Maybe your Facet is on the way out? You say you changed the fuel filter. Is there any kink in the fuel delivery lines that could restrict flow?

    If not a fuel problem, is there an air restriction? How's the air filter?

    I will get your symptoms if the carbs are out of sync, or I have an air leak that causes a backfire into the carbs. Seems like you've already excluded these, so . . . dunno. I'm stumped.
    #11
  12. Bumpaman

    Bumpaman Been here awhile

    Joined:
    Oct 21, 2009
    Oddometer:
    162
    Location:
    Foot of the Sangre de Cristos and Music City, TX.
    Hello all,
    I just wanted to close out this thread with an update on my 950 that had a real hard time revving up past 4k rpm. Just finished a trip on the Heart of the west and being that most of the trip was 4k rpm and below the problem wasn't too bad. But the problem plagued my mind and bike everyday until I attended the KTM Nat'l Rally in Steamboat last weekend and talked to KTM Tech Tyler Burner. When I described the problem the first thing he asked was where were my carb vent hoses located...in the airbox or out? When I told him in and he shook his head and said they must be outside the airbox, I immediately realized what a bonehead stunt I had committed when I did my valve adjust last spring (not locating the vent hoses where they should be). I tore the bike down to the carbs that day and put the vent hoses where they belong and VOILA'....the old girl pulls like a racehorse in everygear and behaves like it was meant to. Thank you Tyler!!!!!!!!!!!!!!!! Big lesson learned by me in more than one way. Thanks so much to all of you who tried to help. I think the only reason that vent hoses weren't mentioned was that you didn't think anyone would be that foolish. I evidently am. Thanks to all again. Till next time:bow
    #12