Horn quit working after wreck

Discussion in 'GS Boxers' started by Sasquatch2112, May 3, 2013.

  1. Sasquatch2112

    Sasquatch2112 scatology expert

    Joined:
    Sep 9, 2007
    Oddometer:
    9,121
    Location:
    Homeless
    I washed out the front end and landed on the left handlebar. Since that time the horn (Nautilus Steble) no longer works.

    I have done the following tests.

    13.3 Volts on the hot side of the relay
    0.0 volts when horn button not pushed
    0.06 volts momentary when horn button pushed. ~2-3 seconds and gone
    oo Ohms resistance through the wires going to the horn
    hitting the horn button does not change the "open" that I am seeing.

    I do not hear a relay click when I hit the horn button. I am thinking that a buggered up the horn button in the crash. Any logical thoughts?

    Thanks
    #1
  2. Ridingfast

    Ridingfast n00b

    Joined:
    Feb 21, 2013
    Oddometer:
    5
    Location:
    So. California
    The cable somewhere in the line might have been ruptured.
    #2
  3. oldfool

    oldfool Been here awhile

    Joined:
    Jun 17, 2006
    Oddometer:
    733
    Location:
    San Pedro, california
    I found that my bike weighs less without the horn. Richard
    #3
  4. TuefelHunden

    TuefelHunden Been here awhile

    Joined:
    Sep 23, 2008
    Oddometer:
    600
    Location:
    Spartanburg, SC
    Run a hot wire from the battery and touch the horn button contact to the relay. If the horn blows then it is the horn button. If the relay clicks and it doesn't blow then it is probably the horn. If it doesn't click and horn doesn't blow it is probably the relay. Relay's die easy.
    #4