Husaberg 450 FE does not want to work

Discussion in 'Thumpers' started by rd07luis, Mar 2, 2013.

  1. rd07luis

    rd07luis KTM REBUÇADO

    Joined:
    Apr 23, 2007
    Oddometer:
    36
    Hi guys,

    After a jet wash the bike doesn't want to start. The batery is good and the start engine is runing, have fuel.
    What should I look for ?
    Thanks for your help.

    LD
    #1
  2. 4ReelMoto

    4ReelMoto Seasoned Rider

    Joined:
    Oct 3, 2009
    Oddometer:
    1
    Location:
    Motoring Michigan
    How high did you have the pressure set on the power (jet) washer?
    Did you have the seat off when washing? If so, make sure the starter solenoid is still connected properly.
    You mentioned that the battery is good, have you made sure you have at least 10.6 V while trying to start?, the Husa's fuel injection can be temperamental in regards to this.
    I replaced the stock battery with a Shorai not long after the bike was new and this problem has never happened since.
    #2
  3. AustinJake

    AustinJake DR650 - Versys

    Joined:
    Aug 20, 2010
    Oddometer:
    4,430
    Location:
    Austin, TX
    On my Husky TE 450, water infiltrated my gear position sensor, and the bike would not start or if it started it would die immediatley when put into gear, Check to see if you have a gear position sensor on the bike.

    [​IMG]
    #3
  4. FamilyRider

    FamilyRider Been here awhile

    Joined:
    Dec 16, 2012
    Oddometer:
    504
    Location:
    Salt Lake City, UT
    I have heard of others having trouble when the spark plug wire gets wet. Apparently water gets down inside the cap.
    #4
  5. Off the grid

    Off the grid Unsmooth Operator

    Joined:
    Jan 3, 2008
    Oddometer:
    12,978
    Location:
    That buzzing in your earhole, NorCal.
    I ruined my stator by using a pressure washer, even by being careful.

    Never, ever again.
    #5
  6. Huskylove

    Huskylove Adventurer

    Joined:
    Jun 2, 2012
    Oddometer:
    54
    Location:
    SF Bay
    Check the clutch disconnect switchy thing...I had that happen to my husky 450 2006. Wouldn't start wouldn't start, new battery, wouldn't start...figured her out eventually.
    #6
  7. rd07luis

    rd07luis KTM REBUÇADO

    Joined:
    Apr 23, 2007
    Oddometer:
    36
    Thanks guys I will check all the possibilities.
    #7
  8. Jacl-Kampuchea

    Jacl-Kampuchea Booze Merchant

    Joined:
    Sep 27, 2010
    Oddometer:
    887
    Location:
    I see Drunk People.
    Simply a water infused contact somewhere.

    Every bike wash where I live has an air gun and if a bike won't start they just blast every point where water could cause a fault - spark plug, kill switch, sidestand switch, clutch switch etc. . .

    Fixes everything. Alternatively, leave it alone for 24 hours so the water can dry out and it will likely start then.
    #8
  9. kdennan

    kdennan Been here awhile

    Joined:
    May 6, 2010
    Oddometer:
    635
    Location:
    Vermont, USA
    listen to the manufacturer
    NEVER PRESSURE WASH
    If you want the bike spic and span, use Motoclean by motorex. spray on and rinse off with GENTLE stream from a garden hose.
    #9
  10. rd07luis

    rd07luis KTM REBUÇADO

    Joined:
    Apr 23, 2007
    Oddometer:
    36
    Once again thanks for all your help.

    Today I start to do a check and the fuel pump was disconected with the water or when taking out the air filter.
    Problem solved :freaky
    #10