Idle drop after revving.

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by Jdeks, Jan 10, 2013.

  1. Jdeks

    Jdeks Departed

    Joined:
    Aug 30, 2009
    Oddometer:
    1,035
    Hi again all,

    I'm putting my bike back together, after having done a lot of service work (valves, new oil regulator, cam chain tensioners) and also I've switched to a 2 to 1 exhaust, and installed Pyndons prefilter. I'm using a jetting config that he recommended for it (nothing special really, actually pretty close to stock).

    It starts fine, idles fine, revvs fine. No smoke from the exhaust. But when I rev it hard and then let it off, the idle drops low (about 1000rpm) for a few seconds then slowly recovers. Sometimes, if its a really fast on/off throttle snap, it dies on the way back to idle. It pops a little on its way back down the revs, but thats normal I believe.

    Any ideas?

    Thanks!
    #1
  2. Jdeks

    Jdeks Departed

    Joined:
    Aug 30, 2009
    Oddometer:
    1,035
    Anyone?

    I've checked carb sync, calibrated the TPS, checked the carbs are seated properly.

    :(
    #2
  3. Jdeks

    Jdeks Departed

    Joined:
    Aug 30, 2009
    Oddometer:
    1,035
    Okay, I think I fixed it. Swapped out my new fuel filter for my larger old one - seems it was restricting fuel flow.

    Got a new problem now though...
    #3
  4. GSAragazzi

    GSAragazzi Long timer

    Joined:
    Sep 16, 2012
    Oddometer:
    1,692
    Location:
    The Purgatory of Suburbia
    But I'm also waiting for someones suggestions bc my bike starts, runs well but after 5 min it starts to sputter and then dies. Push and push the magic button and nothing. If i wait 5 min it starts but sputters, give gas and dies. The only thing I've found helpful is to let the bike fall on its side (clearing whatever the problem is) and then it starts and back to square 1.
    I'll ck my fuel filter, so thanks.

    Anyone out there with any suggestion?
    #4
  5. Jdeks

    Jdeks Departed

    Joined:
    Aug 30, 2009
    Oddometer:
    1,035
    My fuel filter was a custom one I installed myself.

    I would check your fuel pump - have you opened it up and looked at the contact points?
    #5
  6. Deepc

    Deepc Been here awhile

    Joined:
    Apr 11, 2011
    Oddometer:
    299
    Location:
    St. Petersburg, Florida
    It sounds like your fuel pump might be on its way out. There are a bunch of upgrade options out there. I used the dr. beans kit. Its cheap, simple to install, and was delivered in about 1 week.
    #6