? Installing OEM GSA Driving Lights on a GS

Discussion in 'GS Boxers' started by Canada Mike, May 12, 2010.

  1. Canada Mike

    Canada Mike Been here awhile

    Joined:
    Oct 16, 2009
    Oddometer:
    292
    Location:
    Langley BC
    Hello,

    Does anyone have any hints on the connection points to the canbus. I purchased used off another inmate here a complete OEM GSA Driving lights off a 2007 GSA (I have a 1200GS 2007). The wiring harness looks simple, two connectors for the lights, switch, and the 4 pin connector for the canbus( power). Well there is also a fuse box and a relay wired in the harness as well but I'm mostly wondering about the canbus connection to the bike.

    Anyone done this already?:ear

    Cheers,

    Mike
    #1
  2. Canada Mike

    Canada Mike Been here awhile

    Joined:
    Oct 16, 2009
    Oddometer:
    292
    Location:
    Langley BC
    Nobody has done this yet?

    #2
  3. Burnszilla

    Burnszilla BurnsMoto.com

    Joined:
    Jun 10, 2005
    Oddometer:
    1,345
    Location:
    Redwood City, California
    Take the tank off and look for the connector on top of the computer box.

    [​IMG]
    #3
  4. Canada Mike

    Canada Mike Been here awhile

    Joined:
    Oct 16, 2009
    Oddometer:
    292
    Location:
    Langley BC
    YES Yes YES....Thanks so much... I hadn't even confirmed if it was possible to put these on the GS.

    But really thanks a lot!

    Mike



    #4
  5. Burnszilla

    Burnszilla BurnsMoto.com

    Joined:
    Jun 10, 2005
    Oddometer:
    1,345
    Location:
    Redwood City, California
    Can you post photos of your harness. I'm curious if you could use the BMW harness and switch to install aftermarket lights. A macro shot of the connector into that connector I posted above would be nice too.
    #5
  6. Canada Mike

    Canada Mike Been here awhile

    Joined:
    Oct 16, 2009
    Oddometer:
    292
    Location:
    Langley BC
    Will do...

    #6
  7. Jolly Roger

    Jolly Roger Been here awhile

    Joined:
    May 29, 2008
    Oddometer:
    584
    Location:
    British Columbia
    Yes, I'd also be interested in some close-up photos of the harness as a friend of mine is wanting to do exactly the same thing as you. He's a bit of a noob when it comes to anything "electrical" so anything we can do to help him out would be great.

    :rofl
    #7
  8. Pcfly

    Pcfly Dude?! Seriously??

    Joined:
    Nov 30, 2008
    Oddometer:
    1,140
    Location:
    SF. Bay Area
    This might be a dumb question but.... Do you unplug that round placeholder then plug it into that? :dunno Is this where the GSA Aux light switch (from the left handgrip) plugs into?
    #8
  9. Burnszilla

    Burnszilla BurnsMoto.com

    Joined:
    Jun 10, 2005
    Oddometer:
    1,345
    Location:
    Redwood City, California
    Check out the harness. It looks like the plug on the very right end plugs into the top of the computer plug.

    [​IMG]
    #9
  10. Canada Mike

    Canada Mike Been here awhile

    Joined:
    Oct 16, 2009
    Oddometer:
    292
    Location:
    Langley BC
    [​IMG]
    Remove Tank as per manual. DIS-CONNECT THE BATTERY NOW!!!!!!

    [​IMG]


    [​IMG]
    This plug on the top right is a dumy plug that will actually come off, and be replaced by the one on the harness. I'll show you later...

    [​IMG]


    [​IMG]

    [​IMG]

    This is the close up of the plug on the harness that connects to the bike wiring ( top right on cpu panel.
    [​IMG]


    [​IMG]
    Open this tray with a small scewdriver to pop up the tabs

    [​IMG]
    Swing this top CPU part out of your way.

    [​IMG]
    Un-plug the bike harness wire from the dumy plug.

    [​IMG]


    [​IMG]
    Use a small screwdriver on the left of the plug to move the latch and slide it off to the right.

    [​IMG]


    [​IMG]
    This is the OEM harness plug shown earlier...slide it on

    [​IMG]


    [​IMG]
    Plug in the OEM bike harness plug to the installed outlet.

    [​IMG]
    Now install the connector for the switch to the other side.

    [​IMG]
    The top item in this picture goes behind the CPU. It can be swug up and tye wrapped to the plastic.

    [​IMG]
    Route the cabling down to the front beak for the driving lights.

    [​IMG]
    Riders right side...Fuse panel mounted to the post on the bike. I have the BMW part on order for this attachment. It is a GSA part number and will let you know if I get the correct one. Tye wrapped and velcro for now.

    [​IMG]
    Reconnect the battery once the lights are connected and check for fault codes.

    [​IMG]



    [​IMG]

    All is good....I have just received the 2009 left control upper and lower to relocate the switch from the top of the forks to the left hand controls. NICE should work well. I'll send some pics once completed.

    Cheers,

    Mike:D
    #10
  11. Canada Mike

    Canada Mike Been here awhile

    Joined:
    Oct 16, 2009
    Oddometer:
    292
    Location:
    Langley BC
    Nope do NOT plug into that...Drop me a line if you have any questions...:ear
    #11
  12. paco fernandez

    paco fernandez Mexico

    Joined:
    Aug 22, 2010
    Oddometer:
    64
    Location:
    URUAPAN, MICHOACAN. MEXICO
    Tahank you so much, ery helpfull
    #12
  13. dseric

    dseric Living for Adventure

    Joined:
    Jan 10, 2006
    Oddometer:
    257
    Location:
    Atlanta, GA USA
    Has anyone tapped into this part of the harness for aux light power or as a trigger?

    Seems this wire will not power up till after start just like the headlight.
    #13
  14. dseric

    dseric Living for Adventure

    Joined:
    Jan 10, 2006
    Oddometer:
    257
    Location:
    Atlanta, GA USA
    Just to update this thread and contribute, I tapped into this harness after testing the wires. The purple/yellow wire adjacent to the brown wire only has 12v after the bike is running just like the headlight. Great spot for AUX light trigger so as not to stress battery before startup. Would make the lights only run until after startup. :clap

    On my '09 SE GS the harness was on the top left of the ZFE module. It seems all have this harness if your bike was an '08 or later. Please correct me if I am wrong. :wink:

    Photos:

    Location and removed from holster on ZFE module:
    [​IMG]

    Red trigger wire is Posi-tapped for my Skene Lighting controller and the is harness put back into holster:
    [​IMG]
    #14
  15. Penfold99

    Penfold99 Adventurer

    Joined:
    May 28, 2013
    Oddometer:
    56
    Location:
    Atlanta
    This is exactly what I was looking for, great thread...

    Does anybody know (before I pull my tank off) if that 4 pin aux connector is on a 2005 1200GS? I have the complete set with this harness (from an 07 GSA). I don't want to pull my tank if I am chasing a dead end...

    Hope some of you with pre '06 bikes have been down this road and can help.

    Also, can you clarify the fuse box, and relay box mounting locations.

    Thanks,

    Dave
    Atlanta
    2005 R1200GS
    #15
  16. dseric

    dseric Living for Adventure

    Joined:
    Jan 10, 2006
    Oddometer:
    257
    Location:
    Atlanta, GA USA
    Dave, AFAIK the 4 pin harness is on the '08 and later models. If I am wrong I would hope someone corrects me. :D
    #16
  17. Penfold99

    Penfold99 Adventurer

    Joined:
    May 28, 2013
    Oddometer:
    56
    Location:
    Atlanta
    It looks like the harness I have is good for 06 and up... If that 4 pin plug is there, I'm good. If not, I will try to use the harness, I will just have to tap into some switched power, instead of the engine running power only.

    Hoping someone can tell me if that plug is there on an '05 though...
    #17