Just dies for a second and restarts

Discussion in 'GS Boxers' started by bob393, Nov 25, 2012.

  1. bob393

    bob393 Been here awhile

    Joined:
    Dec 23, 2010
    Oddometer:
    431
    Location:
    Goshen, NY
    So I'm riding down the road at night just chill-in and the bike shuts off the dash and headlight go out and just as quickly, like less than one second later, everything comes back on and scared to death I ride back home. It has done this twice in the last 500 miles and never before. And the bike runs perfectly otherwise. Both time this has happened I was using a brand new ignition key and had my aux driving lights on. I'm ready to switch back to my old key and not use the aux lights and see if it does it again but I really don't see why that would do it.
    #1
  2. Wolfgang55

    Wolfgang55 Long timer

    Joined:
    Dec 24, 2006
    Oddometer:
    3,816
    Location:
    Next to Rio Bravo
    Recall the same issue you described a year back on someone's 07. I maybe all wrong but.....
    Sounds like the security ring in the switch.
    Soon, it will just not start.
    #2
  3. PineyMountainRacing

    PineyMountainRacing Oops....

    Joined:
    Jul 2, 2008
    Oddometer:
    2,911
    Location:
    Sarasota, FL / Sylva, NC
    Not the same bike but my 08 KLR used to do that before I replaced the wiring harness. It happened so quickly I wouldn't even be sure it had happened. Weirdest thing I'd ever experienced. Even seemed to lose power for less than a split second. KHI finally had a factory recall on the harnesses. I never found a problem with my old harness but the new one solved the problem.

    PMR
    #3
  4. funinthesun

    funinthesun Been here awhile

    Joined:
    Oct 30, 2009
    Oddometer:
    260
    Location:
    so cal
    The signal in the key ring wont kill the bike it only prevents starting(according to the dealer I talked to). sounds like something else is killing the bike. could be as simple as the key, If there are other keys or something on it causing the switch to have a bad connection on the plug or inside. Id use that key and try to get it to fali in the garage. center stand and start wiggling stuff until it dies. good luck
    #4
  5. bob393

    bob393 Been here awhile

    Joined:
    Dec 23, 2010
    Oddometer:
    431
    Location:
    Goshen, NY
    Like I said it's so intermittent is scary.
    I have switched back to the old key just to see what happens. :baldy
    Thanks
    #5
  6. bob393

    bob393 Been here awhile

    Joined:
    Dec 23, 2010
    Oddometer:
    431
    Location:
    Goshen, NY
    So far so good about 500 miles.
    I did find a loose wire under the seat but that was for the driving lights and was wired directly to the battery and shouldn't have anything to do with it.
    #6
  7. Zoef zoef

    Zoef zoef Been here awhile

    Joined:
    Apr 19, 2009
    Oddometer:
    558
    Location:
    Finn√ły Island, near Stavanger, Norway
    Sir,

    It could be the wiring to and from the ignition switch. After a while, these wires can have some internal breaks.
    #7
  8. bob393

    bob393 Been here awhile

    Joined:
    Dec 23, 2010
    Oddometer:
    431
    Location:
    Goshen, NY
    This could be it. It wouldn't power up this morning and out of desperation I wiggled the harness into the ignition switch and it came to life. Now to fix it the dam thing :cry
    #8