k75 newby question

Discussion in 'Old's Cool' started by neil p, Oct 2, 2012.

  1. neil p

    neil p Adventurer

    Joined:
    Mar 14, 2009
    Oddometer:
    96
    Location:
    La Alpujarra,Andalucia.
    HELP
    New to me ´88 k75, lots of years standing, new fuel pump and filter,been starting ok,but now flooding and not starting. Got sparks but also the red dash triangle staying on. Is this a clue ? what does this warning light indicate ?
    #1
  2. OldPete

    OldPete Be aware

    Joined:
    Oct 6, 2007
    Oddometer:
    5,801
    Location:
    SoSoCal
    #2
  3. mwood7800

    mwood7800 Banned

    Joined:
    Feb 10, 2011
    Oddometer:
    611
    Did you change the rubber ell on the air box yet?
    #3
  4. makulekane

    makulekane n00b

    Joined:
    Mar 6, 2009
    Oddometer:
    5
    That red light lets you know when there is a fault in the brake light system (light bulb, wire, switch, whatever). It will stay on until you test your brakes, once the motor is running pull the front brake and step on the rear brake, the light should go off.

    If you changed to LED lights, it will stay on unless you also add a resistor. Mine stayed on when I changed to an LED brake light, even with resistors. I eventually pulled the bulb from the cluster and just check the lights by eye more often.

    If it ran before, you may have changed something when you last worked on it...maybe? Especially if you changed plugs. Check the wires to make sure they are on the right plugs. It could still have spark but it will be all bassackwards.

    Pretty simple machines... good luck.
    #4
  5. neil p

    neil p Adventurer

    Joined:
    Mar 14, 2009
    Oddometer:
    96
    Location:
    La Alpujarra,Andalucia.
    Thanks for the responses/support.

    I have changed the engine breather.

    Today i took out the injectors and observed what i imagine is an even spray as the motor cranked. Put it back together and it ran ! Still not sure what the problem was/is. But learning all the time about this bike.

    Makulekane- thanks for the warning triangle/brake test education.

    As for being a simple machine..........its my first injected bike, and WOW aren´t all those little electrical components expensive !
    #5
  6. bmwrench

    bmwrench Long timer

    Joined:
    Nov 10, 2006
    Oddometer:
    2,428
    It is very easy to foul the plugs on a K75, even one that is in good tune, by starting and running it briefly. If the motor is run for less than about ten minutes, the next time you try to start it, the plugs can foul. Every time you start one of these bikes from they run fairly rich for a few minutes.
    #6