KTM 950 ADV trouble

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by norschweger, Oct 11, 2012.

  1. grenemy

    grenemy n00b

    Joined:
    May 23, 2011
    Oddometer:
    7
    Location:
    mexico MIL CUMBRES
    Hello everybody,

    do you know if the cylinder of a ktm adv 950 from the 03-06 is exactly the same???

    Best regreads,

    alberto
    #21
  2. grenemy

    grenemy n00b

    Joined:
    May 23, 2011
    Oddometer:
    7
    Location:
    mexico MIL CUMBRES
    Hello everybody,

    do you know if the cylinder of a ktm adv 950 from the 03-06 is exactly the same???

    Best regreads,

    alberto
    #22
  3. norschweger

    norschweger Been here awhile

    Joined:
    Apr 21, 2012
    Oddometer:
    242
    Location:
    Germany
    Hi Alberto,
    I cannot answer the question, but maybe you should post that as an own thread.
    Cheers Tobias
    #23
  4. norschweger

    norschweger Been here awhile

    Joined:
    Apr 21, 2012
    Oddometer:
    242
    Location:
    Germany
    the radiator cap was bad, the thermo sensor did not work properly so the fan did not kick in when it should.
    Replaced both, big service, new battery. Not cheep but better than to get stuck in the dessert.
    Still: there are vibrations (a grinding, as if something was not properly tightened or a shaft bent...?) that I can feel, especially when accelerating. It disappears when I pull the clutch or am in neutral...
    Any ideas???
    #24
  5. norschweger

    norschweger Been here awhile

    Joined:
    Apr 21, 2012
    Oddometer:
    242
    Location:
    Germany
    The vibrations disappear when I am in neutral, pull the clutch or take off the luggage.
    If it was something with the chain, sprockets, shaft, tire...it would not disappear when I pull the clutch, right?
    Or could it be that pulling the clutch takes away the stress from anything in the transmission (maybe a bent shaft?remember that the chain came off-masterlink opened up at high speed)
    Could it be anything with the clutch? It slips sometimes in first gear when I want to take off and the engine is cold...
    #25