lc4 640 enduro speedo problem

Discussion in 'Thumpers' started by mountaincadre, Nov 13, 2012.

  1. mountaincadre

    mountaincadre Been here awhile

    Joined:
    Jul 18, 2012
    Oddometer:
    364
    Location:
    Mid Calder,Scotland
    As above display is fine but no speed shown, is there a pick up on the wheel? if aye can you buy/rig another one as the bike shop is quoting £46 for a new one and if it is just a pick up for the sensor then £46 is very steep.
    #1
  2. mountaincadre

    mountaincadre Been here awhile

    Joined:
    Jul 18, 2012
    Oddometer:
    364
    Location:
    Mid Calder,Scotland
    Or doe's anyone have a clear photo?
    #2
  3. dhally

    dhally Hammerhead

    Joined:
    Feb 18, 2006
    Oddometer:
    2,421
    Location:
    Kennewick, WA
    Here's the OEM sensor off my 2001 640Adventure. Don't know if the same one is used on the Enduro. The cable and sensor are one piece, hence the high price. I have heard of others using a cheaper sensor and splicing it in. Trailtech sells them I think.

    [​IMG]
    #3
  4. mountaincadre

    mountaincadre Been here awhile

    Joined:
    Jul 18, 2012
    Oddometer:
    364
    Location:
    Mid Calder,Scotland
    Must be a different one to yourself, mine is just a black cable with a block connector at the headlight end with a flat pad at the other, thanks anyway hombre.
    #4
  5. laramie LC4

    laramie LC4 crash test dummy!

    Joined:
    Sep 19, 2004
    Oddometer:
    2,449
    Location:
    Tucson, Az
    you have a "dial" gauge? stock speedo?

    if so then you have a cable drive and it is not uncommon (in fact quite common) for those to snap, wear out, break, get caught on something, ......you get the idea. i finally gave up and got rid of all of it. i run my gps which does a much better job x 100. now you could probably find a mount for your phone and it would be better than the stock set-up.

    laramie :beer
    #5