Loss of power after 7000 RPM

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by cbmoggia, Apr 10, 2013.

  1. cbmoggia

    cbmoggia Adventurer

    Joined:
    Oct 30, 2011
    Oddometer:
    20
    I have a 04 950 adventure that started doing something new. During hard acceleration the bike pulls strong to 7000 rpm and then has sudden loss of power. The rpm shudders like its hitting a rev limiter and then backfires. When you shift and get on it again the motor runs fine until 7000 again. The motor runs great under 7000. Any thoughts.
    #1
  2. up2nogood

    up2nogood Adventurer

    Joined:
    Apr 2, 2008
    Oddometer:
    66
    Location:
    Sydney, Australia
    Time for a new aircleaner?
    #2
  3. cbmoggia

    cbmoggia Adventurer

    Joined:
    Oct 30, 2011
    Oddometer:
    20
    Just put a new one in before the ride.
    #3
  4. ciedema

    ciedema мотоциклист

    Joined:
    Oct 14, 2007
    Oddometer:
    2,161
    Location:
    Brisbane
    Are the spark plug caps on all the way? I have the this happen before and this was the cause.
    #4
  5. cbmoggia

    cbmoggia Adventurer

    Joined:
    Oct 30, 2011
    Oddometer:
    20
    I will check them.
    #5
  6. gefr

    gefr Life is a trip

    Joined:
    Nov 26, 2005
    Oddometer:
    4,636
    Location:
    East Med, Greece
    :eek1 :ear
    #6
  7. cbmoggia

    cbmoggia Adventurer

    Joined:
    Oct 30, 2011
    Oddometer:
    20
    Rear plug cap was loose. Thanks ciedema.
    #7