NAV V and iPhone X not playing well.

Discussion in 'Mapping & Navigation' started by tentative_rider, Nov 26, 2017.

  1. tentative_rider

    tentative_rider Wanna Be On Gravel

    Joined:
    Jul 11, 2009
    Oddometer:
    736
    Location:
    New Braunfels TX
    Hello can't get the NAV V to bluetooth link with my iPhone X.

    Anyone else had issues? Have re-booted both several times, unpaired, re-paired (pardon the pun), everything looks good, pairs up and connects at first, then says "smartphone link failed" and won't stay paired.

    I have not yet checked for firmware upgrade on the NAV V, that is my next step.

    Also have a email in to Garmin.

    Anyone's thoughts or experiences will be appreciated.

    TR
    #1
  2. JimVonBaden

    JimVonBaden "Cool" Aid!

    Joined:
    Feb 11, 2005
    Oddometer:
    72,785
    Location:
    Alexandria, VA
    It's an iPhone, so...


























    (sorry, not helpful)
    #2
    krussell and ckindt like this.
  3. Sailorlite

    Sailorlite Been here awhile

    Joined:
    Feb 18, 2006
    Oddometer:
    946
    Location:
    So. Calif.
    What's helped me pair the smartphone link between my iPhone 5s and the Nav V is to fully power-off the iPhone and then repower it (a sort of re-boot). My speculation is that the new iOS 11 is responsible for this relatively common problem.
    #3
    tentative_rider likes this.
  4. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    497
    Location:
    Webster Groves, MO
    When they released iOS 11, Apple updated its AirPlay software to AirPlay 2. I suspect that may be one the sources for the many SmartLink connectivity issues that have surfaced between the BMW Navs and iPhones. Somewhere in the upgrade, they broke something in the Bluetooth comm protocol. My problems are similar with a Nav VI and iPhone 8.


    Sent from my iPhone using Tapatalk Pro
    #4
    tentative_rider likes this.
  5. cug

    cug --

    Joined:
    May 31, 2009
    Oddometer:
    5,877
    Location:
    Sunny California
    It's a Garmin, so ...

    I'd say apply all the updates and try again. I have not tried with iOS 11 and the Nav V or VI, but have a few small issues (all on BMW side from what I can see) with the phone and the Connectivity system.

    Overall I'd say Bluetooth is an absolutely terrible system. No matter what manufacturer, everybody effs up in their own way and then you try to combine the various devices in an interconnected system (for me: 2018 GSA with Connectivity, Sena 20S, iPhone 7 with iOS 11). I leave the Nav out of the system as I never thought the implementation was particularly great.
    #5
    tentative_rider likes this.
  6. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    I just replaced my iPhone 6 with an iPhone X two days ago, but I have not yet tried to pair it with my Nav VI. That said, like many others, I had been experiencing connectivity issues between my iPhone 6/Nav VI/Smart Link app. As others have said, the speculation is that the upgrade to iOS 11 introduced these issues, so I suspect it's not your iPhone X per se that's the problem, but the iOS 11 it's running.
    #6
    tentative_rider likes this.
  7. Maxim T

    Maxim T Adventurer

    Joined:
    Aug 5, 2017
    Oddometer:
    33
    I had issues when I first updated to iOS 11 in several cars, Ford, BMW, and Porsche, I found that unpairing the device and repairing seemed to solve the iPhone issues. You have already done that.

    I have had the same issues with Garmin products in general. I also sometimes use a Galaxy S7 Edge, and have experienced reliability issue with my Nav V as well, so I am not thinking this is an iPhone specific problem.

    One thing to check, if you are using the smartlink app, ensure background services and location services are enabled.

    Another thing is that if you are around other devices that are connecting to your phone, like headphones, or even an Apple Watch try disabling those for trouble shooting purposes.

    What has worked for me in the past when I have had issues was to un-pair my headphones / helmet from my phone, pair them to the Nav V then connect to my phone via the Nav V. I will say that the bluetooth reliability of the Nav V has lead me to disabling it completeley.

    Keep in mind that from a software standpoint the Nav V comes from the same people as the Basecamp Application.

    Best of luck!
    #7
    scfrank and tentative_rider like this.
  8. ohgood

    ohgood Just givver tha berries !!!

    Joined:
    Sep 21, 2010
    Oddometer:
    6,595
    Location:
    alabama

    Bluetooth works great between phones and hearing devices/file sharing/control devices.... it's usually the middle man that messes things up.... hence the strange pairing sequences in this and other threads.

    skip the middle man, works great!
    #8
  9. tentative_rider

    tentative_rider Wanna Be On Gravel

    Joined:
    Jul 11, 2009
    Oddometer:
    736
    Location:
    New Braunfels TX
    Hey now :(

    Anyhow I also am unable to get iPhone X to pair with my Delorme InReach (the last model with the smaller screen.)

    I have fully upgraded the firmware of the InReach and the iPhone, and keep getting the same failure. It connects initially, all looks good and then disconnects.

    Thinking it's probably more iPhone X / iOS related, more to follow if I ever get it figured out.

    TR
    #9
  10. tentative_rider

    tentative_rider Wanna Be On Gravel

    Joined:
    Jul 11, 2009
    Oddometer:
    736
    Location:
    New Braunfels TX
    Update, spent about 60 minutes with Apple support, did all they suggested, and no change in the behavior of the Garmin and Delorme (Garmin) apps.

    Cannot connect to either the NAV V or the InReach through the iPhone X. All devices have the latest software and or firmware, I re-booted the phone, unpaired and re-paired multiple times, deleted the apps and reinstalled.

    Apple even did a full remote diagnostic on all bluetooth hardware and firmware, all is working fine on my new iPhone X.

    Looks like it's a Garmin / Delorme (Garmin) thing.

    I'll call Garmin tomorrow but guessing no quick fix.

    TR
    #10
    scfrank likes this.
  11. marco polo

    marco polo Long timer

    Joined:
    Sep 12, 2002
    Oddometer:
    1,070
    Location:
    Alexandria Virginia and Ottawa, Canada
    Garmin just released a software update (v 4.90) for the Nav VI. There is a fairly long list of issues it supposedly corrects, including the Smart Link connectivity issue, streaming of music from iOS devices etc. I just loaded it onto my GPS, but have no idea whether it actually does what Garmin says it does.
    #11
  12. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    497
    Location:
    Webster Groves, MO
    I have an iPhone 8 and Nav VI. I downloaded/installed the new software this morning and it does appear to have fixed the Smartphone Link connectivity (at least for me). I could receive local temperature/weather info along with traffic alerts. I was also able to browse playlists on my iPhone and see the album art for the currently playing song. However, once I start a song, I can't pause/stop it from playing, nor can I skip forward/backward. The only way to stop the music (while riding) is to turn off the Nav VI Bluetooth and then turn it back on. I'll try to clear all the Bluetooth pairings maybe this evening (iPhone, Nav VI, Sena 20S & Sena SM10) and re-pair everything to see if that clears up the music streaming. I also tried the "Here I Am" (or whatever it's called) app on the Nav VI. It sent me an email with a link to the location, but clicking the link just opens an essentially blank my.garmin.com page.
    #12
  13. cug

    cug --

    Joined:
    May 31, 2009
    Oddometer:
    5,877
    Location:
    Sunny California
    Just for the fun, I have to quote this again after this Garmin bugfix ... ;-)

    #13
  14. Maxim T

    Maxim T Adventurer

    Joined:
    Aug 5, 2017
    Oddometer:
    33
    Hey, if a company can let this through QA, I would not discount the possibility of it being an Apple issue.
    #14
  15. cug

    cug --

    Joined:
    May 31, 2009
    Oddometer:
    5,877
    Location:
    Sunny California
    Point taken ... that is embarrassing as hell ...

    [Making Groot noises] I AM ROOT ...
    #15
    Maxim T likes this.
  16. scfrank

    scfrank Old farts riding club.

    Joined:
    Oct 27, 2005
    Oddometer:
    17,744
    Location:
    Upstate SC
    One thing I know. My iPhone is a hell of a lot more intuitive and easier to use than my Nav.
    #16
    cug likes this.