Navigation 6

Discussion in 'Mapping & Navigation' started by River-Runner, Sep 14, 2017.

  1. River-Runner

    River-Runner Been here awhile

    Joined:
    Apr 11, 2010
    Oddometer:
    300
    Location:
    Portland, OR
    Do you folks use Garmin Basecamp at home to create routes/tracks that can then be transferred to the Nav 6? Can you then transfer actual tracks back to the home system?

    I'm using a Garmin Montana now on my 690 for back country travel.

    Can a guy load the Garmin 24K regional maps on to the Nav 6? I use the 24K maps on my Montana, they provide a better representation of topography - I've been known to get/be lost........
    #1
  2. hammick

    hammick Long timer

    Joined:
    Dec 2, 2007
    Oddometer:
    3,601
    Location:
    Kansas City, Missouri
    The 24k maps would load on the NAV V so I assume will also load on the NAV VI. I'm not very familiar with Basecamp but I see no reason why it wouldn't work with the NAV VI.
    #2
  3. Fastman

    Fastman Been here awhile

    Joined:
    Sep 15, 2002
    Oddometer:
    436
    Location:
    Webster Groves, MO
    I have a Nav VI and use Basecamp to plan routes/trips. I can also download/import tracks from rides I've been on and convert them to routes. As for the 24K maps, I've never used them, but I'm sure another inmate can answer that question.


    Sent from my iPad using Tapatalk Pro
    #3
  4. genka

    genka SUV hater

    Joined:
    Mar 25, 2010
    Oddometer:
    1,999
    Location:
    Baltimore, MD
    #4
    GrusMC likes this.
  5. JetSpeed

    JetSpeed Naviator

    Joined:
    Nov 28, 2007
    Oddometer:
    7,012
    Location:
    Coronado, CA - KNZY
    I have TOPO 100K on my Nav VI and it works just fine, I'm sure that the 24K versions would as well.
    #5
  6. Blissed

    Blissed Been here awhile

    Joined:
    Dec 6, 2014
    Oddometer:
    101
    Location:
    PNW
    I moved an SD card from Nav V to Nav VI. It had custom and open source topo maps installed on it. When I powered Nav VI, the maps on the SD card were working fine.
    #6