Neotech Whistle

Discussion in 'Equipment' started by ghostryder, Jan 11, 2013.

  1. ghostryder

    ghostryder Long timer

    Joined:
    Aug 20, 2004
    Oddometer:
    6,339
    Location:
    Atlanta
    About a week ago I was riding and my neotech developed a whistle from about 50 mph up. I tried re adjusting the shield, opening and closing all the vents, even paid particular attention to securing the neck strap and still it persists. Anyone have this happen....or any other ideas?
    #1
  2. cognosticator

    cognosticator Long timer

    Joined:
    Jul 30, 2007
    Oddometer:
    1,697
    Location:
    Rincon, GA
    I have had mine for 3 months and a few thousand miles and haven't noticed a whistle. Do you have anything attached to the helmet like a bluetooth headset?

    That would drive me nuts for sure :huh
    #2
  3. Twinz

    Twinz Been here awhile

    Joined:
    Sep 16, 2005
    Oddometer:
    542
    Location:
    VT
    Try wearing a bandana around your neck. I've heard that can solve the whistle problem.
    #3
  4. bomber60015

    bomber60015 Anatomically Correct

    Joined:
    Sep 11, 2008
    Oddometer:
    27,772
    Location:
    Chicago-ish
    Are deer leaping form your path?

    Seriously, remove/reseat the shield . . . . . . check that all weatherstripping/sealing strips of schtuff are still in the right place, and think about anything else that may have changed (on the bike, you . . . .)
    #4
  5. That'sLife

    That'sLife Adventurer

    Joined:
    Oct 4, 2011
    Oddometer:
    20
    Location:
    Indianapolis
    One time I accidentaly closed the chin bar with the neck strap between it and the helmet. It sat all day at work like this and created a gap until it relaxed back to normal on the way home. Can't say for sure if it was a whistle but it did create some noise.

    If the problem is repeatable on different days and you haven't changed anything on the bike or got a new jacket, then I am out of ideas.

    I hope you get it sorted though. I'll be interested to hear what you find.
    #5
  6. ghostryder

    ghostryder Long timer

    Joined:
    Aug 20, 2004
    Oddometer:
    6,339
    Location:
    Atlanta
    :lol3:lol3
    No...no dear leaping from my path. I noticed it on my 09 GS, started going nuts seeing if there was something that moved etc. Got the 12 same thing. I have no blue tooth etc attached.
    I'm going to try putting the chin guard wind thingie back on and see if that helps, thanks for the idea.
    Ill check the shield when it closes, but I tried putting my hand over the shield in different places when I'm moving. Still get the same sound. I havent changed anything, no new coat etc.
    #6
  7. dan-c

    dan-c Undescended Testicle

    Joined:
    Aug 19, 2005
    Oddometer:
    14,170
    Location:
    SATX
    Mine was whistling too until I r&r the shield. It seems to be a little more finicky to get the shild all the way in the pivots than my multitec
    #7
  8. ghostryder

    ghostryder Long timer

    Joined:
    Aug 20, 2004
    Oddometer:
    6,339
    Location:
    Atlanta
    Been looking on line and there seems to be a few more people with new shoei helmets that have the same problem. i am going to try adjusting the latching mechanisim for the face shield. Seems like a shitty thing to have happen on a helmet that is not even a year old.
    #8