New Oberon Clutch slave leaking

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by Oz_, Aug 25, 2013.

  1. 5 speed

    5 speed Been here awhile

    Joined:
    Sep 12, 2006
    Oddometer:
    993
    Location:
    Orlando Florida
    Do not be tempted to disassemble the unit. You will not get it back together and in fact will damage the u-shaped seals and will have to send it back to the factory. It was an expensive lesson for me and doubled the cost with shipping. It should not require disassembly and I doubt there is anything wrong with the seals. check the banjo bolt and suppose the plastic housing could cause an issue but I doubt it would cause a leak, it might not work well but thats it. The ball bearing should be down in the grease. If you use a paperclip or something thin you should be able to dig around and figure it out. You can always put another one in there. Good luck

    If you call ask for Steve
    #21
  2. ICERIDER

    ICERIDER Adventure Rider

    Joined:
    Jun 23, 2006
    Oddometer:
    854
    Location:
    Stanley Falkland Islands
    Could be going around in circles here... the amber is residual from around your clutch rod. Clean it. Ride it. Enjoy your trip!
    #22
  3. Oz_

    Oz_ Adventurer

    Joined:
    Jan 18, 2011
    Oddometer:
    23
    Location:
    Manchester, UK

    Turned out to be the clutch push rod seal in the end! Must have been disturbed when the old slave was removed and the new one fitted. Seal swapped and not a drop of oil since.

    Currently sat on the balcony in the Dolomites.
    #23
  4. ICERIDER

    ICERIDER Adventure Rider

    Joined:
    Jun 23, 2006
    Oddometer:
    854
    Location:
    Stanley Falkland Islands
    Thanks for the info. I'll carry one of these seals with me from now on.
    #24