New Safari tank & canisterectomy - now won't start

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by procycle, Aug 5, 2013.

  1. procycle

    procycle Long timer

    Joined:
    Jun 7, 2007
    Oddometer:
    3,123
    Location:
    Center of the DR650 universe
    2011 990 Dakar 5500 miles.

    I just installed new Safari tanks and deleted the SAS and canister system wile it was all apart. The valves were all in spec.

    Nothing sounds unusual. The motor cranks strong and I can hear the fuel pump running for a few seconds every time I turn the key. I've cycled the key on/off more than a twenty times and tried starting at least a dozen.

    I checked for spark - all good so I know it's fuel. It sure seems like it shouldn't take this long to prime the injectors.

    Any ideas?
    #1
  2. procycle

    procycle Long timer

    Joined:
    Jun 7, 2007
    Oddometer:
    3,123
    Location:
    Center of the DR650 universe
    OK, sometimes the best way to solve a problem is to sit down and write a post about it.

    Turned out the be the fuel 'quick disconnect'. It was not completely pushed together. A little additional nudge on the two halves of the connector and the beast starts right up.
    #2
  3. Dagwood_55

    Dagwood_55 Long timer

    Joined:
    Jun 23, 2007
    Oddometer:
    1,381
    Location:
    The Ozarks
    Such a dummy, I've never done that!!

    Well, meybe once....

    Or twice......

    OK, OK, I admit to doing it more than twice, but thats all I admit to.
    #3