New scala rider G4 won't turn on

Discussion in 'Equipment' started by Jaimoto, Dec 5, 2011.

  1. Jaimoto

    Jaimoto Spaniard in Chile

    Joined:
    Sep 26, 2007
    Oddometer:
    1,396
    Location:
    ViƱa del Mar, Chile
    I bought a scala rider G4 powerset a couple of weeks ago. Installed the latest software in both units and they were connected with a Blackberry (mine) and an Iphone (a friend). Everything was working fine and the only function that we didn't use was the Voice Dial.

    Two days ago, both scala rider stopped working, no matter during how much time we press the Mobile button, they just don't turn on. Yep, both. Almost at the same time :hmmmmm

    They show a solid red light while charging but that's all they do.
    It sounds stupid but .. both units stopped working after we use the Voice Dial function. it looks like a software failure but I just can't believe they won't work because of using one of its functions.

    I already emailed Cardo so hopefully the'll take care of me. Meanwhile, I would like to know if any of you had a similar problem and how did you fix it.

    Thanks!
    #1
  2. pond

    pond Adventurer

    Joined:
    Mar 18, 2009
    Oddometer:
    45
    Location:
    Austin, TX
    My friend and I just got our Scala Rider G4 set on Monday and last night his started showing the exact same problem that you mention. It shows red when charging, but won't power on. We bought the two-pack. Mine still works; his doesn't. Have you heard back, yet?
    #2
  3. pond

    pond Adventurer

    Joined:
    Mar 18, 2009
    Oddometer:
    45
    Location:
    Austin, TX
    My friend called them up and got an RMA (return merchandise authorization) for the faulty unit. He said support was fast (only took about a minute). Not sure what else to do at this point.

    You can contact Cardo Systems support at:

    USA and Canada: 1-800-488-0363
    International: +4989 450 36819
    #3
  4. flybitten

    flybitten n00b

    Joined:
    Aug 28, 2012
    Oddometer:
    1
    I had the same problem with my G4. One month old and all of a sudden 1 of the 2 units won't turn on. At first, I charged it for about 3-4 hours thinking the battery died. After the red light went off, I pushed the mobile button but nothing happened. I tried plugging it into the PC to see if it would connect, but only the red light came on and the unit wouldn't turn on. I charged it again for another 3 hours, nothing. I did the reset thing by plugging it in for 10 seconds and unplugging it and tried to turn it on, still nothing.

    I let the unit sit for about 2 days getting some paperwork ready to send the unit to Cardo. I tried to turn the unit on again and all of a sudden the blue light flashed! But it wouldn't remain on. I plugged it into the PC, and the unit finally turned on (hold down volume up and mobile for a few seconds). It's alive! So I removed it from the PC and plugged it into the wall to charge for 3 hours. I turned it on, and now it's working again. I don't get it, but happy that it works! :clap
    #4
  5. GatorGuy

    GatorGuy n00b

    Joined:
    Jan 16, 2013
    Oddometer:
    1
    I had mine turn off by itself after I made my first phone call and used the VOX feature to answer the phone. When I got home to "turn it off" much to my surprise, it was already turned off. When I tried to turn it on, it would not turn on. :kboom

    When I plugged it into the charger, the red light would turn on, but even following the "reset" instructions of charging it for 10 seconds and unplugging it, did not work. I waited several days and tried to turn it on many times unsuccessfully. I found this thread and thought that maybe there is a VOX issue. I was going to call Cardo Systems for warranty work, but procrastinated for almost 2 weeks. Today, I brought it with me to work to finally get it serviced and when I turned it on, it powered up, paired with my phone and turned itself off. :huh

    I did this several times. I finally plugged it into the computer and turned it on while plugged into the computer and so far it has stayed on. I called Cardo Systems and they were very nice and quick to give me directions on how to send the unit back. They said it would take about two weeks to get it from me, look it over, fix it (or replace it) if needed, and return it to me. I gave them the URLto this thread and the support person said he didn't think it had anything to do with the VOX or voice feature as this has happened before, but is not a regular problem with the units. :hmmmmm
    <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" /><o:p></o:p>
    I guess packing a billion features into a tiny little electronic piece of equipment is only good as long as it works. We'll see... :beer
    ---
    Shut Up and Ride!!!
    www.GatorRiders.com
    #5
  6. dillendger

    dillendger n00b

    Joined:
    Jun 7, 2014
    Oddometer:
    1
    Hi to all!

    I got last week the same problem as topic writer and my set is as new, about 5 times used... my friend supposed to remove battery, so we disassembled the case, removed the battery from pins for about 10 sec and installed it back and uoooljaaaa... it starts to work! I Gues it has some electric fault while last charging or some else... any way if Your Scala if Faulty like discribed at 1st topic, :deal, REMOVE BATTERY FOR 10 SEC and that's all... :freaky
    #6
  7. Scott_PDX

    Scott_PDX Leisure Engineer

    Joined:
    Oct 18, 2010
    Oddometer:
    4,020
    Location:
    Portland...the newer one on the left side.
    Hmmm....that might explain that when my G4 stopped working, months later when I decided to try it again and charged it first it began working. Wondering if I fully discharged the battery and it came back to life. Really wish they would make replaceable batteries, I hate all the throw-away stuff in our lives.
    #7
  8. asuarez

    asuarez n00b

    Joined:
    Jun 21, 2015
    Oddometer:
    1
    Location:
    Porto Alegre, RS, Brazil
    I have the same problem
    It does not turn on one of my headsets
    If I plug to charge it, it starts blinking the blue light, instead of red light

    Cant do anything, and I just use it once

    Any idea what to do?
    #8
  9. k-moe

    k-moe Long timer

    Joined:
    Jun 27, 2012
    Oddometer:
    3,284
    Do this

    :deal
    #9
  10. Izzy3

    Izzy3 Freak of Unnature

    Joined:
    Aug 7, 2011
    Oddometer:
    319
    Location:
    NOVA
    The software is crap. Connect more than one device and try to use VOX and it shuts itself off.

    I'm using a Qz just for music and phone but when I pair the GPS unit to it, it will shut itself off within 30 minutes. I turned VOX all the way down and stopped pairing the GPS and now it works well for music.

    No software updates on the Cardo site. :(:
    #10