Rally Navigator - Create Rally Roadbooks with Google Earth and GPS

Discussion in 'Racing' started by RenoMoto, Dec 29, 2012.

  1. Seth S

    Seth S Will _____ for _____

    Joined:
    Jul 19, 2004
    Oddometer:
    4,984
    Location:
    sanity?
    So I what sort of easter eggs have you guys hidden in the software?
  2. homerj

    homerj 742 Evergreen Terrace

    Joined:
    Apr 11, 2005
    Oddometer:
    5,864
    Location:
    742 Evergreen Terrace
    I thought I'd just forgotten to save :D We really appreciate all that you've done, and all that you continue to do. Have you identified a tell-tale of routes that won't be saved? Knowing that might help us take steps to mitigate. Or is it random so far?
  3. Yellow Pig

    Yellow Pig Allergic to asphalt!

    Joined:
    Oct 28, 2004
    Oddometer:
    8,260
    Location:
    Kalifornia
    Hey HomerJ can I peek at your routes? Mine is the Westcreek loop. Feel free to us it. I have yet to pre-run it, but plan to do so this sunday.
  4. fetid_swamp

    fetid_swamp Been here awhile

    Joined:
    Nov 23, 2008
    Oddometer:
    748
    i was having that prob on an ear;lier version. was driving me wild.
    then i updated firefox from the ancient version i orig had.
    dont know if it was the fix but since then with an up to date firefox and the older GE, all has been good.
  5. Motorfiets

    Motorfiets Long timer

    Joined:
    Oct 1, 2007
    Oddometer:
    3,000
    Location:
    Southern California
    So glad I'm not the only one crashing the software!! Haha

    Thanks so much for all the hard work Mike!!!!
  6. Yellow Pig

    Yellow Pig Allergic to asphalt!

    Joined:
    Oct 28, 2004
    Oddometer:
    8,260
    Location:
    Kalifornia
    So what do you do if while you are working on the route you DO NOT get the "Project saved" message?


    Is there a way to force the software to save the work done?

    It looks like the software does not like to do more than a few saves before it stops saving properly.
  7. RenoMoto

    RenoMoto Rally Navigator

    Joined:
    Jul 6, 2007
    Oddometer:
    317
    Location:
    Sitting at My Computer


    Guys:

    I'm really pulling my hair out on this save issue....suffering along with the rest of you.

    Stand by for some code updates that (hopefully) will get this fixed.

    Thanks for your patience, this bug has been much more difficult that I imagined.

    Mike
  8. beechum1

    beechum1 Dandole Gas al Burro

    Joined:
    Oct 14, 2007
    Oddometer:
    9,593
    Location:
    Not home in Tijuana
    Do what you do buddy. Thanks for even having this tool to begin with!!
  9. RenoMoto

    RenoMoto Rally Navigator

    Joined:
    Jul 6, 2007
    Oddometer:
    317
    Location:
    Sitting at My Computer
    Guys:

    Please include the following information when reporting bugs:


    1. Operating system eg. WindowsXP, Windows 7 or OSX
    2. Browser MSIE, Firefox, Opera. Make sure to report the browser version as well
    3. Google Earth version
    4. A complete description that lead to the bug.
    5. Try to replicate the bug yourself and in that case describe a clean replication scenario.
    6. Include details such as which gpx file and attach it
    The more detail the better - when we can replicate things, they get fixed.

    Send info to mike@rallynavigator.com and include any GPX files that you have used

    Thanks!
    Mike
    <!--[if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:TrackMoves/> <w:TrackFormatting/> <w:punctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:DoNotPromoteQF/> <w:LidThemeOther>EN-US</w:LidThemeOther> <w:LidThemeAsian>X-NONE</w:LidThemeAsian> <w:LidThemeComplexScript>X-NONE</w:LidThemeComplexScript> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <w:DontGrowAutofit/> <w:SplitPgBreakAndParaMark/> <w:EnableOpenTypeKerning/> <w:DontFlipMirrorIndents/> <w:OverrideTableStyleHps/> </w:Compatibility> <m:mathPr> <m:mathFont m:val="Cambria Math"/> <m:brkBin m:val="before"/> <m:brkBinSub m:val="&#45;-"/> <m:smallFrac m:val="off"/> <m:dispDef/> <m:lMargin m:val="0"/> <m:rMargin m:val="0"/> <m:defJc m:val="centerGroup"/> <m:wrapIndent m:val="1440"/> <m:intLim m:val="subSup"/> <m:naryLim m:val="undOvr"/> </m:mathPr></w:WordDocument> </xml><![endif]-->
  10. Hayduke

    Hayduke ///SAFETY THIRD/// Super Moderator

    Joined:
    Jun 8, 2004
    Oddometer:
    45,092
    Location:
    Salida, coloRADo
    I'm working on a pretty big project and so far so good for me. :thumb
  11. beechum1

    beechum1 Dandole Gas al Burro

    Joined:
    Oct 14, 2007
    Oddometer:
    9,593
    Location:
    Not home in Tijuana
    I have to get my RB switch wired up, then I can start doing some real research.
  12. Yellow Pig

    Yellow Pig Allergic to asphalt!

    Joined:
    Oct 28, 2004
    Oddometer:
    8,260
    Location:
    Kalifornia
    I just started having issues w/ it not saving changes to the road-book. It used to work fine, but despite having made no changes to my computer or the installed software after a couple of saves it starts NOT saving my data.

    Windows 7 Home Premium Edition service pack 1
    FireFox 19.0.2
    Google Earth 6.2.2.6613

    Was working fine, the on Monday I started adding detail to the road-book after having pre-run a portion of the route. When I go to save the changes initially I see the project updated text, then after a few saves it just saves (I see the spinning dots) but do not see the project updated text. At this point if I click out of the page and then come back all the data I added ( new tulips, text annotations, new way points, etc...) is not saved. It seems like it can only take 2-3 proper saves, then stops saving the info.


    e-mail sent.

    <table style=" margin-top:0px; margin-bottom:0px; margin-left:0px; margin-right:0px;" border="0" cellpadding="0" cellspacing="2"><tbody><tr><td>
    </td></tr></tbody></table>
  13. Motorfiets

    Motorfiets Long timer

    Joined:
    Oct 1, 2007
    Oddometer:
    3,000
    Location:
    Southern California
    bingo!!!! exactly what is happening to me!
  14. Hayduke

    Hayduke ///SAFETY THIRD/// Super Moderator

    Joined:
    Jun 8, 2004
    Oddometer:
    45,092
    Location:
    Salida, coloRADo
    Screenshot of a little loop I'm working on. :evil

    [​IMG]
  15. oossie

    oossie Been here awhile

    Joined:
    Jul 4, 2007
    Oddometer:
    118
    Location:
    dutch mountains
    Cool!!!
  16. oossie

    oossie Been here awhile

    Joined:
    Jul 4, 2007
    Oddometer:
    118
    Location:
    dutch mountains
    when you try the url rallynavigator.com without www i get a error.

    de normal url entry is working fine. it's a minor issue, but mentioning worth:evil


    Importing a GPX track file only 2 lines are created, start and endpoint. Previously this worked like a charme.
    Here's the url to the route http://www.rallynavigator.com/routes/453
  17. RenoMoto

    RenoMoto Rally Navigator

    Joined:
    Jul 6, 2007
    Oddometer:
    317
    Location:
    Sitting at My Computer
    Team:

    Sorry to be slow on the updates - I was busy...doing something "Diabolical" :)

    We just released an update to Rally Navigator - fixed a lot of stuff under the skin and a few bugs. We won't totally fix the "Save" issue till Dave gets back from his Taureg Adventure.

    In the meantime, enjoy:

    • Added a new "create roads" interface, you no longer have to go into a specific tab to add a road
    • Started an "Add Text" feature to add simple text descriptions with a quick drag and drop
      • Both of these need some help on the GUI, but the idea is coming along.
    • Fixed an occasional text bubble pop up over a newly created track handle
    • Cleaned up the header a bit
    • Fixed some weird behavior around the first and last WP in a route
    • Added 120 speed limit icon
    • Removed a duplicate "Ford' icon
    • Improved load and save function - its still not perfect.
    [​IMG]
    We probably created a few new bugs also...

    Take it for a spin at www.rallynavigator.com

    Let me know how it goes,
  18. HogWild

    HogWild Scott Whitney

    Joined:
    Nov 12, 2003
    Oddometer:
    3,102
    Location:
    SoCal USA
    Mike's Diabolical ride:

    [​IMG]
  19. Yellow Pig

    Yellow Pig Allergic to asphalt!

    Joined:
    Oct 28, 2004
    Oddometer:
    8,260
    Location:
    Kalifornia
    We won't totally fix the "Save" issue till Dave gets back from his Tuareg Adventure.



    Well at least you guys have your priorities right. :wink:
  20. Hayduke

    Hayduke ///SAFETY THIRD/// Super Moderator

    Joined:
    Jun 8, 2004
    Oddometer:
    45,092
    Location:
    Salida, coloRADo
    Crap. Now it's erroring out on me, too. Stops saving, etc. Also, when I re-open a route, now there are now "connections" between the points, if that makes sense.