Royal Enfield 350 help!

Discussion in 'Thumpers' started by OU81, Dec 8, 2012.

  1. OU81

    OU81 n00b

    Joined:
    Dec 7, 2012
    Oddometer:
    3
    So i am the new owner of a 2007 Enfield that i got to ride in India. All has been going good for the past 300 miles or so but shes starting to make some bad noise. it seems when ever im in lower or mid RPM going up hill or just pulling back on the throttle she makes a klunk klun klunk noise. on flat ground at steady speed the sound aint there. wonderin if any one has had this and if it is piston slap or it need a new main baring or what. only ganna keep her for about 4 or 5 more weeks then offloading her and going home. Taking her to the shop in a few days but would like to see what others would have as advice so i can compare it to what the mechanic says (If he speaks English). any suggestions will help. Thanks guys!!!
    #1
  2. Beezer

    Beezer Long timer

    Joined:
    Oct 26, 2004
    Oddometer:
    6,858
    Location:
    Anchorage, formerly Spenard (hub of the universe)
    I'll go out on a limb here...

    [​IMG]

    thats my buddies' rental bike when we were on tour over there.... the mechanics that came along brought a spare crank bearing. why? because it's not the first one they had to change 1000 miles from home. the good news is they did it in a couple hours in a parking lot. bike had 11-12000 miles on it

    [​IMG]



    "klunk" usually means bottom end... piston slap is a "lighter" sound...
    I could be wrong though.... so maybe a little more information would help.
    #2
  3. OU81

    OU81 n00b

    Joined:
    Dec 7, 2012
    Oddometer:
    3
    Beezer thanks for the info and the pics! it makes me feel better to know you were able to have it done in a parking lot! if i take her to a shop they should be able to fix her in no time!:D
    #3