saving files in GPX from Garmin

Discussion in 'Mapping & Navigation' started by rogerdodger, Sep 5, 2012.

  1. rogerdodger

    rogerdodger Been here awhile

    Joined:
    Nov 3, 2006
    Oddometer:
    545
    Location:
    Currently in Australia
    Funny whenever I have a GPS problem this is the first place I come for help! has worked every other time, so lets hope you can help this time.

    Ok I can download my tracks from my Garmin 60CSx to mapsource, but I want to save it in a GPX format. So I can then load the data into JOSM to then manipulate and upload to Openstreetmaps. But when I go to save it as a GPX file I get an error message and then Mapsource closes. The error message doesnt have any number to it, but it has a pop up screen that asks if I want to send the report to Garmin. Ive done this but not heard anything back. Any clue what is going on? a conflict of some sort Im guessing. Or maybe a simpler question would be how do I save tracks from my GPS in a GPX format?

    thanks for any help
    Rog
    #1
  2. OceanMtnSea

    OceanMtnSea Pretty Dogged

    Joined:
    Apr 19, 2010
    Oddometer:
    639
    Location:
    left middle Saskatchewan & entering middle BC
    It is a MapSource issue - which Garmin is no longer servicing.

    I have occasionally had the same problem with MapSource, but not consistently (sometimes it does save to GPX??) so I converted to BaseCamp.

    There are 2 options for you from my experience: 1) Save the track in MapSource in Gdb format - then use GPSBabel here: http://www.gpsvisualizer.com/gpsbabel/ to convert to GPX. 2) Download Garmin Basecamp here: http://www8.garmin.com/support/download_details.jsp?id=4435 and do the save to GPX format in Basecamp.

    For a quick fix Option 1 is the way to go as using Basecamp has a learning curve to go through, but it is quite similar to MapSource.
    #2
  3. Countdown

    Countdown Long timer

    Joined:
    Oct 20, 2003
    Oddometer:
    6,010
    Location:
    Carson City/Ridgecrest
    What version of MapSource?

    Never had this problem with 6.13.7
    #3
  4. rogerdodger

    rogerdodger Been here awhile

    Joined:
    Nov 3, 2006
    Oddometer:
    545
    Location:
    Currently in Australia
    Yeah I'm running 6:16:3, so maybe the problem is there.
    #4
  5. rogerdodger

    rogerdodger Been here awhile

    Joined:
    Nov 3, 2006
    Oddometer:
    545
    Location:
    Currently in Australia
    Awesome! Havent tried either yet, but that looks like it will take care of the issue one way or the other. Thanks!
    #5