Substitute for broken Scala Rider G4 (intercom)?

Discussion in 'Equipment' started by bokad, May 2, 2012.

  1. bokad

    bokad Difficult Child

    Joined:
    Nov 22, 2011
    Oddometer:
    396
    Location:
    Wherever it is warm.
    My Scala Rider G4 (intercom and bluetooth) died after 5 months of use and Cardo Systems isn't being nice about replacing it.

    What is a good substitute product?
    I use it primarily for talking to my hack monkey/navigator and listening to music from my bluetooth phone.
    Price not important.
    Reliability very important.
    #1
  2. ww73

    ww73 Been here awhile

    Joined:
    Mar 11, 2009
    Oddometer:
    137
    Location:
    Sammamish, WA
    #2
  3. MK96xj

    MK96xj 100% Seat Time

    Joined:
    May 6, 2007
    Oddometer:
    403
    Location:
    Asheville NC
    I am suprised Scala will not replace it. Do you not have a reciept or did you buy it second hand?

    I have had very good experiences with them in the past. Usually shipping me a replacement unit before I even shipped my bad one back.
    #3
  4. bokad

    bokad Difficult Child

    Joined:
    Nov 22, 2011
    Oddometer:
    396
    Location:
    Wherever it is warm.
    I bought it first hand five months ago.
    I'm in the middle of a long overseas trip. Despite that the unit is faulty they will not pay for return shipping. Shipping to them from Indonesia would either be very slow or very expensive. Nor will they ship me a replacement before they get the old one back. Not even to a relative of mine in the US that would forward it to me. Also they are insisting on a receipt. Oddly enough I'm not carrying it with me. I registered the product (serial numbers, bar codes, and all) with them when I originally bought it so I could get the software updates. But that registration doesn't count towards warranty registration they say.

    What they have told me on the phone and in e-mail is that there is nothing they can do to help until I return to the US and find the receipt. It had some glitches anyway and now it's dead after five months. I'm looking for a new brand!

    #4
  5. PhotoBiker

    PhotoBiker Please insert title here

    Joined:
    Sep 26, 2008
    Oddometer:
    1,442
    Location:
    Southern Maine
    Sena, plus they have a 2 year warranty.

    Look around for Adam from Rocketmoto, not only will you get a good deal, he will stand behind whatever he sells.
    #5
  6. stealth916

    stealth916 n00b

    Joined:
    Jan 18, 2010
    Oddometer:
    3
    My Scala G4 also died today. It has been working fine for about 5 months. Today it was working fine for my ride into work. I turned it off as normal. Then when I went to leave work, I powered it up and heard nothing - all of a sudden the blue light is stuck on. Of course this condition isn't documented in the manual, even though all other status light conditions thoughtfully are. PRO TIP TO SCALA: Document EVERY status light condition. And of course, Scala support was not in the office at exactly 5:01PM EST, which is only 2:01PM on the west coast where more than half their clients are located.

    I have plugged it in to the power brick, plugged it into the PC, all for varying intervals, and the blue light just stays on. The PC does not recognize that anything has been plugged in.


    EDIT - UNIT FIXED:
    Here's where, before I present my solution, I give a big virtual foot in the rear to ANY company who makes consumer electronic devices without a real, hard, inline, physical POWER CIRCUIT INTERRUPTER aka ON/OFF SWITCH. Your 'soft' switches are nice, until the logic behind them freezes up. And they require a parasitic load on the power source. There are times when I'd like to LEAVE something turned off for a long while and not return to find a piece of garbage formerly known as a battery powered gadget. AS A BONUS SCALA - such a switch would work as a 'reset' for you, and likely stave off flames such as you're getting in this thread.

    To fix my Scala Rider G4 when the blue light was stuck 'on' and the unit would not respond to any buttons at all - I removed the four enclosure screws using a T6 driver (one of the screws is behind the antenna when it is retracted. remove this screw but do not remove the screw holding the antenna swivel), opened the unit up just a little, only about a half inch, and using a dental probe I slightly lifted the battery connector from the socket on the PCB, for one second, and then reconnected it by pushing the connector back down. Now my unit is working again, as I predicted it would. This is a LOGIC problem, a bug if you will. Removing the power is the reset. The battery connector is located at the FRONT (Forward) of the unit. You may be able to completely lift away and remove the back half of the unit for better access to the battery connector, but I elected not to try since I had enough access by just lifting it away a small bit, and I didn't want to find out the hard way how it was all packaged :)

    Now the unit is turning on and off normally, it was still paired with my phone (I did not have to re-pair it). It is charging and working like normal.

    Two words: POWER INTERRUPT

    I chose to open it and try this, rather than wait for the battery to die first and the blue light to go out and see what would happen, because the circuitry that protects the lithium ion battery from low voltage (deep discharge) may have also been locked up and not working while the unit was in this frozen condition, and the battery may have discharged too deeply if I had waited it out.
    #6
    adrian_vg likes this.
  7. stealth916

    stealth916 n00b

    Joined:
    Jan 18, 2010
    Oddometer:
    3
    UPDATE in case this helps any Google searchers: I have had to reset my Scala 4 times or so since this started happening. The unit always works fine for a whole ride, the problem never starts until you turn it off, or on - somewhere in that off/on cycle.

    After a reset the Scala will work for a week or so, perhaps six to ten on/off cycles - then it will lock up again, always after turning it off or trying to turn it on.

    I have had it happen right after charging so I don't think battery status is the problem. Today, I went to turn it on for the ride home and noticed the Scala locked up again only this time the BLUE LIGHT WAS STUCK OFF, which was a first, and nothing would happen regardless of button pressing, charging etc which is normal when it freezes. To the casual observer it would appear totally dead this time and I feared myself, perhaps it had finally given up the ghost. But the red light did illuminate for a charge cycle then extinguish after a few hours. So sensing it just needed a reboot, I opened it and reset the battery connector and voila, I am ready for tomorrow's commute ride.

    I am using the term reboot now, because like a Windows 3.0 PC, this thing must be rebooted after not too many uses. Call it the 'blue light of death'.

    If this keeps up I may just have to call Scala - maybe this is defective hardware manifesting itself as a software problem. If any replacement does it to me again, I am going to wire in a minature reset switch to the power lead, accesible from outside the case, and call it good - because I love this Scala rider and I have to keep it working.
    #7
  8. 67BustedKnuckles

    67BustedKnuckles n00b

    Joined:
    Feb 15, 2013
    Oddometer:
    1
    I had this same issue on mine. I put mine in the fridge, because it felt warm, while searching for solutions via the google machine, where I came upon this thread. I checked it about two hours later and the light was off. I turned it back on and checked with my phone. It seems to be working...for now. Couldn't agree more with having a power interrupt on electronic devices.

    So just saying thanks for your post and bumping the thread, despite being an evil Harley rider (The wife should be getting a Ural within the year, hopefully a 2WD model).

    Cheers
    :beer
    #8
  9. adrian_vg

    adrian_vg n00b

    Joined:
    Jul 21, 2015
    Oddometer:
    1
    Location:
    Sweden
    Awesome, thank you for this easy fix!
    I had this happen to me just the other day and was pretty irritated about it...
    #9