Super Enduro Fuel Pump, Help out an Idiot

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by kanur, Dec 31, 2012.

  1. kanur

    kanur cu new er

    Joined:
    Nov 27, 2007
    Oddometer:
    775
    Location:
    Cape Girardeau, MO
    Dear Orange Crush,

    OK, so I had the tank off my SE to put in a new air filter and put the stock tank on for awhile. After getting it together and putting the fuel back in I was ready to take a little spin. It would start and die, start and die...............

    At first I would hear the fuel pump and then not........and then Doh! :huh I hadn't turned the fuel on. Now the fuel is on but will not start and no fuel pump sound. I check the fuse first and it is good, check the fuel pump connection and I am not getting current to the pump. Checked the fuse again and even put in a new one, nothing at the pump.

    What am I missing? Is there another fuse or relay?

    Signed,
    Dumb Dumb
    #1
  2. dogsslober

    dogsslober No neck tie, Ti neck

    Joined:
    Feb 10, 2009
    Oddometer:
    1,154
    Location:
    Morgan Hill Ca
    I would pull the pump and check to see if the points are stuck together. Happened to mine and was able to take a finger nail file to them to get going again. Then ordered a Dr Bean kit.
    #2
  3. kanur

    kanur cu new er

    Joined:
    Nov 27, 2007
    Oddometer:
    775
    Location:
    Cape Girardeau, MO
    Thanks for the reply dogsslobber, turns out I'm an idiot X2 :baldy

    I was going to pull the lines off the pump to see if maybe it had hyrdo locked from pumping dry. When I looked up at it not only had I not turned the fuel on but in my hurry to get a short ride in before the snow and ice started again i hadn't connected the quick connect going to the carbs. Plugged that in and it fired right up.

    I do find it odd that the connection going to the pump will not show current with my tester. The horn wire lights it bright and the fuel sensor makes it glow dim but nothing for the pump :scratch

    To late to go for a ride, getting a rain,sleet,and snow mix :lol3
    #3
  4. DSM8

    DSM8 Where fun goes to die....

    Joined:
    Aug 1, 2005
    Oddometer:
    4,097
    Location:
    Glendora, Ca
    There is only current to the pump when it need fuel which trigger the points. Think of it as a momentary switch within the pump and not a constant on like an EFI pump.
    #4
  5. kanur

    kanur cu new er

    Joined:
    Nov 27, 2007
    Oddometer:
    775
    Location:
    Cape Girardeau, MO
    Ahh, that makes perfect sense.
    #5
  6. Head2Wind

    Head2Wind MotorcycleMayhem

    Joined:
    Mar 13, 2006
    Oddometer:
    2,626
    Location:
    NorthWet Washington
    the correct answer is there is voltage applied to the pump PRE start for about 5 seconds, then it gets turned off by the ECU if no ignition pulse sensed (engine running). If you were checking after that time, then there will be no power to the pump circuit.... On a dry carb prime I will cycle the key on then off several times, listening for the pump (OEM Mitzu pump BTW, the Facet does not stop clicking when it meets set pressure.) to stop clacking, cycle key one more time, then begin normal start sequence.
    #6
  7. Iflylo

    Iflylo Adventurer

    Joined:
    Apr 5, 2011
    Oddometer:
    22
    Location:
    South Africa
    Connect yr tester to the positive wire on the fuel pump and then switch the ignition on.I think you should get an ignition supply to the pump.I lost ignition on mine when there was an open circuit on the multi-plug from the ignition switch behind the dash.
    If your pump is playing up maybe you should use the opportunity to fit a Facet.
    Happy New Year
    #7
  8. markie_wales

    markie_wales Been here awhile

    Joined:
    Nov 12, 2005
    Oddometer:
    942
    Location:
    Hampshire, UK
    Surely not?? Who'd do something like that and spend 15 mins trying to diagnose it?? Surely no one on here??

    Walks away, hands in pockets, looking down, whistling......

    cheers

    Markie
    #8
  9. Phil in K.C.

    Phil in K.C. Been here awhile

    Joined:
    Dec 2, 2008
    Oddometer:
    554
    Location:
    just outta town
    Sounds like you should have just gone to the cabin!
    #9