trouble downloading on Streetpilot iii

Discussion in 'Mapping & Navigation' started by bikecrawler, Jul 28, 2009.

  1. bikecrawler

    bikecrawler Adventurer

    Joined:
    Oct 3, 2008
    Oddometer:
    20
    Location:
    Southern Idaho
    I recently purchased a Streetpilot 3 from a fellow rider on the forum. The GPS has north east on it and I live in the north west. It shows major hwys but that is it, so I purchased City Navigator north america. When I down load the DVD onto my computer with the coupon code I recieved with the disk it recognizes my gps but it keeps saying no internet connection. Is there something I am missing? I know I have connection to the internet. Any help would be great. I've called to talk to garmin support and waited 40 min. and no help.
    #1
  2. Railbender

    Railbender Long timer

    Joined:
    Oct 3, 2006
    Oddometer:
    1,050
    Location:
    NW PA
    What OS are you using and what version of Mapsource do you have? Vista does not play nice with some older versions of Mapsource.

    :freaky
    #2
  3. bikecrawler

    bikecrawler Adventurer

    Joined:
    Oct 3, 2008
    Oddometer:
    20
    Location:
    Southern Idaho
    I am using mapsource 7.0 I believe.
    #3
  4. Railbender

    Railbender Long timer

    Joined:
    Oct 3, 2006
    Oddometer:
    1,050
    Location:
    NW PA
    No such animal. 6.15.6 is the latest version. Since you mentioned a DVD I assume you have a fairly recent version of City Nav which should have a somewhat recent version of Mapsource. I just loaded an old City Nav 5 and had the same problem but it was resolved by updating Mapsource. What operating system are you using?

    :freaky
    #4