Trouble With '07 Uly

Discussion in 'Moto Bellissima: All Other Dualsports' started by vtwin, Jun 19, 2008.

  1. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    I've had a few annoying issues with my Uly. Rear wheel bearing, drive belt chaffing the guard and mostly the surging/backfire and at times even dying. They replaced a few parts and did a tps adjustment and seemed to make it better. At times, on idling warmup, it has died. Starts right back up, but that never happened before. Today it was warm, about 96deg F, and pulling into my driveway after my 25 mile commute, it died. It wouldn't restart and I didn't hear the fuel pump. After several tried, it finally started. Has the Uly had any fuel pump issues? If it happens again tomorrow (forecast near 100 deg) I'll have to bring it in again. Still love the bike though.
    #1
  2. FT BSTRD

    FT BSTRD Welcome to The Dispersive

    Joined:
    Aug 6, 2005
    Oddometer:
    4,338
    Location:
    TN, WHERE THE MEN ARE MEN AND THE SHEEP ARE SCARED
    Have the dealer check the fuel pump.

    I had problems with mine and it was replaced at 1,000 miles.
    #2
  3. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    Thanks FB
    #3
  4. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    So far the Ulysses has been pretty trouble free until about 5 months ago I noticed this....:eek1

    <iframe width="425" height="349" src="http://www.youtube.com/embed/EDqI1mgtiRw" frameborder="0" allowfullscreen></iframe>

    A bit of research has reveiled a few inmates had this issue. Skifastbadly and Hughlysses to name two. I've posted it in Badweb as well, so finally getting down to removing the engine.
    #4
  5. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]


    There's alot involved, so I'm cookbooking it and just working a couple hours a day on it after work. More to come....
    #5
  6. Florida Lime

    Florida Lime Long timer

    Joined:
    Sep 5, 2008
    Oddometer:
    2,516
    Location:
    As stated, and as often as possible -R'ville, N.C.
    I can't see or hear what is there, but I don't have to.

    My 2007 is the same.

    Want another one to do after you practice on yours ? :D
    #6
  7. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    That engine knock wasn't there before I racked up 30K on it. Always used Harley Synthetic, hmm, maybe that's the problem.:lol3 Hughlysses had the same noise although his was a bit louder. His ended up being the crank pin with alot of play from the front rod. Mine sounds like it's from the front as well. Good luck on yours, recommended fix is an '08 crank with the larger pin, 1 1/2" I think it was. '07s have the 1 1/4".
    #7
  8. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    Ok, really wasn't too bad, and now it's out.

    [​IMG]

    Good thing I have an engine hoist!

    [​IMG]

    [​IMG]

    Tomorrow, I'll start tearing down the engine. Hopefully it's what I think it is.
    #8
  9. larryboy

    larryboy Chopper Rider

    Joined:
    Jan 9, 2005
    Oddometer:
    15,368
    Location:
    On a set of 50,000 mile tires.
    Good catch, some of them threw the front rod right out. :eek1
    #9
  10. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    Sure glad it didn't get to that point Larry.:D Some more work done today.

    [​IMG]

    [​IMG]

    Pulled the front head off first and started to think I made a big mistake as I found the exhaust manifold a bit loose, nah, didn't sound like an exhaust leak.:shog

    Front rod and piston felt ok, so I pulled the rear head and found the rear rod with at least 1/16" of play with my calibrated fingers. Didn't know whether to be happy or not, but at least I found something not right.

    [​IMG]

    [​IMG]
    #10
  11. cardoctor1

    cardoctor1 Been here awhile

    Joined:
    Nov 21, 2010
    Oddometer:
    554
    Location:
    horsham pa
    interested in the outcome
    #11
  12. Viking44

    Viking44 Been here awhile

    Joined:
    Feb 17, 2011
    Oddometer:
    135
    Location:
    Formerly Minnesota, now the Vegas desert
    Thanks for the walk thru. Reading this closely...:ear
    #12
  13. merc16

    merc16 Been here awhile

    Joined:
    Nov 26, 2008
    Oddometer:
    331
    Location:
    West Blocton,Alabama
    I am subscribed. Have any '06 Uly's had the rod knock or other engine problems?
    #13
  14. cardoctor1

    cardoctor1 Been here awhile

    Joined:
    Nov 21, 2010
    Oddometer:
    554
    Location:
    horsham pa
    can the sportster motor be used or strictly buell ?
    #14
  15. Florida Lime

    Florida Lime Long timer

    Joined:
    Sep 5, 2008
    Oddometer:
    2,516
    Location:
    As stated, and as often as possible -R'ville, N.C.
    Every one I've seen seems to be an '07 with 30,000+ miles (like mine), but I'm sure someone's had an '06 with a similar problem. :ear
    #15
  16. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal
    So far, I'm the third one I knew of that had this problem. Guess your number 4 Florida. Word from Buell is that the '07's had marginal quality control by the engine shop since they had to ramp up production.:eek1 Guess "good enough" was good enough for us consumers.:huh Looks like we got a tail light warranty.:lol3
    #16
  17. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal

    Not sure, since they got 103hp out of a Sporty engine that comes with like 60? I'd imagine that the compression is higher as well as head work and camming.
    #17
  18. Florida Lime

    Florida Lime Long timer

    Joined:
    Sep 5, 2008
    Oddometer:
    2,516
    Location:
    As stated, and as often as possible -R'ville, N.C.
    Mines been sitting for "a while". :cry
    It actually went before Hughlysses' bike did .
    #18
  19. vtwin

    vtwin Air cooled runnin' mon

    Joined:
    Jan 11, 2005
    Oddometer:
    7,752
    Location:
    NorCal

    Mine has been sitting awhile too, at least 6 months now. Getting a quote on getting the current crank repaired right now.
    #19
  20. merc16

    merc16 Been here awhile

    Joined:
    Nov 26, 2008
    Oddometer:
    331
    Location:
    West Blocton,Alabama
    Vtwin, are using an indy for engine reair?
    #20