TuneECU for 990 - got tunes?

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by jetpoweredmonkey, Oct 31, 2010.

  1. Norton guy

    Norton guy Serial bike owner

    Joined:
    Jul 12, 2008
    Oddometer:
    362
    Location:
    SE Taxachusetts
    Thanks, yes I upped the rate etc, I'll plow into it again after work and see what I can screw up.....
  2. speedy 1

    speedy 1 Wizard

    Joined:
    Jan 26, 2013
    Oddometer:
    453
    Location:
    100km north of the Golden Gate
    With the device manager dialog open, then plug in the adapter it will show which port it is using.
    The only electronic / software thing more finicky then a KTM ECU is Tune ECU
    When it is finally starts showing up on screen I start taking screen shots at intervals as the program randomly disconnects during use

    your results may vary
  3. jdubb75

    jdubb75 Vicarious Adventurer

    Joined:
    Jan 11, 2008
    Oddometer:
    498
    Location:
    Deep South(ern) Indiana
    It sounds like your computer isn't recognizing the USB cable. Are you sure you have the FTDi drivers installed? I am running windows 10 and vaguely remember having to install the FTDi separate from the TuneECU software. Here's a link to a post I remember reading when I was having troubles connecting.

    https://www.r3owners.net/threads/cable-connection-problem.19568/page-2


    And here's a link to the TuneECU install directions. There's also a link in the instruction to install the usb drivers. http://tuneecu.com/TuneECU_En/install1.html
  4. Norton guy

    Norton guy Serial bike owner

    Joined:
    Jul 12, 2008
    Oddometer:
    362
    Location:
    SE Taxachusetts
    Yeah the issue is that the cable shows up in com4 and the program defaults to three and won't allow 4. Doesn't show up as a conflict in the device manager but it but it won't let me resolve it either.
  5. Norton guy

    Norton guy Serial bike owner

    Joined:
    Jul 12, 2008
    Oddometer:
    362
    Location:
    SE Taxachusetts
    Thanks for the links, it may help.
  6. Themastermike

    Themastermike Think you caught me in a coma

    Joined:
    Jan 20, 2011
    Oddometer:
    1,535
    Location:
    So Ill
    I used with Windows 7, then win 10 upgrade. New pc has win10 factory install... well see how that goes.

    Sent from my SCH-I535 using Tapatalk
  7. Norton guy

    Norton guy Serial bike owner

    Joined:
    Jul 12, 2008
    Oddometer:
    362
    Location:
    SE Taxachusetts
    My laptop has win10 which I'm not fond of but I'm getting the hang of it. Seems different just for the sake of being different, not a step up as far as human interface goes IMHO.
  8. Norton guy

    Norton guy Serial bike owner

    Joined:
    Jul 12, 2008
    Oddometer:
    362
    Location:
    SE Taxachusetts
    Mr dumbass finally figured it out, plug in laptop, turn ign on and THEN open Tune Ecu.
    Seemed to do the trick. Saving the map is a problem but tomorrow is another day.
    jdubb75 likes this.
  9. 2 SPOT

    2 SPOT bring the rape whistle

    Joined:
    Dec 14, 2005
    Oddometer:
    5,162
    Location:
    Payson AZ
    maybe its cause i dont do computers much,,, but i havent had one issue with tune ecu. i followed the directions from a rotty vid and aside from not knowing what i'm doing its been communicating just fine.
  10. Norton guy

    Norton guy Serial bike owner

    Joined:
    Jul 12, 2008
    Oddometer:
    362
    Location:
    SE Taxachusetts
    I guess the main problem was having tune ecu open before I started the procedure.
    I loaded the Akra map and it runs like a jet.
  11. Antti

    Antti Been here awhile

    Joined:
    Mar 14, 2003
    Oddometer:
    268
    Location:
    Finland
    My `07 990 setup is:
    - ITG filter
    - 2in1 and Wings silencer
    - SAS blocked.

    Bike had Akra map but took it for tuning in bench and we had some problems.
    It gets VERY rich around 5krpm, even if map is setted to lean as possible its still too rich.

    At low and high end it works OK but problem is at mid-area.

    What could make it behave like that?
  12. Antti

    Antti Been here awhile

    Joined:
    Mar 14, 2003
    Oddometer:
    268
    Location:
    Finland
    Here you can see afr sudden peak. It got better from that but is still there.

    [​IMG]
  13. keener

    keener Speed changes you.

    Joined:
    Feb 24, 2010
    Oddometer:
    2,023
    Location:
    Toronto, Canada
    I noticed the same thing with Akro map but I'm running RC8 throttle bodies. I have the ITG filter too.

    I am trying to tune with two AFR sensors and a data logger/broadcaster that outputs live to my phone by bluetooth. I made the whole thing and wrote the software. It shows me RPM, TPS, AFR front and rear and soon MAP front and rear.

    I'm still learning how to tune the 990. I find not having a definite answer to meaning of data in the F-L switch table a huge set back. I see the L table effect the filling a lot specially at lower RPM range. Changing the data on F-L table makes a difference but not knowing the formula the ECU uses to use the data from L and F tables is frustrating.

    I kept leaning out the F tables to a fix rich idle and low RPM AFR with no luck. I changed the L table and that made a very noticeable difference.

    I found the Akro map harder to work with. I started with the stock map instead. Akro map has more ignition advance.

    Until we figure out how exactly F-L table is interpreted, we are really shooting in the dark. Even putting zero in all cells of F-L table won't make the L tables completely irrelevant !

    Next I may try putting zero in all cells of L tables and see what happens.
    Antti likes this.
  14. rider911

    rider911 Shortcut Navigator

    Joined:
    Sep 18, 2009
    Oddometer:
    1,055
    Location:
    Australia
    Nice work, thanks for sharing
  15. Dusty

    Dusty Long timer

    Joined:
    Jun 15, 2007
    Oddometer:
    1,415
    Location:
    Bismarck
    Hmm... when i compare the 07-08 standard and Arka maps the ignition is the same.
  16. keener

    keener Speed changes you.

    Joined:
    Feb 24, 2010
    Oddometer:
    2,023
    Location:
    Toronto, Canada
    Interesting. I see 54^ vs 60^.

    I'm comparing with 2007 SD stock map. That's the ECU I have.
  17. Dusty

    Dusty Long timer

    Joined:
    Jun 15, 2007
    Oddometer:
    1,415
    Location:
    Bismarck
    SD must be the difference.
    The adv-maps they just pumped more fuel on for the Arka up to 15% in some places and no other big changes.
  18. Antti

    Antti Been here awhile

    Joined:
    Mar 14, 2003
    Oddometer:
    268
    Location:
    Finland
    I did put back 2-2 exchaust and Wings without killers. On a short testdrive bike feels much more sensitive again and I must say that there was kind of dead area at around 5-6krpms, now thats gone.

    Could it be that my 2-1 y-piece makes kind of resonation thingy at that area and exhaust just doesen't flow?

    [​IMG]
  19. aun

    aun n00b

    Joined:
    May 31, 2012
    Oddometer:
    1
    Can anyone please share Tuneecu v1.7.7 (or 1.7.4 as minimum)? Need to apply older map to my 2010 ADV.
  20. Antti

    Antti Been here awhile

    Joined:
    Mar 14, 2003
    Oddometer:
    268
    Location:
    Finland
    Bike had second round at bench. I made some changes and setup is now:
    - ITG
    - SAS removed
    - went back to 2-2 from 2-1
    - Wings without killers
    - lamba sensors disconnected
    - RC8 intake parts.

    Tuner called and told that the bike is now working like it should and he got afr in to order. And he was happy to the result. He was thinking that lamdas may affect still even if they are programmed not to be in use but connected and the 2-1 y-piece did mess it up too.

    Can't wait to get it back to home