TuneECU for 990 - got tunes?

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by jetpoweredmonkey, Oct 31, 2010.

  1. d-squared

    d-squared Adventurer

    Joined:
    Mar 31, 2009
    Oddometer:
    16
    Location:
    Warrenton, VA
    Excuse me for farting, but is anyone interested in helping me jump into the orange sea of knowledge by selling me a spare tuneecu cable? I have a 2008 ADV (all stock) and i'm very anxious about my very crappy flat spot between 4500 and 5000 rpm.

    My dealer charged me $85 to tell me i have to replace my fuel injectors - @$650. I paid him his blood money and decided to tackle the problem myself - with help from the community here. i've already taken the first 2 steps in the progression checklist. I changed the fuel filters and i tried the 15 minute re-set. Results were underwhelming. Next step is loading up the ideal map (w/the o2 disabled). I'm only up to page 56 on this thread, so i still have a ways to go. but i figure I should try to get the cable early to help fight the inevitable onset of laziness. Every bit of motivation helps bc I'm working with almost no mechanical skill whatsoever.

    I may be undermining myself by admitting this :hide, but i want to get the bike in shape so i can sell her. She deserves better. plus i'm lusting over her slutty cousin the 500exc:sweeti. I can't fight it no more, and i can't have both.

    The only reliable looking cable vendor that i found on the internet is out of stock. Please PM me if you're willing to sell me a cable. Thanks.
  2. Ladukebob

    Ladukebob lost in hood river

    Joined:
    Feb 14, 2008
    Oddometer:
    2,310
    Location:
    Hood River, Or.
  3. d-squared

    d-squared Adventurer

    Joined:
    Mar 31, 2009
    Oddometer:
    16
    Location:
    Warrenton, VA
    nothing currently in stock at cj. dunno how long for the backorder
  4. Zuber

    Zuber Zoob

    Joined:
    Sep 28, 2004
    Oddometer:
    2,614
    Location:
    Main Street, Shedd, Oregon
    I have a condensed file of the past 122 pages that is 'almost' done.

    Is there a place on ADV that I can post it? (Don't want to e-mail 100 times).
  5. gefr

    gefr Life is a trip

    Joined:
    Nov 26, 2005
    Oddometer:
    4,614
    Location:
    East Med, Greece
    I believe you could send it to cpmodem in the HOW so it could be suspended there in full glory. In ADV here is the most special place... or maybe a new thread?
    Cheers.
  6. gefr

    gefr Life is a trip

    Joined:
    Nov 26, 2005
    Oddometer:
    4,614
    Location:
    East Med, Greece
    In the TUNEecu site you can find instructions in how to fabricate a cable with all necessary connections here:

    http://www.tomhamburg.net/TuneECU_En/KTM.html
    You can do that buying through ebay the OBDII cable and a sumitomo plug according to the first page of this thread from:
    http://www.corsa-technic.com/item.php?item_id=230&category_id=54
    or
    http://easternbeaver.com/Main/Elec__Products/Connectors/Sealed/SM-HM/sm-hm.html

    Cheers
  7. kenhaw

    kenhaw 2006 Adventure S EU

    Joined:
    May 28, 2012
    Oddometer:
    31
    Location:
    Cannes, France.
    What will disabling the idle speed control device do to the bike?
    Had problems with engine stalling when decellerating and pulling clutch , rpm dipps to around 1000 rpm and engine stalls.
    Tried disabling idle speed control and problem seems to be gone.
  8. Gustavo.Ramos

    Gustavo.Ramos Long timer

    Joined:
    May 19, 2008
    Oddometer:
    1,054
    Location:
    Accross the pond
    Being an EFI engine, it does not have manual idle accelerometer, so when starting the bike you may have problems keeping the correct engine speed for warm up. Also different ambient temperatures affect the engine idle speed, thus the presence of the idle speed control.

    Either verify the TPS voltage, or disable the clutch sensor, that way the idle speed control is fooled and won't drop the rpm's so much when the clutch is pulled.
  9. d-squared

    d-squared Adventurer

    Joined:
    Mar 31, 2009
    Oddometer:
    16
    Location:
    Warrenton, VA
    thanks gefr for the tip. and thank you zuber. looking forward to seeing a condensed version of this.
  10. Alleycatdad

    Alleycatdad Unbunch yer panties!

    Joined:
    Feb 6, 2008
    Oddometer:
    1,448
    Location:
    True Norcal, not that Bay Area/Sacto Crap...

    It's not ADV, but I'd be happy to host it for you and you could point folks to it. Better than 100 emails for sure!

    Drop me a pm and we can make it happen.

    Steve
  11. Blackhole

    Blackhole Adventurer

    Joined:
    Aug 6, 2009
    Oddometer:
    79
    Location:
    Northern Ireland
    Thanks to louiĀ£ and Spark for the advice. Much appreciated!

    I`m new to Tuneecu and would also really like to see the condensed version. :thumb
  12. kenhaw

    kenhaw 2006 Adventure S EU

    Joined:
    May 28, 2012
    Oddometer:
    31
    Location:
    Cannes, France.
    Hi Guys

    I have an irritating problem with my 06 Adv S with akro map 06

    Whenever coming to a stop, pulling the clutch coming from high RPM, my engine stalls.
    If I engine brake and let the bike go down in RPM before pulling the clutch, everything is fine.
    I can see that the RPM dips to around 1000 rpm for a short moment when pulling the clutch.
    Have checked tps and syncro, all is good, tps at 0.6 warm and difference in syncro is between 6 an 8.
    Disabled SAI, o2, 2nd Throttle and EPC. Akro wo/inserts.
    Have checked clutch switch in Tune Ecu and it seems to be working.

    Hope you can help
  13. kenhaw

    kenhaw 2006 Adventure S EU

    Joined:
    May 28, 2012
    Oddometer:
    31
    Location:
    Cannes, France.
    Ok I have tried bypassing the clutch now, but the weather is not for riding so I will have to wait and see the result of this later
  14. deksawyer

    deksawyer Adventurer

    Joined:
    Mar 26, 2012
    Oddometer:
    49
    Location:
    Scotland
    I had a similar issue with my 06 ADV. Turned out to be the sidestand switch.

    D.
  15. Gustavo.Ramos

    Gustavo.Ramos Long timer

    Joined:
    May 19, 2008
    Oddometer:
    1,054
    Location:
    Accross the pond
    Pls provide more details
  16. kenhaw

    kenhaw 2006 Adventure S EU

    Joined:
    May 28, 2012
    Oddometer:
    31
    Location:
    Cannes, France.
    Hi Guys and Girls

    Well it was not the clutch switch.
    Still cutting out. Rpm drops to a 1000 or less coming to a stop pulling clutch, and engine dies.
    It happens 3 times out of 5 so not fun.
    Starts pretty easily afterwards and some times not.

    Any ideas???

    Kenenth
  17. Spark01

    Spark01 V-Twin

    Joined:
    Aug 29, 2010
    Oddometer:
    309
    Location:
    The Netherlands
    I guess something wrong with your idle stop screws.
    When the engine is warm, the idle speed motor is fully retracted.
    and the throttle plates should be stopped at a certain position, this is done by the idle stop screws.

    when the idle stop screws are set at a to low hight then when you release the throttle.
    The throttle valves closes to much and causes the engine to stall.
    When the screws are set to high, the engines rev's will drop too slow (very high idle speed).

    What you can check with a warm and idle running engine what the play is between the idle stop screw and the throttle valve.
    And measure how much it is
    [​IMG]

    What is the correct setting...? i really don't know the manual doesn't give that information.
    But for safety reason i would maintain a gap of minimal 0,1mm to prevent a high idle situation.
  18. kenhaw

    kenhaw 2006 Adventure S EU

    Joined:
    May 28, 2012
    Oddometer:
    31
    Location:
    Cannes, France.
    Thanks for the reply.. Will look into that tomorrow..

    On another note, why cant I use the test to adjust throttle cable function in Tune Ecu, it is greyed out?

    I have a 2006 adv S

    Thx
  19. Gustavo.Ramos

    Gustavo.Ramos Long timer

    Joined:
    May 19, 2008
    Oddometer:
    1,054
    Location:
    Accross the pond
    I've noticed that different map files have different available tests in ECU.

    My 06 with 06 akro map didn't show all tests: example, test the injectors, was not available among others. When changed to 07 Akro map, a few other tests were available.

    Couldn't figure out why... anyone noticed that too?
  20. spencergt66

    spencergt66 Been here awhile

    Joined:
    Jun 25, 2011
    Oddometer:
    872
    Location:
    Lake Stevens WA
    Just started messing with tunes on my 990 (2007 adv)

    What is SAI? Is that stand for secondary air injection? Do I want to turn this off?

    What is the base setting for tps? I want to say .6 v is what I remember is this correct?