water pump cover tube o rings?

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by 666, Dec 23, 2012.

  1. 666

    666 Agnostic and Orange

    Joined:
    Feb 23, 2005
    Oddometer:
    1,321
    Location:
    San Francisco, CA
    I was replacing water pump seal today. First time on this bike - 31k miles. 2006.
    Original stock, didnt go bad yet, but I had time.
    When I was pulling the aluminum "tube" from the cover o-rings were not "together"(like in Pyndon's rebuild report on HOW), but on either side of the tube "bulge". It never leaked(visibly) from there and came that way from the factory.
    Did anybody else had orings from factory installed the same way?
    It may explain why I always had to add a little bit of coolant .

    Here 2 pictures from Pyndons rebuild, clearly both o rings on the inside, so I installed it the same way.
    [​IMG]
    [​IMG]
    Shaft looked just fine, no wear. But some milky stuff was between shaft bearings and seal - may be it was about to go.
    Here is shaft:
    [​IMG]
    here is milky stuff
    [​IMG]
    #1
  2. Gabby

    Gabby Been here awhile

    Joined:
    Apr 14, 2006
    Oddometer:
    467
    Location:
    The Greater Cutler Ohio Metro Area
    That is the way the o rings on my 990 were installed. One on either side of the "bulge". I put them back that way...
    #2
  3. cjracer

    cjracer AWD please!!

    Joined:
    Sep 26, 2005
    Oddometer:
    3,976
    Location:
    Mukwonago, WI
    From the factory.

    One on each side as stated.

    When we rebuild WPs we put 2 new o-rings on the Inside and one of the older ones, or New if you want to, on the outside. Gives you a few more sealing surfaces and does no harm.
    #3
  4. 666

    666 Agnostic and Orange

    Joined:
    Feb 23, 2005
    Oddometer:
    1,321
    Location:
    San Francisco, CA
    Well, too late for me. Already installed 2 on the inside. It's all buttoned up and running fine. I went for a ride - it's nice and sunny here.
    I used regular coolant, if there is no sign of leaking water pump seal at next oil change then I will drain and put engine ice and add o ring on the outside.
    thanks guys.
    #4
  5. roookie1

    roookie1 Been here awhile

    Joined:
    Jun 15, 2009
    Oddometer:
    127
    Location:
    Denmark
    Hi 666 my 2004 950 Adv was assembeled the same way as yours. I also used Pyndons write up, and placed the new O-ring on the same side of the "bulge" that is pump side....

    Mine was also leaking from that pipe, just a Little. Now it is holding up fine, but I´m loosing a bit of coolant still/Again, havent solved that yet..havent tried..

    I Wonder what the right way is..:deal
    #5
  6. murphyKTM

    murphyKTM Adventurer

    Joined:
    May 3, 2007
    Oddometer:
    57
    Location:
    North Island New Zealand
    I am currently changing out my water pump shaft, all going well, but looking at the water pump shaft bearings I do not understand how they get lubricated. The two bearings are set up with the seals on the outside of each bearing:huh, circlip in the middle, I dont understand how they get oil. The seals would tend to keep oil out of the bearings?? Or at least the seal on the inner bearing would.
    What am I missing?
    #6
  7. Katoom72

    Katoom72 Been here awhile

    Joined:
    Jun 3, 2012
    Oddometer:
    937
    Location:
    Belgium
    I put one on o-ring eatch side, slide the tube in, put liquid gasket into the grove between the tube and the case. Then push in the outer o-ring, put some liquid gasket ontop of that and then add the pressplate where after i add blue threadlock to the bolts and tighten them to 15NM.

    Every other way of sealing failed due to the tubing being rubbed in a bit from the outher o-ring. It has been leak free for the past 8k km. The threadlock is for precautionary matters. It's my 4th KTM and i always add threadlock or saftewire to most bolts that have the function to seal fluid openings.
    #7
  8. murphyKTM

    murphyKTM Adventurer

    Joined:
    May 3, 2007
    Oddometer:
    57
    Location:
    North Island New Zealand
    I would advise caution applying anything that sets to an o ring to help it seal, especially if there is movement or alignment issues in the joint.The whole concept of o rings is that they deform in a controlled manner and if you put in some liquid gasket material that may then turn hard, you may effect the o rings chances of sealing under vibration or movement with heating and cooling.
    I have found that some decent lube on the o rings so that they seat happliey is the most important factor.
    You have to have happy well lubricated o rings!!

    No warrenty expressed or implied by these coments! If it works for you go for it.
    #8
  9. 666

    666 Agnostic and Orange

    Joined:
    Feb 23, 2005
    Oddometer:
    1,321
    Location:
    San Francisco, CA
    Damn it. Just walked through my garage and noticed coolant dripping from the bike. Yep, looks like it's coming from there. I guess I have to pull it out and add o ring on the outside.
    p.s.
    never mind. It doesnt leak from there. I took gas tank off and for some reason all hose connections to the thermostat housing started to leak. Factory clamps. I guess 7 years old is too old for these hoses and clamps.
    #9
  10. Katoom72

    Katoom72 Been here awhile

    Joined:
    Jun 3, 2012
    Oddometer:
    937
    Location:
    Belgium
    I always grease the o-rings with marine grade Suzuki water resistant grease. No luck in that department. The tubing is rubbed in a bit and the o-ring lacks the form to seal it properly.
    So i had 2 options, new tubing or liquid gasket. My cheap-o solution seems to be fine after 8000km. :)
    #10
  11. murphyKTM

    murphyKTM Adventurer

    Joined:
    May 3, 2007
    Oddometer:
    57
    Location:
    North Island New Zealand
    The standard o ring for the tube to water pump connection is 25* 3. these dimensions are metric. If you have wear in one part you could try a 1 inch * 1/8 dia o ring. The 1/8 o ring is very slightly larger in diameter and the o ring is is slightly longer (25.4 mm) so you are stuffing a little bit more rubber in the hole which may make the difference.
    I have reguarly made o rings using o ring cord, a sharp knife and instant glue. Got me out of a hole a few times at work but really only works best on larger diameters. On smaller diameters it is hard to get an aligned joint in the o ring.
    I am not suggesting that you tear down your non leaking bike to try this out though.

    All opinions are given with no warrenty, expressed or implied!!
    #11
  12. Katoom72

    Katoom72 Been here awhile

    Joined:
    Jun 3, 2012
    Oddometer:
    937
    Location:
    Belgium
    I tear it down every year anyway.
    Fresh coolant and quick flush for the peace of mind. (and a complete 'gotrough' maintenance wise)
    But if this holds up im just gonna use the method i am currently using. It's a guaranteed seal on the first try.

    Unless you can give me that warrenty! :evil Thx for the tip tho, appreciate it.:freaky
    #12
  13. murphyKTM

    murphyKTM Adventurer

    Joined:
    May 3, 2007
    Oddometer:
    57
    Location:
    North Island New Zealand
    You probably would not be able to find imperial o rings in metric Belgum any way. Been a little while since they used feet and inches:D
    #13