Wiring help needed (1977 R100RS)

Discussion in 'Airheads' started by WANDERING KTM, Jan 12, 2013.

  1. WANDERING KTM

    WANDERING KTM Adventurer

    Joined:
    May 4, 2006
    Oddometer:
    89
    Location:
    PERTH,WESTERN AUSTRALIA
    Hi All
    before I ask my couple of questions I think I should give a little bit of history of my project and how I arrived at the problems I have today
    I bought this 1977 R100RS off a bloke in my local pub, he had stopped riding it when it started making a loud rattling noise and after a quick tear down (he pulled the cylinders off) he had decided "its just f#$@ed mate" he was right, for anyone who cares here is the vin plate

    [​IMG]

    and after a full tear down the cause of the loud noise was immediately evident

    [​IMG]

    Yep thats the two pieces of crankshaft

    seeing as we have all seen plenty of photos of these being rebuilt I will go straight to what it looks like today

    [​IMG]

    so that brings me to my questions, I need to hook up the wires to the back of the ignition key but need to know what goes where, the terminals on the back of the key look like this

    [​IMG]

    they are numbered 30 , 15 , 56 and 58 and i have four wires to connect to them

    [​IMG]

    two green a red and a grey one in the front of the headlight bucket
    can anyone help with some advise on what goes where ?

    next up is a similar question for the alternator , every picture i have seen shows the three wires in a large plug but i have them all seperate can anyone please advise what colours go onto what pin

    [​IMG]

    any help with these two questions would be greatly appreciated as I am at a bit of a standstill until
    I get these hooked up
    #1
  2. JRP

    JRP Old guy

    Joined:
    Apr 4, 2004
    Oddometer:
    1,564
    Location:
    Hampden, MA
    [​IMG]

    This might help
    #2
  3. Smurfen

    Smurfen Airhead Traveller

    Joined:
    Feb 2, 2007
    Oddometer:
    67
    Location:
    Ă…ngermanland, Sweden
    This is a pic from my '79 100RT, but these wires for the charging should be the same I think.

    [​IMG]

    For the ignition switch it should be:
    Red wire goes on no. 30, live all the time.
    Grey one goes on no. 58 for the parking light.
    One green goes on no. 15 and should also connect to no. 15 on the connection block at he upper fuse. For ignition and starter button, some measuring may be needed here if it's not possible to see wich wire it is.
    The other green should go on no. 56 for the lights. But this one you might have to test your way, may depend on what switch you have on the handlebar. If it is ligths on always when ignition is on.

    Well, hope it is of some help.
    #3
  4. WANDERING KTM

    WANDERING KTM Adventurer

    Joined:
    May 4, 2006
    Oddometer:
    89
    Location:
    PERTH,WESTERN AUSTRALIA
    Excellent ! Thanks guys that will give me somewhere to start tomorrow
    The wiring diagram is slightly different to what I have but I should be able to work something out
    Thanks again
    #4
  5. bmwrench

    bmwrench Long timer

    Joined:
    Nov 10, 2006
    Oddometer:
    4,061
    The red wire attaches to one of the center terminals. The grey goes on 58. The green goes on 15. The second green goes on 56.
    #5
  6. spo123

    spo123 Man About Town

    Joined:
    Nov 7, 2006
    Oddometer:
    1,024
    Location:
    North Shore Mass. USA
    The three wires to the three pin connector, on the alternator, can be connected in any combination......IT DOES NOT MATTER.
    Good Luck.
    #6