XR650L running problems please help

Discussion in 'Thumpers' started by hemithis, Oct 13, 2012.

  1. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    I have posted my problem on supermoto junkie and thumpertalk with no real help. Time to try you guys.

    About 3 weeks ago I jumped on my bike to go ride around town and hooligan it up some. Bike is supermotoed. About 5 mins into my ride in 3ed gear slight acceleration waiting on another rider the exhaust tone changes pitch. This is very hard to explain but it just sounded different all at once. I gagged the throttle bike pulled then started poping and sputtering. I pulled off the road and looked the bike over real quick nothing out of the normal. So I limped the bike home. If it is kept below about hafe RPM the bike runs and pulls fine. Dosnt matter if its hafe or full throttle. When holding WOT sitting still it sounds like its hitting a ignition cut revlimiter at about hafe RPM.

    SO here is what I have dun. I held it wot and hit it with starting fluid to see if it was lack of fuel. No change in the motor at at.

    I pulled and went through the carb twice cleaned and checked no problems.

    I pulled the valve access holes on the head to check valve clearance the chain tench and the decompression mechanism all are good.

    I checked the motor at TDC make piston is all the way up valves closed.

    Checked compression. 150psi

    Banged around my cdi with no results.

    Pulled my stator cover and fly wheel to check for a spun key way. All is good.

    Now I have ordered a cdi it just hasn't shown up yet but Idk if its guna help any. Im kindov at a loose on this thing right now. If any one can help at all please point me in the right direction.
    #1
  2. Switchblade315

    Switchblade315 Long timer

    Joined:
    Oct 10, 2009
    Oddometer:
    7,097
    Location:
    Watching Bridges Burn
    my first thought was something went wrong with the choke but you say you've had the carb off twice and nothing is wrong there. Have you tryed a new spark plug? I know it sounds stupid but they can do odd things and it's probably due a new one anyway. And your pickup coil might have moved. dought it but possible.
    #2
  3. mcma111

    mcma111 Long timer

    Joined:
    Jul 17, 2007
    Oddometer:
    14,860
    Location:
    San Francisco,Ca.
    Cam jump timing??
    #3
  4. africa twin

    africa twin Been here awhile

    Joined:
    Feb 1, 2008
    Oddometer:
    184
    It sounds like something is blocking the air intake under the seat. Did u mount anything under the seat change the seat cover etc. Try running it with the seat off to confirm.
    #4
  5. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    Changed the plug when it first happend choke is fine.

    The air intake is not stock its a round filer type now. I have run it open carb after putting the carb back on no change

    And the cam chain is tight valves closed at TDC cam hasn't jumped.

    :0/
    #5
  6. Kawidad

    Kawidad Long timer

    Joined:
    Jul 9, 2005
    Oddometer:
    5,683
    Location:
    Central Coast, Cal
    #6
  7. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    Not much info on it. My motor starts and runs fine until about 3500 RPM.... makes good compression. You think a valve seat smacking around in the head would make noise.....
    #7
  8. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    Cdi just shower up in the mail not that.

    Barrowed a coil from another bike not that..... may just have to pay some one to look at it.
    #8
  9. Kawidad

    Kawidad Long timer

    Joined:
    Jul 9, 2005
    Oddometer:
    5,683
    Location:
    Central Coast, Cal
    Check the ignition pick up inside the case. You can test it with a multi-meter.

    "GEN, IGNITION PULSE" Part # 30300-MY6-671

    Mine died suddenly and without warning. I was completely baffled and had to take it to a shop to have it diagnosed.
    #9
  10. jrsride2002

    jrsride2002 Adventurer

    Joined:
    Aug 20, 2011
    Oddometer:
    82
    Location:
    Houston, Tx, USA
    Bummer, I was going to say coil....... Im stumped.:huh
    Sucks when you have to take it to someone. Costs 10's the amount it should be. And usually its something you might have over looked.

    Good luck dude. Wish I knew, but for sure, I am going to follow this thread,
    ~Junior
    #10
  11. Hurricane Bob

    Hurricane Bob Long timer

    Joined:
    Jun 6, 2007
    Oddometer:
    2,963
    Location:
    Rhode Island
    [​IMG]
    #11
  12. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    No tears in mine..... bike is at the dealer I finally just got feed up with fucking with it. Maybe I over looked something.... I will keep u posted.
    #12
  13. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    So the bike was at the dealer for 3 days after them coming up with nothing and me being quite aggravated I payed them there 100$ and picked my bike up..... when I got home I decided to go after my first instincts witch was timing..... pulled the cam cover and the picture tells the rest of the story.
    [​IMG]
    #13
  14. Mike the Yank

    Mike the Yank Long timer

    Joined:
    Jun 27, 2012
    Oddometer:
    1,295
    Location:
    MILLJURAH Vic. Aus
    excuse my ignorance, is that a really badly streched cam chain?
    #14
  15. Sierra Thumper

    Sierra Thumper Been here awhile

    Joined:
    Oct 3, 2012
    Oddometer:
    641
    So another fuk-up of a shop gets an easy $100 for doing nothing. Shops are worthless anymore...makes me so very glad I do all my own work and give them nothing....fukkers :fyyff
    #15
  16. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    Chain is stretched and let the bike jump timing. I have a new chain and tench ordered.

    The dealer had me livid charging me for not fixing my bike. They where convinced it was my wiring because my bike being motoed I have moved a bunch of stuff. Lesson learned......
    #16
  17. mcma111

    mcma111 Long timer

    Joined:
    Jul 17, 2007
    Oddometer:
    14,860
    Location:
    San Francisco,Ca.
    See post #3. :deal


    BTW... The chain tensioner allowed the timing to jump. I would replace that.
    #17
  18. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    I ordered that when i ordered the chain. I still dont understand how it jumped. It advanced its self 3 teeth and the chain was not lose. We will see once I put it back together.
    #18
  19. hemithis

    hemithis n00b

    Joined:
    Oct 5, 2012
    Oddometer:
    9
    Back together and runs better than ever!
    #19