XR650L won't start

Discussion in 'Thumpers' started by BMW4LIFE, May 23, 2007.

  1. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    I need some help. I have a Honda XR650L and it won't start. I have pulled the plug and I don't have any spark. I tryed a new plug and nothing. I also took the tank and seat off and looked at all of the wires and everything looked good. All of the fuses are good also. Please let me know what I need to look at next. I am not much of a mechanic so please speak in layman terms! Thanks!!!
    #1
  2. B DIRT

    B DIRT Long timer

    Joined:
    Jan 4, 2007
    Oddometer:
    1,378
    Location:
    your moms house startn a small fire in her panties
    Its either the CDI box which is common or one of the safety switches on the clutch or kickstand. You can by pass them to try to figure it out
    #2
  3. GLOCKBOY

    GLOCKBOY n00b

    Joined:
    Apr 12, 2007
    Oddometer:
    1
    I have your answer. The ECM is the problem. It is to the right of the battery as you face the left side of the bike. Take a hammer and tap it a few times, then try to start the bike. It should start right away. Now REPLACE THE ECM BEFORE IT STRANDS YOU!!! I read this in MCN a few months ago and then my bike would die and not start. I rapped the ECM a few times and it started right up. It has failed a few times since (my new ECM hasn't come in yet) two taps and it lives. There is a crack internally in the unit and contact is being lost.

    Glockboy
    #3
  4. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    Thanks for the replys! I will give these a try tonight. How much should a new CDI cost?
    #4
  5. B DIRT

    B DIRT Long timer

    Joined:
    Jan 4, 2007
    Oddometer:
    1,378
    Location:
    your moms house startn a small fire in her panties
    around 100 bucks from the dealer, and its the CDI thats right of the battery
    #5
  6. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    Anything else. I just talked to the Honda dealer and thay said thay never see a CDI go bad:lol3 . I just need any help I can get. Thanks!
    #6
  7. XR650L_Dave

    XR650L_Dave Long timer

    Joined:
    Apr 3, 2006
    Oddometer:
    3,905
    Location:
    Near Cortland NY

    XRL CDIs do fail, usually they become intermittent as they die. You'll be riding along, it dies, you wait 5 minutes, it starts right up.

    The CDI failure is relatively rare, but with the number of XRLs out there, it adds up.

    You can read reports of this here, on thumpertalk, on 4strokes, and on the yahoo XRLUG group.

    If you want to bypass all safeties very quickly, you can remove the 2 wires that go to the clutch lever switch and connect both to ground.

    If your XRL is older (before 94? help me out here...) its much more likely to be the CDI than if its much newer.

    Dave
    #7
  8. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    Thanks Dave. My XRL is a 1998 with 4500mi. Thanks to all for the help.
    #8
  9. B DIRT

    B DIRT Long timer

    Joined:
    Jan 4, 2007
    Oddometer:
    1,378
    Location:
    your moms house startn a small fire in her panties
    theyre really easy to get to if the dealers got one on the showroom floor :deal
    #9
  10. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    How much power should I be getting to my coil?? I seem to be getting around 3 volts. That just seems really low.
    #10
  11. 12bridn

    12bridn I need throttle therapy

    Joined:
    Apr 25, 2004
    Oddometer:
    4,677
    Location:
    Cincinnati, OH
    I had an NX that wouldn't spark if the battery was low. Check the battery voltage before switching parts, you may be throwing money at a non-existent problem.
    #11
  12. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    Thanks!
    #12
  13. 12bridn

    12bridn I need throttle therapy

    Joined:
    Apr 25, 2004
    Oddometer:
    4,677
    Location:
    Cincinnati, OH
    Is it running yet? What was the issue?
    #13
  14. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    No it's not running yet. I checked everything I can like the on/off switch, fuses, kickstand, and a few others. I just don't know where to go now. I have made a app with a dealer. I would be willing to try something else if anyone has any ideas.
    #14
  15. Mercury264

    Mercury264 Once you go Triple...

    Joined:
    Nov 7, 2005
    Oddometer:
    23,021
    Location:
    Masshole
    It's more than likely your CDI box - I had to change mine recently. Another thing to check is the kill switch. On mine, even on run, it initially would not start. Turns out the contacts were dirty.

    I am betting CDI unit though. I think mine was about $100. Save yourself some money and order one. If it isn't that, take it to the dealer and either keep the CDI unit (for when it does go TU) or sell it here on ADV. Sure you'll lose a few $$ but the CDI is probably what the problem is if you have checked everything else.

    Good luck and be sure to report back :thumb
    #15
  16. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    Thanks for the info. Where did you guys get a CDI box for $100. I checked with my dealer and he told me $140:puke1 . If you know somewhere I can get one for 100 please let me know.
    #16
  17. Mercury264

    Mercury264 Once you go Triple...

    Joined:
    Nov 7, 2005
    Oddometer:
    23,021
    Location:
    Masshole
    I think I got mine online from http://www.servicehonda.com/ or it might have been http://www.ronayers.com/
    #17
  18. BMW4LIFE

    BMW4LIFE Been here awhile

    Joined:
    Sep 9, 2006
    Oddometer:
    124
    Well it's back up and running. I found some moisture in the plugs on the CDI. I dryed them out and all is good. Thanks to everyone for your great help. You guys really know your stuff:clap !!!
    #18
  19. Machtig

    Machtig Been here awhile

    Joined:
    Aug 19, 2008
    Oddometer:
    369
    Location:
    Monterey, CA
    Hey guys, I have the same issue, won't start. Was cruising down the street last week, and she just died, wouldn't restart. I checked the CDI, and can hear it clicking when I push the start button. Also, I pulled the spark plug wire, to check for spark, but it is very weak, and you see some spark even when you're not cranking. Very strange. Any ideas.
    #19
  20. doughy

    doughy Long timer

    Joined:
    Apr 23, 2008
    Oddometer:
    3,142
    Location:
    Everywhere I shouldn't be...
    NOw that's a bit weird......

    So you have constant power to the plug wire?
    #20