Yes or No, Have you had a fuel pump problem on your 990.

Discussion in 'Crazy-Awesome almost Dakar racers (950/990cc)' started by Gimme 2, May 7, 2009.

  1. Gimme 2

    Gimme 2 wheels , with nobs

    Joined:
    Mar 29, 2009
    Oddometer:
    2,174
    Location:
    still looking
    In the interests of understanding more about the 990 efi, please state if you've had a problem with your fuel pump, the circumstances in which it may have occurred eg traffic riding ,freeway riding, ambeint tempreture etc.. and please explain in detail how the problem began to rear its little ugly head. And mention the k's on the bike and the rectification of the prolblem.
    It maybe usefull to note your general throttle action eg hard or gentle.

    For the record i have a 990 adv s 07 purchased in late 08 and yes the pump packed it in.
    The bike had aprox 2500 k's on the clock.

    Cheers
    #1
  2. danceswithdeer

    danceswithdeer Space Wrangler

    Joined:
    Mar 19, 2008
    Oddometer:
    176
    Location:
    Wyoming
    My '08 has 1100 miles and is doing the same thing as yours. As soon as I can get a spare moment, I'll drag it over to the dealer.
    #2
  3. fireball5050

    fireball5050 n00b

    Joined:
    Jun 8, 2007
    Oddometer:
    6
    '07 with 5600 miles, no problems so far. Hard throttle of pavement but don't have cajones to twist it hard on the dirt.
    #3
  4. Knackers

    Knackers Polishing Turds

    Joined:
    Sep 18, 2006
    Oddometer:
    4,840
    Location:
    Drinking Vic, Qld & NSW Sewerage, Adelaide SA
    06 990 25,000km.

    NO.

    Just you ya whinging crunt :rofl
    #4
  5. Vicks

    Vicks gets stuck in sand

    Joined:
    Oct 4, 2006
    Oddometer:
    3,228
    Location:
    Abu Dhabi, UAE
    '07 990S bought in early '08. 16,000kms+ of hard tarmac & pussy-like dirt riding, live in the middle-east, temps go 40+ DegC most of the year. No problems whatsoever with the bike.

    just pulled my fuel pump apart today to give it a good look. everythink is Ok in there. posting pics on another thread.

    seems like you either had a bad bike or bad (very) fuel all along.
    #5
  6. LC8TY

    LC8TY must......find.......fuel

    Joined:
    Dec 25, 2006
    Oddometer:
    2,297
    Location:
    was Kununurra, now Carnarvon, Australia
    I had blocked fuel filters after a couple of thousand Ks. I refuel from some pretty dodgy (remote) places and thats what caused it.

    Get the replacement filter kit, use petroleum jelly to lube the o ring seals when reinstalling the pump and carry a spare kit when going bush.

    :thumb
    #6
  7. cool dude

    cool dude Been here awhile

    Joined:
    Nov 7, 2006
    Oddometer:
    273
    Location:
    Hereford, UK & Chamonix, France
    23000Km on my early 2006 990 Adventure and no fuel pump issues to date.
    #7
  8. stimmer6253472

    stimmer6253472 Been here awhile

    Joined:
    Dec 1, 2008
    Oddometer:
    366
    Location:
    Belton, Mo.
    10,000 miles and no issues at all with the bike.

    I think another question you should ask is how often you run the bike really low on gas. I live near a lot of gas stops and so I rarely go 5-10 miles past when the reserve light comes on.
    #8
  9. 911racer

    911racer dare to explore

    Joined:
    Feb 25, 2007
    Oddometer:
    471
    Location:
    Santa Cruz Mountains,CA
    15,000 miles = no problems :clap
    #9
  10. K80JIM

    K80JIM Super Tanker

    Joined:
    Feb 8, 2006
    Oddometer:
    556
    Location:
    Huntington Beach Ca.
    07 with 11,900 no problems
    #10
  11. BIG-E

    BIG-E AKA; Mongo-E

    Joined:
    Jun 28, 2007
    Oddometer:
    2,099
    Location:
    Phoenix, Arizona
    '07 990"S" 13,000 miles, no problems at all. Ran it waaaay low on gas a few times, no problem. it will actually go 60 miles on "F" trip, I found that out in Death Valley this year. Allthough, I am wondering about it at every oil change, and the water pump.

    Take care Brothers, Eric.
    #11
  12. MAXVERT

    MAXVERT OG on da OC

    Joined:
    Jan 19, 2004
    Oddometer:
    1,069
    Location:
    Sun Valley Idaho, Baja Arizona
    No problems yet.
    Changed filters at 25,000 miles, with many long hard days in challenging
    conditions.
    Kyrgyzstan near the Tajik and China borders

    [​IMG]
    [​IMG]

    Local gas

    [​IMG]

    Twist it, MAX
    #12
  13. Dusty

    Dusty Long timer

    Joined:
    Jun 15, 2007
    Oddometer:
    1,317
    Location:
    Bismarck
    17,000 miles no probelemo. Changed filters at 8,000 miles...

    07 - 990
    #13
  14. Taurkon

    Taurkon Been here awhile

    Joined:
    Aug 9, 2007
    Oddometer:
    814
    Location:
    Calgary, Ab
    YES. Around 3500 km and mine died.

    New one replaced on warranty, and I am now at 10500 km and beginning to wonder if the new one is bummed! Bike is sputtering, popping, stalls at idle once warm, and sometimes is only running on a single cylinder. Thing is, it does not happen all the time. Dealer can't find the problem... plugs are good, diagnostics comes up clean. I've run a few containers of injection cleaner through, and no luck. Starting to think it may be the pump.
    #14
  15. sidestand

    sidestand bristol, uk.

    Joined:
    Dec 6, 2005
    Oddometer:
    273
    07 990S , 12000miles pump failed no warning start up from cold 10 sec ride to the fuel pumps start up again into gear clutch out stopped dead . replaced under warranty, no probs with anything else since or before.
    #15
  16. sidestand

    sidestand bristol, uk.

    Joined:
    Dec 6, 2005
    Oddometer:
    273
    07 990S, 12000mile pump failed, start up from cold, ride 30 sec to fuel pumps , fueled up, started her up, into gear clutch out started to roll, stopped dead . pump replaced under warranty. no probs since or before this.
    #16
  17. Venteuri

    Venteuri I don't give a shit

    Joined:
    Sep 3, 2007
    Oddometer:
    15,799
    Location:
    Queretaro , Mexico
    Nov 07 990 - NO problems at all.
    Have not cleaned or replaced the filters yet
    All with Mexican red gas :D (some ocassional visits to Texas)
    #17
  18. Vicks

    Vicks gets stuck in sand

    Joined:
    Oct 4, 2006
    Oddometer:
    3,228
    Location:
    Abu Dhabi, UAE
    a question for you and the others whose fuel pumps were replaced under warranty.

    did u guys check with the dealer about the reason & nature of failure on the pumps ? are you sure it was the fuel pump or just the fuel filters ?
    #18
  19. sidestand

    sidestand bristol, uk.

    Joined:
    Dec 6, 2005
    Oddometer:
    273
    They showed me the pump looked very new and clean [ including the large external sock filter]. They were sending it back to ktm as at that time, they knew of not one other failure. i'm sure he would have tested it though to make sure it was the pump and not just the filters.[ he's a very good bike mechanic]

    If my pump would have failed Now, looking at the pics on this fourm, i would have ripped it a part for a closer inspection.
    #19
  20. duct tape

    duct tape Lost

    Joined:
    Jul 9, 2007
    Oddometer:
    473
    Location:
    Colorful Colorado
    Seems like you answered less than 50% of your own questions.....
    #20