Yet Another EWS Issue

Discussion in 'GS Boxers' started by Dahhbuzz, Jan 14, 2013.

  1. Dahhbuzz

    Dahhbuzz n00b

    Joined:
    Apr 3, 2011
    Oddometer:
    2
    I've had a 2007 GSA for about 3 months now. Of this, I have been battling with the EWS error for 2 months. When I got the GSA it started fine.

    One day it got caught in the rain and wouldn't start. It was giving the EWS error. After it dried out and I disconnected then re connected the battery , it started.

    After some research on ADV Rider , I got a new ring antenna. But this did not stop my particular problem. Basically if my ignition is wet(after rain or a bike wash), I Get the EWS error till it dries out. After it dries out I have to remove the battery head and wait for about 2 minutes, reconnect and all is well. Typically I have been riding my GSA this way(removing the battery head before I start the bike)

    One of the causes of the EWS error is said to be a broken wire. So today I stripped my bike and traced the 4 ring antenna wires that go into the ECU.They are all fine!

    So right now I'm at my wits end in trying to determine how to solve. Someone has suggested replacing ECU and keys, but I'm not sure if that will solve my problems..

    Any one have any Ideas?

    O by the way, I live in Nigeria , so no friendly neighborhood bike shops to go to......................

    Many thanks.

    Today
    #1
  2. GB

    GB . Administrator

    Joined:
    Aug 16, 2002
    Oddometer:
    57,519
    Location:
    Toronto
    Read the part number on the ring antenna itsefl, does it end in 247? if it doesn't, it needs to be changed. Back in 2008, there was a rash of problems with the 07 and 08 ring antennae and 4 part numbers later, it was concluded that the ring antenna was finally sorted.. There was no recall but dealers did replace the antenna without charge if you took the bike in. So check the replacement antenna to be sure it's the latest and greatest..
    #2
  3. Dahhbuzz

    Dahhbuzz n00b

    Joined:
    Apr 3, 2011
    Oddometer:
    2
    Thanks GB. Yes its is the 247 module. They both are!
    #3
  4. Wallowa

    Wallowa Long timer

    Joined:
    Nov 30, 2006
    Oddometer:
    5,517
    Location:
    NE Oregon
    In the owner's manual that you should have been given with your '07 GSA you will note that "EWS" not only signifies a lock out by the ring antenna but a weak battery. So battery or ring antenna can give "EWS". My '07 GSA OEM battery needed to be replaced with 12 months and that while on the BMW AGM charger/tender. Oh yes, the clue that it is battery is that when the ring antenna locks you out, you will need a new chip code. Once you are locked out, you must take it to a BMW shop and essentially re-key/chip it. I believe each bike has 6 chip codes pre-assigned to that VIN.

    Put in a fresh battery. I used a Yuasa motocross AGM battery; perfect fit, shock resistant. That was 5 years ago.

    PS..After reading Mudcat's advice, it could very well be a broken wire...but again, if failed antenna, you will not be able to restart it.
    #4
  5. Mudcat

    Mudcat Unregistered

    Joined:
    Jul 22, 2004
    Oddometer:
    4,472
    Location:
    Bay Area
    A weak battery can cause a EWS fault but if it is happening only after the bike gets wet, I’d suspect a loose/bad electrical connection at the ring antenna.
    Unfortunately you can have a broken wire without any outward sign but just happening when the bike is wet, I don’t think so.
    Next time the EWS error happens, turn the ignition off and try manipulating the wires at the antenna, then try restarting.
    You might also try spraying the ring antenna plug with WD40, which will displace water. And then see if the bike will start.
    #5