Zumo won't charge

Discussion in 'Mapping & Navigation' started by levain, Sep 10, 2012.

  1. levain

    levain STILL Jim Williams

    Joined:
    Oct 29, 2005
    Oddometer:
    7,641
    Location:
    Providence, RI
    First I can't get maps into my new macbook air. Now, my 6 year old Zumo won't charge in the mount. It's currently plugged into my laptop and charging so it does charge, just not while on the bike. I tried a different mount. I tried a different cable. Nuthin. I tried cleaning the contacts. Checked the fuse. Nuthin. Great timing. I leave on a trip Wed. am...

    Any help?
    #1
  2. Twilight Error

    Twilight Error Going nowhere slowly

    Joined:
    May 18, 2002
    Oddometer:
    22,807
    Location:
    The Submarine Mines
    How are you hooked into the electrical system? Check those connections too.
    #2
  3. WoodButcher

    WoodButcher Long timer

    Joined:
    Sep 17, 2004
    Oddometer:
    2,133
    Location:
    Austin, TX
    Does it charge in the car mount? If not, then it's the zumo for sure, but just on the contacts on the bottom. I'm assuming it used to work on the motorcycle and just suddenly stopped working? Or is this a different bike than normal? If it is a new hookup, check the polarity of the wires. You may have them reversed.
    #3
  4. levain

    levain STILL Jim Williams

    Joined:
    Oct 29, 2005
    Oddometer:
    7,641
    Location:
    Providence, RI
    Yeah. It's the zumo. bummer.
    #4
  5. JR356

    JR356 Long timer

    Joined:
    May 4, 2005
    Oddometer:
    4,094
    Location:
    Way out West
    Did you take the Zumo battery out and clean those contacts?

    JR356
    #5