05 12GS Throttle Cable Replacement Issue

Discussion in 'GS Boxers' started by Romet, Jul 25, 2020.

  1. Romet

    Romet Been here awhile

    Joined:
    Mar 18, 2014
    Oddometer:
    175
    Location:
    Chicago, Illinois, USA
    I just replaced a sticky throttle cable on my 2005 R1200GS according to manual. Now the bike isn’t running the same. Low RPMs on right cylinder. Adjusted the nuts near the throttle bodies. Now running too high or uneven. Any advice on proper adjustments? Thanks
    #1
  2. * SHAG *

    * SHAG * Unstable

    Joined:
    Nov 28, 2001
    Oddometer:
    5,652
    Location:
    Bradford, Pa
    Are the cables seated correctly?
    #2
    Romet likes this.
  3. * SHAG *

    * SHAG * Unstable

    Joined:
    Nov 28, 2001
    Oddometer:
    5,652
    Location:
    Bradford, Pa


    #3
    Romet likes this.
  4. Romet

    Romet Been here awhile

    Joined:
    Mar 18, 2014
    Oddometer:
    175
    Location:
    Chicago, Illinois, USA
    Yes they are. Thank you for asking.
    #4
  5. Romet

    Romet Been here awhile

    Joined:
    Mar 18, 2014
    Oddometer:
    175
    Location:
    Chicago, Illinois, USA
    Great videos. Thanks. It looks like I have to do throttle bodies synch now.
    #5
  6. ultane

    ultane sqeezin the bag

    Joined:
    Feb 20, 2008
    Oddometer:
    2,884
    Location:
    The dry side of the blood brain barrier
    Have you balance the throttle bodies?
    #6
  7. Romet

    Romet Been here awhile

    Joined:
    Mar 18, 2014
    Oddometer:
    175
    Location:
    Chicago, Illinois, USA
    I haven’t yet so that’s probably what I will have to do.
    #7
    ultane likes this.
  8. Romet

    Romet Been here awhile

    Joined:
    Mar 18, 2014
    Oddometer:
    175
    Location:
    Chicago, Illinois, USA
    Balanced the throttle bodies using Twinmax. Problem solved. Thanks to everyone for their help and input.
    #8
    Jim H, Callisto224 and ultane like this.