2006 gs1200 brake failure flashing lights

Discussion in 'GS Boxers' started by sergito, Jul 29, 2020.

  1. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    hi i got 06 gs1200 with the abs ( red triangle) and the brake failure light flashing really fast,i replaced the front abs sensor(it had a hole on it) and now the lights still flashing,not sure if i need the obd scanner to reset the codes?
    i tried the abs on off and nothing,also cable from the green-blue from the round obd plug to the negative to the battery and the abs button for 8 seconds.
    whats next???
    #1
  2. Desert Skies

    Desert Skies One brick shy...

    Joined:
    Mar 2, 2004
    Oddometer:
    2,613
    Location:
    Tejas
    Scan with GS911 to get fault code.
    #2
  3. lewisjr1

    lewisjr1 Long timer Supporter

    Joined:
    Sep 26, 2008
    Oddometer:
    5,707
    Location:
    DC metro
    Is the battery certain to be fully charged? And when was the brake fluid last thoroughly flushed?
    #3
  4. Lead Wrist

    Lead Wrist Mehr Gelände Weniger Straße

    Joined:
    May 26, 2007
    Oddometer:
    7,102
    Location:
    Zer0-Zer0-Zer0-Zer0
    If you don't have owner's manual, you should download one for free from the interwebs. The sequence and frequency of ABS brake lights flashes (if bike is equipped with ABS servo brakes) is explained during the self diagnosing so you first establish that there is an issue, if indeed it is the case...

    Then, in misfortunate case you'll have to deal with one, you can proceed with GS911 scanning reading the codes etc...
    #4
  5. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    12.45v unsure of brake flushed bout it used cheap like that with the lights
    #5
  6. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    kk gonna download it now and count the sequence thanksss
    #6
  7. b4thenite

    b4thenite Long timer

    Joined:
    Oct 14, 2008
    Oddometer:
    1,214
    Location:
    Korea Town, Los Angeles,
    Could be many things. Check all physical elements first. Brake lever, rear brake sensor, bulbs, etc.
    I had to replace small parts on brake lever once. When I dropped the bike the rear brake pedal was miss aligned and it resulted ABS sensor malfunction. Other times it was a bulb that needed to swap. Good luck and let us know.
    #7
  8. Chuck Roll

    Chuck Roll Lazy

    Joined:
    Feb 15, 2004
    Oddometer:
    4,180
    Location:
    Duvall, WA.
    When it happened on my 07 , a abs pump was the culprit , a rebuilt one fixed it .
    #8
  9. 0neTrackMind

    0neTrackMind Motorcycle Mechanic

    Joined:
    Apr 2, 2010
    Oddometer:
    33
    Location:
    Puget Sound
    2006 was a different animal. Power brakes. If bought cheap, there is likely deferred maintenance...

    OP needs to follow guidance above first.
    #9
  10. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    Hi,i just checked all fisical elements, back bulb works as it should,brake switches work too,i can hear the servo pump pretty loud tho,diferent sound for each brakes,how can i check the level on the main pump? Abs servo pump? Might need some oil there? Im borrowing an scanner tomorrow but not really sure what it is,i thought the broken ans sensor was the issue.
    #10
  11. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    Yeah bought it cheap coz of the lights flashing lol
    #11
  12. * SHAG *

    * SHAG * Unstable

    Joined:
    Nov 28, 2001
    Oddometer:
    5,652
    Location:
    Bradford, Pa
    Have you ridden the bike? Do the brakes work?
    #12
  13. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    Yeah drove the bike with the lights,it breaks ,
    #13
  14. postoak2112

    postoak2112 Javalina

    Joined:
    Jun 5, 2016
    Oddometer:
    55
    Location:
    Austin, Tx
    just make sure your break lever is fully releasing. i crashed my '06 and when i got her back up
    long story short the hand protector had shifted such that it wouldn't allow the break lever to fully release.
    good luck
    marty
    #14
  15. mouthfulloflake

    mouthfulloflake Not afraid

    Joined:
    Aug 21, 2008
    Oddometer:
    32,423
    Location:
    The Berkeley of Arkansas
    My 2005 did this off and on

    Brakes would work great
    Then not work

    Then sometimes drag and engage themselves

    I ripped that servo ABS junk off and
    Now the brakes work wonderfully
    #15
  16. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    Hi guys update, i borrowed the scanner and this happened lol deleted them and now i only have the fluid level coming up,i also got other codes for engine and the alarm system i deleted them tgey are not back for now,tomorrow i will flush the system and will get back to you guys,thanks for the help

    Attached Files:

    #16
  17. PerazziMx14

    PerazziMx14 Been here awhile

    Joined:
    Oct 9, 2011
    Oddometer:
    943
    I just bought an 05 last Monday knowing the idiot lights were illuminated. Got it home flushed the servo unit and the fronts were good rear Elias dead. Wednesday this is what was on the garage floor

    4AEDA9E6-901C-4B62-9B96-22E00A27016A.jpeg
    #17
    mouthfulloflake and sergito like this.
  18. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    Fixed???
    #18
  19. Lead Wrist

    Lead Wrist Mehr Gelände Weniger Straße

    Joined:
    May 26, 2007
    Oddometer:
    7,102
    Location:
    Zer0-Zer0-Zer0-Zer0
    Fixed as in removed and discarded...
    #19
  20. sergito

    sergito Adventurer

    Joined:
    Jul 29, 2020
    Oddometer:
    14
    Location:
    bc
    I saw u. An fix them on YouTube,
    #20