2007 R1200GS Starting problems post servicing.

Discussion in 'The Garage' started by Scottonthelam, Aug 21, 2019.

  1. Scottonthelam

    Scottonthelam n00b

    Joined:
    May 7, 2016
    Oddometer:
    5
    Location:
    Canada
    Hi all I'm looking for some suggestions, my bike was running fine until I had the ABS system bled. The tank has to come off to service the ABS system on this bike and ever since the service the bike only starts intermittently. Can anybody help?
    #1
  2. shovelstrokeed

    shovelstrokeed Long timer

    Joined:
    Jun 20, 2003
    Oddometer:
    5,707
    Location:
    6South Florida
    You will find much more information if you delete this post and pose the same question in the GSpot forum which is where GS folk hang out.
    #2
  3. Beezer

    Beezer Long timer Supporter

    Joined:
    Oct 26, 2004
    Oddometer:
    9,182
    Location:
    Anchorage, formerly Spenard (hub of the universe)
    1st thing is to check that the throttle cables are properly seated in the injector bodies
    #3
  4. Scottonthelam

    Scottonthelam n00b

    Joined:
    May 7, 2016
    Oddometer:
    5
    Location:
    Canada
    Thank you.
    #4
  5. Scottonthelam

    Scottonthelam n00b

    Joined:
    May 7, 2016
    Oddometer:
    5
    Location:
    Canada
    Thanks I’ll check that.
    #5
  6. VX Rider

    VX Rider Long timer

    Joined:
    Dec 11, 2015
    Oddometer:
    5,456
    Location:
    Phoenix
    Take tank off
    Verify all routing and connections are secure

    Start with tank off
    Verify operation

    Reinstall tank
    #6
  7. groop

    groop So much to ponder

    Joined:
    Jun 5, 2007
    Oddometer:
    5,956
    Location:
    oc, ca
    Also, the 2007 was subject to a fuel pump recall. Did the tech do the recall repair at the same time as the ABS since he had the tank off?
    #7
  8. H96669

    H96669 A proud pragmatist.

    Joined:
    Nov 20, 2009
    Oddometer:
    5,634
    Location:
    Hiding off Hwy 6, B.C.
    All that is saying is that you have never seen a 2005-07 BMW 1200GS fuel tank.

    Until they move this thread where it should be......maybe the OP could confirm that the fuel pump runs briefly to prime the fueling system when turning on the ignition.That is everytime the ignition is cycled On.No pump whirring everytime I'd think the FPC (fuel pump controller) is starting to act up and will fail shortly as many others have.
    #8