2009 RT ESA

Discussion in 'The Garage' started by Beemer Bob, Sep 6, 2019.

  1. Beemer Bob

    Beemer Bob Long timer

    Joined:
    Jun 30, 2009
    Oddometer:
    4,350
    Location:
    Beautiful Downtown WV
    Pushing the ESA button changes the mode from Comfort to Normal to Sport but when holding the button down to change the rate nothing happens. Any ideas?
    #1
  2. lkraus

    lkraus Long timer

    Joined:
    Dec 15, 2012
    Oddometer:
    1,056
    Location:
    Central Ohio
    Are you stopped, in neutral?
    #2
  3. Beemer Bob

    Beemer Bob Long timer

    Joined:
    Jun 30, 2009
    Oddometer:
    4,350
    Location:
    Beautiful Downtown WV
    Yes engine off ignition on.
    #3
  4. Jeffrop

    Jeffrop n00b

    Joined:
    Apr 22, 2018
    Oddometer:
    4
    Location:
    Marietta, GA 30062, United States
    I have same year and model. I have engine on, in neutral, hold down ESA for 5 seconds, then press and release button till desired setting shows. Icon should blink while being adjusted and goes solid when finished
    #4
  5. kasuckmo

    kasuckmo Been here awhile

    Joined:
    Jun 21, 2018
    Oddometer:
    252
    Location:
    fl
    When mine did the same it was a weak motor in the rear shock. Time to toss the esa or don’t worry about it. If your at 50k it’s new shock time anyway
    #5
  6. AviatorTroy

    AviatorTroy Long timer

    Joined:
    Oct 15, 2007
    Oddometer:
    2,282
    Location:
    Castle Rock, CO
    Not sure about the RT but my same year GS has to have the engine running and in neutral for that to work. The comfort norm sport thing works with engine off.
    #6
    mitchapalooza likes this.
  7. mitchapalooza

    mitchapalooza Rider is Air-cooled Supporter

    Joined:
    Sep 1, 2010
    Oddometer:
    352
    Location:
    Castle Rock, CO
    2009 gsa needs motor running to change stuff
    #7