790 Adventure Standard surge at low speeds

Discussion in 'Parallel World (790/890)' started by karmicgumbo, Jul 23, 2019.

  1. karmicgumbo

    karmicgumbo n00b

    Joined:
    Sep 3, 2009
    Oddometer:
    6
    A few days ago, I got stuck in slow moving traffic on a highway where they are widening the road, so there were construction delays and speeds 8-15 mph. I was in 1st gear and the bike couldn't run smoothly at a slow speed/rpm. Anything under 3500 rpm in 1st gear and the bike would lurch or surge. Below 1500 rpm, it felt like it wanted to stall. I only have 640 miles on the bike and it hasn't had its 620 mile service, but just wondering if anyone else has had a similar experience?

    thanks,

    karmicgumbo
    #1
    Rudy likes this.
  2. chippertheripper

    chippertheripper motorcycle junkie Supporter

    Joined:
    May 30, 2009
    Oddometer:
    10,231
    Location:
    s.e. mass
    Totally normal at low rpms.
    #2
  3. ettienne.scheepe

    ettienne.scheepe Adventurer

    Joined:
    Oct 18, 2016
    Oddometer:
    35
    Sounds like my 990
    #3
    mickd likes this.
  4. gearheadE30

    gearheadE30 @LC8Adventures Supporter

    Joined:
    Jan 20, 2012
    Oddometer:
    2,165
    Location:
    Indiana
    On an electronic throttle fuel injected bike tuned for emissions with a chain drive, I will also concur that it's probably normal. Putting it in rain mode to deaden the throttle response is probably the best you can do.
    #4
    TrailTrauma likes this.
  5. twinrider

    twinrider Pass the catnip

    Joined:
    Aug 20, 2002
    Oddometer:
    17,241
    Location:
    日本
    Sounds like it's tuned lean at those RPMs to pass emissions, pretty common these days across many makes. I flashed my S10 to get rid of the same issue. A booster plug can also be a cheap fix, used one of those on my AT. https://www.boosterplug.com/shop/boosterplug-ktm-790-805p.html
    #5