Beta RR /RS 4T enduro thread

Discussion in 'Thumpers' started by RICHXHELL, Feb 11, 2008.

  1. srelegante

    srelegante srelegante Supporter

    Joined:
    Apr 25, 2010
    Oddometer:
    471
    Location:
    Atlanta
    I will weigh in on this one, FWIW. I have found myself with a 2010 990 Adventure R and a 2019 Beta 500 RRS and these two "Book End" motorcycles cover the whole spectrum of needs, at least for me. I have done 4-5 day rides on the Beta, fully adventurized and just returned from doing the MABDR and the NEBDR on the 990.

    As much as I love the 690/701 series, unless you can ride out your back door to some great off road riding, it is my experience the "Book End" approach is the way to roll. If I lived in the country, wanted one bike, etc., then I would look at the 650+ displacement.

    YMMV

    :beer
    Twenty9 and AdamChandler like this.
  2. Carlos Thomas

    Carlos Thomas Fast not Furious

    Joined:
    Sep 5, 2015
    Oddometer:
    402
    Location:
    San Francisco, CA
    Agreed.
  3. AdamChandler

    AdamChandler Ascending n00b

    Joined:
    Feb 29, 2016
    Oddometer:
    8,249
    Location:
    Hanover, NH USA
    What are were you riding?
  4. Twenty9

    Twenty9 Adventurer

    Joined:
    Oct 31, 2019
    Oddometer:
    19
    Location:
    New England
    390...a tractor
    AdamChandler likes this.
  5. shortman

    shortman Beta 500 RS, X-Trainer 250 Supporter

    Joined:
    Jun 14, 2013
    Oddometer:
    1,592
    Location:
    Cumming Georgia
    @AdamChandler

    What happened to his post? I was trying to hit the like button and then it was gone? I can't believe the Mods would have yanked that. The video was great and the fall colors spectacular!
  6. AdamChandler

    AdamChandler Ascending n00b

    Joined:
    Feb 29, 2016
    Oddometer:
    8,249
    Location:
    Hanover, NH USA
    I’m sorry. I meant “where” not what. Looks like my backyard.I’m on the NH VT border.
  7. AdamChandler

    AdamChandler Ascending n00b

    Joined:
    Feb 29, 2016
    Oddometer:
    8,249
    Location:
    Hanover, NH USA
    I don’t know. Seems like a glitch in the matrix.
  8. Twenty9

    Twenty9 Adventurer

    Joined:
    Oct 31, 2019
    Oddometer:
    19
    Location:
    New England
    I can repost...although link seems to work in your reply...the video has text inserts that say where the riding is; central VT.
    AdamChandler likes this.
  9. Twenty9

    Twenty9 Adventurer

    Joined:
    Oct 31, 2019
    Oddometer:
    19
    Location:
    New England
    AdamChandler likes this.
  10. Twenty9

    Twenty9 Adventurer

    Joined:
    Oct 31, 2019
    Oddometer:
    19
    Location:
    New England
    Where are ya'll purchasing motul engine and transmission oil?
  11. shortman

    shortman Beta 500 RS, X-Trainer 250 Supporter

    Joined:
    Jun 14, 2013
    Oddometer:
    1,592
    Location:
    Cumming Georgia
    motosport.com
    Twenty9 likes this.
  12. NoelJ

    NoelJ Long timer

    Joined:
    Apr 7, 2016
    Oddometer:
    1,641
    Location:
    USA
    RMATV.

    AOMC on Labor Day when they have the big sale. They suck, but they're cheap that one time.
    Twenty9 likes this.
  13. NJ-Bill

    NJ-Bill Life is good Supporter

    Joined:
    Jun 11, 2005
    Oddometer:
    1,938
    Location:
    08003
    I have a Cycle Gear near my house and try to buy as much there as possible. It is nice having a place I can go when I need something now.
    Twenty9 and AdamChandler like this.
  14. AdamChandler

    AdamChandler Ascending n00b

    Joined:
    Feb 29, 2016
    Oddometer:
    8,249
    Location:
    Hanover, NH USA
    I would love a motorcycle store near me. We have an HD dealership but a local Moto mechanic just closed so only one non-HD Moto shop left that works on bikes within an hour drive. I guess wal mart sells oil but not Motul.
    Twenty9 likes this.
  15. NJ-Bill

    NJ-Bill Life is good Supporter

    Joined:
    Jun 11, 2005
    Oddometer:
    1,938
    Location:
    08003
    It is a side effect of living in the most densely populated state. Having ridden NH many times, I'd gladly swap locations with you and be without a Cycle Gear. :thumb
    AdamChandler likes this.
  16. AdamChandler

    AdamChandler Ascending n00b

    Joined:
    Feb 29, 2016
    Oddometer:
    8,249
    Location:
    Hanover, NH USA
    Yeah, I promise I wasn't humble bragging. point well taken.

    Here's my backyard:

    [​IMG]
    RyanC, NJ-Bill and rjnutt like this.
  17. H20ENG

    H20ENG n00b

    Joined:
    Sep 29, 2020
    Oddometer:
    5
    Location:
    NorCal
    Hello All,
    I had a 14' 520RS that never had a lick of trouble in 5500 miles. Absolutely loved that bike. I just bought a 19' 500 RR-S which I thought the factory had the electrical issues taken care of by this MY. I have low charging voltage and now the blinkers wont work. If I wiggle the wire harness at the neck of the frame I get one blink. Also when I cycle from left to right blinker, 1 blink. My turn indicator idiot light on the dash stays lit solid. My headlight, tail, brake light all work fine. Not sure if this could be a bad LED flasher or the ground wires inside the loom that everyone else seems to have issues with. I did notice the loom gets stretched tight when full lock left (another issue I thought was taken care of by this year).

    So 2 questions: How do I test the LED flasher? And how close to the frame neck are the grounds that need to be soldered in the harness?

    I do plan on adding a ground to the Reg/Rec and adding larger wires as others have done (Dan K.?)
    Thanks to all
  18. H20ENG

    H20ENG n00b

    Joined:
    Sep 29, 2020
    Oddometer:
    5
    Location:
    NorCal
    Hmm after charging all night blinkers work fine today. Time to dig into the harness I guess.
  19. Surfnjmatt

    Surfnjmatt Adventurer

    Joined:
    Sep 23, 2013
    Oddometer:
    96
    Location:
    ocean city NJ
    anyone have an idea why my F1 warning light on my 2015 350rr would be staying on? Bike still runs but worried ill do damage. closest dealer is 2.5 hours away so if its not something I need to worry about would be great
  20. Thunderbutt

    Thunderbutt Been here awhile

    Joined:
    Aug 16, 2016
    Oddometer:
    238
    Location:
    Clearwater, Fl & Hiawassee, Ga
    Have you checked the fuel line disconnect and also the electrical connections under your tank? I installed an IMS 3.0 gal tank on my '19 390 RR-S. Bike fired right up with the new. Tank but the F/I light stayed lite.
    Lifted the tank and discovered the plug for the rear fuel pump was not pushed in all the way. Was pushed in enough to make just enough contact to start and keep the engine running, but the light stayed on.
    Twenty9 and NJ-Bill like this.