BMW C400X / C400GT

Discussion in 'Battle Scooters' started by cabanza, Nov 6, 2017.

  1. JimInOz

    JimInOz Adventurer

    Joined:
    Sep 13, 2018
    Oddometer:
    61
    Location:
    Melbourne AU
    Because there is SFA in the user manual about what fuse is what, you can just pull the supplementary fuses and see if any have popped.

    If they're all OK I suggest a dealer visit is in order.

    It's a real PITA not being able to locate a service manual, or even a wiring diagram for these models :baldy.
    Soaime likes this.
  2. Soaime

    Soaime Adventurer

    Joined:
    Aug 16, 2019
    Oddometer:
    12
    Location:
    Bucharest
    I talked to the BMW dealership and they told me to bring it in even though the grip worked after another test. I hope they'll check the wiring and maybe get an firmware update for the tft as i keep getting problems with helmet connection (bmw fit for all) once every 3-4 times i start the thing even if i keep the helmet on at all times and the phone bluetooth on
  3. Throttlejunkie

    Throttlejunkie Adventurer

    Joined:
    Apr 3, 2008
    Oddometer:
    15
    Location:
    SWEDEN
    Your dealer will connect their OBD reader (self diagnostic tool) and see if they getting any errors.
    Please tell us if there is a Firmware update available.
    Good luck!
    Soaime likes this.
  4. Oilhed

    Oilhed MarkF Supporter

    Joined:
    Oct 17, 2003
    Oddometer:
    13,048
    Location:
    Connecticut
    I'd be willing to swing a deal with my trade-in now (no winter storage) and financing (no payments til after delivery)!!!

    $2000 0ff a brand new $8000 scooter? Wonder what the out the door price is!
  5. Soaime

    Soaime Adventurer

    Joined:
    Aug 16, 2019
    Oddometer:
    12
    Location:
    Bucharest
    So i got good news, there is a software update for my TFT display which was running S/W Version: 001_019_180 (i'm from Europe btw). They said that the update is done online via the bmw server in Germany and it takes a couple of hours.

    About the left heated grip i forgot to mention that after that morning that it did not work i tried it again and it worked ok so they did not find anything wrong with it but they are checking the cables and connectors.

    There were some guys here that had the engine stop while coasting problem which, unfortunately, happened to me also, 2 times. GOOD news is that they had encountered this problem before and they told me they can fix it by changing some air nozzles for the air-box. So these will be available in a couple of weeks but i'll get to change them only next year as the weather is getting worse here were i am and i won't be able to ride until march next year; so when i'll get the 1200km service next year i will get the changed.
    I'll try to find the code for these supposed nozzles and put it here.
    [​IMG]
    Also, am selling my 2017 Kawasaki Z900 if anyone in Europe is interested :(
    Throttlejunkie likes this.
  6. Soaime

    Soaime Adventurer

    Joined:
    Aug 16, 2019
    Oddometer:
    12
    Location:
    Bucharest
    So they did not find anything with the left grip, they checked the cables and also tried another grip. Software version is the same but they said that they updated other parts (maybe the ecu, i don't know). Here is the stalling problem as BMW sees it:
    bmw sheet.png
    byee and beRto. like this.
  7. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    My BMW dealer swung by this morning to pickup my BMW C400GT to get an oil change as well as getting the brake caliper recall addressed.

    Once everything is done, they’re going to drop it off at my house.

    ....this door to door service is FREE! I’m glad I bought a BMW!
  8. Soaime

    Soaime Adventurer

    Joined:
    Aug 16, 2019
    Oddometer:
    12
    Location:
    Bucharest
    Hey guys, what do you do with the battery during the winter? i keep my scooter in my backyard under a roof and two lateral walls and i also use a waterproof cover; i don't have the possibility to put a charger on it since i don't have a power supply nearby so i think it should be better to disconnect the cables, what's your advice?
  9. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    I typically connect my CTEK MULTI US battery charger to the bike during the winter months.

    You can always run an extension cord to the bike.
  10. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    I’ve received confirmation from BMW they will be replacing the 3 brake calipers kn my C400GT.

    Replacement parts are on order and should arrive in a week or do.

    Here’s a copy of the Canadian BMW recall notice.

    Adjustments.jpg Adjustments.jpg
    The Virginian likes this.
  11. greg531

    greg531 greg531

    Joined:
    Jan 6, 2013
    Oddometer:
    136
    Location:
    Grand Pothole Rapids, Michigan
  12. Jwspoonsan

    Jwspoonsan n00b

    Joined:
    Jun 20, 2019
    Oddometer:
    2
    Location:
    Memphis, TN USA
  13. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    Please share photos of your C400X with the taller windscreen.

    Thank you!
    Throttlejunkie likes this.
  14. Jwspoonsan

    Jwspoonsan n00b

    Joined:
    Jun 20, 2019
    Oddometer:
    2
    Location:
    Memphis, TN USA
    The first photo is my 400x with the original screen. The other 3 are the BMW tall screen. The tall reduces buffeting above 50 mph for me.

    Attached Files:

    The Virginian, byee and zmanH2 like this.
  15. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    Very nice! Now the windscreen is functional. I’m not sure why BMW provided the small windscreen. Lots of owners will replace it like yourself.

    Thank you for posting the photos.
  16. kantuckid

    kantuckid Long timer

    Joined:
    Nov 29, 2007
    Oddometer:
    9,018
    Location:
    Kentucky-Eastern that is!
    Per the MN deal linked above, commonly seen on Cycle Trader are less than informative dealer ads that don't include what are often significant dealer "admin fees", actually is more the rule than not, plus some advertised price points will also not include freight which we all must pay on any new wheels. My guess is it's not such a great deal but a common deal.
  17. Furrrr

    Furrrr n00b

    Joined:
    Dec 6, 2019
    Oddometer:
    8
    Location:
    Amsterdam
    Hi,

    Im new here, im from the Netherland and own a C400GT.

    I just bought a Schuberth C4 pro with SC1 advanced communication system. The system connects to the connectivity display without any problems. Only yhe contacts from my iPhone 11 pro with latest firmware wont load in the display.

    Anyone with the same issues?
  18. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    I don’t have your particular combo.

    Make sure there is no Bluetooth connection created from your helmet communications to your phone.

    Your iPhone should have a Bluetooth connection to the TFT on your C400GT. Create a Bluetooth connection from your TFT to your helmet communications.

    This should fix your problem. Good luck.
  19. Furrrr

    Furrrr n00b

    Joined:
    Dec 6, 2019
    Oddometer:
    8
    Location:
    Amsterdam
    Thanks for the fast reply!
    Tried your method, but no succes. Everything works but no contacts list.
  20. byee

    byee Long timer

    Joined:
    Sep 15, 2016
    Oddometer:
    2,074
    Location:
    Vancouver, BC
    Please confirm the following on your iPhone

    Go to settings
    Privacy
    Contacts
    Connected <— confirm it’s on

    If it’s on, turn if off. Connect to the TFT....then turn it back on again.